summaryrefslogtreecommitdiffstats
path: root/testing/asunder
diff options
context:
space:
mode:
Diffstat (limited to 'testing/asunder')
-rw-r--r--testing/asunder/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/asunder/APKBUILD b/testing/asunder/APKBUILD
new file mode 100644
index 000000000..5f715dac2
--- /dev/null
+++ b/testing/asunder/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=asunder
+pkgver=2.1
+pkgrel=0
+pkgdesc="A graphical Audio CD ripper and encoder"
+url="http://littlesvr.ca/asunder"
+arch="all"
+license="GPLv2"
+depends="cdparanoia"
+makedepends="libcddb-dev gtk+-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://littlesvr.ca/asunder/releases/asunder-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/asunder-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="05419a29fd31321f0823c3f90ee1b911 asunder-2.1.tar.bz2"