summaryrefslogtreecommitdiffstats
path: root/testing/dhex
diff options
context:
space:
mode:
Diffstat (limited to 'testing/dhex')
-rw-r--r--testing/dhex/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/testing/dhex/APKBUILD b/testing/dhex/APKBUILD
index d205c4784..5f6fb193d 100644
--- a/testing/dhex/APKBUILD
+++ b/testing/dhex/APKBUILD
@@ -1,20 +1,20 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dhex
-pkgver=0.66
+pkgver=0.67
pkgrel=0
pkgdesc="Ncurses hex editor"
url="http://www.dettus.net/dhex/"
arch="all"
-license="GPL"
+license="GPL2+"
depends=""
makedepends="ncurses-dev"
install=""
subpackages="$pkgname-doc"
-source="http://www.dettus.net/dhex/dhex_0.66.tar.gz
- makefile.patch"
-
+source="http://www.dettus.net/dhex/dhex_$pkgver.tar.gz
+ makefile.patch"
_builddir="$srcdir"/dhex_$pkgver
+
prepare() {
local i
cd "$_builddir"
@@ -27,15 +27,15 @@ prepare() {
build() {
cd "$_builddir"
- make
+ make || return 1
}
package() {
cd "$_builddir"
make install DESTDIR="$pkgdir" \
mandir=/usr/share/man \
- prefix=/usr/bin
+ prefix=/usr/bin || return 1
}
-md5sums="304a91cfd9481b2ddf418f3a943190e1 dhex_0.66.tar.gz
+md5sums="46d24d11b6e389509fff07404aedabb6 dhex_0.67.tar.gz
de16e09d3b416650d84ef39235cd2917 makefile.patch"