summaryrefslogtreecommitdiffstats
path: root/testing/ipt-netflow-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ipt-netflow-grsec/APKBUILD')
-rw-r--r--testing/ipt-netflow-grsec/APKBUILD79
1 files changed, 0 insertions, 79 deletions
diff --git a/testing/ipt-netflow-grsec/APKBUILD b/testing/ipt-netflow-grsec/APKBUILD
deleted file mode 100644
index 2cb30954b..000000000
--- a/testing/ipt-netflow-grsec/APKBUILD
+++ /dev/null
@@ -1,79 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
-_flavor=grsec
-_kpkg=linux-$_flavor
-_kver=3.10.23
-_kpkgrel=0
-
-# when chaning _ver we *must* bump _mypkgrel
-_ver=1.8.4
-
-_mypkgrel=0
-
-# verify the kernel version before entering chroot
-if [ -f ../linux-${_flavor}/APKBUILD ]; then
- . ../linux-${_flavor}/APKBUILD
- pkgname=ipt-netflow-${_flavor}
- [ "$_kver" != "$pkgver" ] && die "please update _kver to $pkgver"
- [ "$_kpkgrel" != "$pkgrel" ] && die "please update _kpkgrel to $pkgrel"
-fi
-
-_kpkgver="$_kver-r$_kpkgrel"
-_abi_release=${_kver}-${_kpkgrel}-${_flavor}
-
-pkgname=ipt-netflow-${_flavor}
-pkgver=$_kver
-
-pkgrel=$(( $_kpkgrel + $_mypkgrel ))
-pkgdesc="Linux kernel netflow sensor module"
-url="http://ipt-netflow.sourceforge.net/"
-arch="all"
-license=GPL3+
-source="ipt-netflow-$_ver.tar.gz::https://github.com/RushOnline/ipt-netflow/archive/v$_ver.tar.gz
- 0001-Fix-compilation-with-3.9.y-kernel.patch
- 0001-Fix-compilation-with-3.10.y-kernel.patch
- constify.patch"
-depends="$_kpkg-dev=$_kpkgver"
-makedepends="linux-${_flavor}-dev=$_kpkgver iptables-dev bash"
-install_if="$_kpkg=$_kpkgver ipt-netflow"
-
-_builddir="$srcdir"/ipt-netflow-$_ver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --kver=$_abi_release \
- --ipt-inc=/usr/include/libiptc \
- || return 1
- make ipt_NETFLOW.ko || return 1
-}
-
-package() {
- cd "$_builddir"
- make -j1 minstall DESTDIR="$pkgdir" || return 1
-}
-
-# override dev() from kernel's APKBUILD
-dev() {
- default_dev
-}
-
-md5sums="a5d564dd5f30d5b61a93decf29e3a208 ipt-netflow-1.8.4.tar.gz
-b300776001b3cc8448ec4019ac9e3b2e 0001-Fix-compilation-with-3.9.y-kernel.patch
-ba1be5dd6b61bb78c9bf2e4c4fbf7341 0001-Fix-compilation-with-3.10.y-kernel.patch
-2d9335c3d5c32c1e18a67fbb83018bae constify.patch"
-sha256sums="bb2446a0b16aa7f6052599410c2b4ce184d40893ec2ca12756f3bcb341890f43 ipt-netflow-1.8.4.tar.gz
-f1f5d33c4f000e22c34a954856ef7d23c24106465c61209c0267f76c7d49011b 0001-Fix-compilation-with-3.9.y-kernel.patch
-f76a4a43f66d05639617b56a4c6e90c373f93548130456484c27206516784d90 0001-Fix-compilation-with-3.10.y-kernel.patch
-5a86c64bdc536bddb780ebaa4aa5fe3bede93d645ed0f00afb41f23314662d1f constify.patch"
-sha512sums="e15ad33b4b3df9e1e53fbac6334dbe08802d66f4850cbf489d7a60184cdb47d94448ae13480d586474a6bec6204680d059543b619ae40a0f74fad22fed1b024a ipt-netflow-1.8.4.tar.gz
-ae42d882ff10f4f8062ca4e2ad9cb2b5bfd05dfde829ffa23b683ee9dcb9aa9063b391171e07f61f6d0d158f1c35e381236e625b7ecaf8192fc6c5964acb6bb8 0001-Fix-compilation-with-3.9.y-kernel.patch
-c0466a9d96eaa5879ac4267de5c44aa8e64bc3f4712fbb28e2f700fc3615980eccff95487689d1356393c9b1ceb1fe75cfabbdaf1b616be7eeb4337f3b9f0092 0001-Fix-compilation-with-3.10.y-kernel.patch
-08835d3de5925d868b70c240e65094a9262c5871d7ca0290001697cf8b7cee74bfc8ac2897b30c3d5ec89700b329d30b539699596f15c1150e18a85234484758 constify.patch"