summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/xarchiver/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/xarchiver/APKBUILD b/x11/xarchiver/APKBUILD
new file mode 100644
index 000000000..0ed45971e
--- /dev/null
+++ b/x11/xarchiver/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xarchiver
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="GTK+ frontend to various command line archivers"
+url="http://xarchiver.xfce.org/"
+license="GPL"
+depends="desktop-file-utils hicolor-icon-theme tar"
+makedepends="intltool gtk+-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/xarchiver-$pkgver"
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/xfce4 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/xarchiver-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="2bc7f06403cc6582dd4a8029ec9d038d xarchiver-0.5.2.tar.bz2"