summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-21 09:45:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-21 09:45:50 +0000
commit1a95628a8e6b6add612ca15905e2395c93d9b187 (patch)
tree08ce24f813ae4531572e7b31388ba367fc143cd3
parent57badfc9c28f37a6d7c99a0627e93151509c800e (diff)
parentc2f77481f457b72ca891953095c2a545550f75f1 (diff)
downloadaports-1a95628a8e6b6add612ca15905e2395c93d9b187.tar.bz2
aports-1a95628a8e6b6add612ca15905e2395c93d9b187.tar.xz
Merge remote branch 'clandmeter/master'
-rw-r--r--main/abuild/APKBUILD6
-rw-r--r--main/abuild/gawk.patch22
-rw-r--r--main/alpine-base/APKBUILD3
-rw-r--r--main/bkeymaps/APKBUILD2
-rw-r--r--main/build-base/APKBUILD8
-rw-r--r--main/enca/APKBUILD40
-rw-r--r--main/faac/APKBUILD13
-rw-r--r--main/gcc/APKBUILD28
-rw-r--r--main/glew/APKBUILD32
-rw-r--r--main/libass/APKBUILD35
-rw-r--r--main/libbluray/APKBUILD36
-rw-r--r--main/libcddb/APKBUILD36
-rw-r--r--main/libcdio/APKBUILD38
-rw-r--r--main/libiconv/APKBUILD20
-rw-r--r--main/libmicrohttpd/APKBUILD44
-rw-r--r--main/libmms/APKBUILD40
-rw-r--r--main/libmms/libmms-0.5-this-keyword.patch18
-rw-r--r--main/libmodplug/APKBUILD37
-rw-r--r--main/libssh/APKBUILD36
-rw-r--r--main/libvdpau/APKBUILD38
-rw-r--r--main/linux-headers/APKBUILD8
-rw-r--r--main/rtmpdump/APKBUILD32
-rw-r--r--main/sdl_image/APKBUILD36
-rw-r--r--main/sdl_mixer/APKBUILD39
-rw-r--r--main/wavpack/APKBUILD40
25 files changed, 663 insertions, 24 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 133aa3497..1c8de49c5 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,10 +2,11 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.5
-pkgrel=1
+pkgrel=2
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
0001-abuild-automatically-add-libgcc-to-depends-when-libp.patch
+ gawk.patch
"
depends="fakeroot file sudo pax-utils openssl apk-tools"
makedepends="openssl-dev pkgconfig"
@@ -35,4 +36,5 @@ package() {
}
md5sums="2173f4775cb2672661cfc3de55c8450e abuild-2.5.tar.bz2
-ce8a7d262d3a341faed0b67c5c894225 0001-abuild-automatically-add-libgcc-to-depends-when-libp.patch"
+ce8a7d262d3a341faed0b67c5c894225 0001-abuild-automatically-add-libgcc-to-depends-when-libp.patch
+7131a1eb6cbc03a2ec70da91be0d16c4 gawk.patch"
diff --git a/main/abuild/gawk.patch b/main/abuild/gawk.patch
new file mode 100644
index 000000000..f0d0e2ed7
--- /dev/null
+++ b/main/abuild/gawk.patch
@@ -0,0 +1,22 @@
+From a5937e5c4590e806832d880b132c7b364b03e3cc Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 27 Aug 2010 13:34:33 +0000
+Subject: abuild: support for alternative awks
+
+some awk's does not understand -F "\ " and treats that as special space
+---
+diff --git a/abuild.in b/abuild.in
+index fbfee57..24920d5 100755
+--- a/abuild.in
++++ b/abuild.in
+@@ -453,7 +453,7 @@ prepare_tracedeps() {
+ options_has "!tracedeps" && return 0
+ find -name '*.so' -o -name '*.so.[0-9]*' | sed 's:.*/::' \
+ >"$controldir"/.provides-so
+- scanelf -Rn "$dir" | awk -F "\ " '$1 == "ET_DYN" || $1 == "ET_EXEC" {print $2}' \
++ scanelf -Rn "$dir" | tr ' ' ':' | awk -F ":" '$1 == "ET_DYN" || $1 == "ET_EXEC" {print $2}' \
+ | sed 's:,:\n:g' | sort | uniq \
+ | while read i; do
+ # only add files that are not self provided
+--
+cgit v0.8.3.1
diff --git a/main/alpine-base/APKBUILD b/main/alpine-base/APKBUILD
index af0cc4561..71145e19a 100644
--- a/main/alpine-base/APKBUILD
+++ b/main/alpine-base/APKBUILD
@@ -7,7 +7,8 @@ pkgdesc="Meta package for minimal alpine base"
url="http://alpinelinux.org"
license="GPL"
depends="alpine-baselayout alpine-conf apk-tools busybox busybox-initscripts
- openrc uclibc-utils bbsuid"
+ openrc bbsuid"
+[ "$ALPINE_LIBC" != "eglibc" ] && depends="$depends uclibc-utils"
makedepends=
install=
subpackages=
diff --git a/main/bkeymaps/APKBUILD b/main/bkeymaps/APKBUILD
index 416b9811c..0534e3f0e 100644
--- a/main/bkeymaps/APKBUILD
+++ b/main/bkeymaps/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Binary keymaps for busybox"
url="http://dev.alpinelinux.org/alpine/bkeymaps"
license="GPL"
depends="busybox"
-source="http://dev.alpinelinux.org/alpine/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://dev.alpinelinux.org/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
cd "$srcdir"/$pkgname-$pkgver
diff --git a/main/build-base/APKBUILD b/main/build-base/APKBUILD
index 59e1f2ee5..c68cc86b5 100644
--- a/main/build-base/APKBUILD
+++ b/main/build-base/APKBUILD
@@ -1,10 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=build-base
pkgver=0.2
-pkgrel=0
+pkgrel=1
url=http://dev.alpinelinux.org/cgit
pkgdesc="Meta package for build base"
-depends="binutils gcc make patch uclibc-dev g++"
+if [ "$ALPINE_LIBC" = "eglibc" ]; then
+ depends="binutils gcc make patch eglibc-dev g++"
+else
+ depends="binutils gcc make patch uclibc-dev g++"
+fi
license=none
build() {
diff --git a/main/enca/APKBUILD b/main/enca/APKBUILD
new file mode 100644
index 000000000..bac568143
--- /dev/null
+++ b/main/enca/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=enca
+pkgver=1.13
+pkgrel=0
+pkgdesc="Charset analyser and converter"
+url="http://freshmeat.net/projects/enca/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dl.cihar.com/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --enable-external \
+ --without-libiconv
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="762bead5d9a0a5e55024e1102baaa89d enca-1.13.tar.bz2"
diff --git a/main/faac/APKBUILD b/main/faac/APKBUILD
index 55fa0a006..1e196aac4 100644
--- a/main/faac/APKBUILD
+++ b/main/faac/APKBUILD
@@ -1,14 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=faac
pkgver=1.28
-pkgrel=4
+pkgrel=5
pkgdesc="FAAC is an AAC audio encoder."
url="http://www.audiocoding.com/"
license="GPL custom"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends="autoconf automake libtool"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+"
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ #taken from http://bugs.sourcemage.org/show_bug.cgi?id=15263
+ [ "$ALPINE_LIBC" = "eglibc" ] && sed -i \
+ "s/^\(.*strcasestr\)/\/\/ This is in libc and conflicts: \1 /" \
+ common/mp4v2/mpeg4ip.h
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 5dc287321..e4d64eca1 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -5,8 +5,16 @@ _pv=4.4.2
_specsver=0.1.7
_espfver=0.3.6
_uclibc_abiver=0.9.32
-
-pkgrel=4
+if [ "$ALPINE_LIBC" = "eglibc" ]; then
+ _chost="i686-pc-linux-gnu"
+ _with_arch="i686"
+else
+ _chost="i486-alpine-linux-uclibc"
+ _dynamic_linker="--with-dynamic-linker=ld-uClibc.so.$_uclibc_abiver"
+ _with_arch="i486"
+fi
+
+pkgrel=5
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
@@ -16,8 +24,8 @@ subpackages="$pkgname-doc libstdc++:libcxx g++:gpp libgcc libgomp objc"
source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-g++-$pkgver.tar.bz2
ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-objc-$pkgver.tar.bz2
- http://weaver.gentooenterprise.com/hardened/patches/gcc-$_pv-espf-$_espfver.tar.bz2
- http://weaver.gentooenterprise.com/hardened/patches/gcc-$_pv-specs-$_specsver.tar.bz2
+ http://build.alpinelinux.org:8010/distfiles/gcc-$_pv-espf-$_espfver.tar.bz2
+ http://build.alpinelinux.org:8010/distfiles/gcc-$_pv-specs-$_specsver.tar.bz2
gcc-spec-env.patch
pt_gnu_eh_frame.patch
uclibc-getipinfo.patch
@@ -50,7 +58,9 @@ build ()
../configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --build=${CHOST:-i486-alpine-linux-uclibc} \
+ --build=${CHOST:-$_chost} \
+ --host=${CHOST:-$_chost} \
+ --target=${CHOST:-$_chost} \
--disable-altivec \
--disable-checking \
--disable-fixed-point \
@@ -68,10 +78,12 @@ build ()
--enable-tls \
--enable-threads \
--with-arch=i486 \
- --with-dynamic-linker=ld-uClibc.so.$_uclibc_abiver \
+ $_with_arch \
+ $_dynamic_linker \
--with-dynamic-linker-prefix=/lib \
--with-system-zlib \
- --without-system-libunwind
+ --without-system-libunwind
+
make || return 1
}
@@ -102,7 +114,7 @@ libcxx() {
gpp() {
pkgdesc="GNU C++ standard library and compiler"
depends="libstdc++"
- local libexec=usr/libexec/gcc/${CHOST:-i486-alpine-linux-uclibc}/$pkgver
+ local libexec=usr/libexec/gcc/${CHOST:-$_chost}/$pkgver
mkdir -p "$subpkgdir/$libexec" \
"$subpkgdir"/usr/bin \
"$subpkgdir"/usr/include \
diff --git a/main/glew/APKBUILD b/main/glew/APKBUILD
new file mode 100644
index 000000000..a6d1b1a8e
--- /dev/null
+++ b/main/glew/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=glew
+pkgver=1.5.5
+pkgrel=0
+pkgdesc="A cross-platform C/C++ extension loading library"
+url="http://glew.sourceforge.net"
+license="GPL"
+depends=
+makedepends="libxmu-dev libxi-dev mesa-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i 's|lib64|lib|' config/Makefile.linux || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make GLEW_DEST="${pkgdir}/usr" install
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+md5sums="3621f27cfd3e33d5dbcc1111ecb5b762 glew-1.5.5.tgz"
diff --git a/main/libass/APKBUILD b/main/libass/APKBUILD
new file mode 100644
index 000000000..2d0012426
--- /dev/null
+++ b/main/libass/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libass
+pkgver=0.9.11
+pkgrel=0
+pkgdesc="A portable library for SSA/ASS subtitles rendering"
+url="http://code.google.com/p/libass/"
+license="GPL"
+depends=""
+makedepends="pkgconfig enca-dev fontconfig-dev libpng-dev"
+subpackages="$pkgname-dev"
+source="http://libass.googlecode.com/files/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="f9042884397002ba40aa89dc7d34f59f libass-0.9.11.tar.bz2"
diff --git a/main/libbluray/APKBUILD b/main/libbluray/APKBUILD
new file mode 100644
index 000000000..85ebd4d80
--- /dev/null
+++ b/main/libbluray/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libbluray
+pkgver=20100902
+pkgrel=0
+pkgdesc="Blu-ray playback libraries"
+url="http://git.videolan.org/?p=libbluray.git;a=summary"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev"
+source="http://alpine.nethq.org/distfiles/libbluray-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="c9ba7a906f5071affc347a6024f174d9 libbluray-20100902.tar.bz2"
diff --git a/main/libcddb/APKBUILD b/main/libcddb/APKBUILD
new file mode 100644
index 000000000..52ca9022a
--- /dev/null
+++ b/main/libcddb/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libcddb
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Library that implements the different protocols (CDDBP, HTTP, SMTP) to access data on a CDDB server (e.g. http://freedb.org)."
+url="http://sourceforge.net/projects/libcddb/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="8bb4a6f542197e8e9648ae597cd6bc8a libcddb-1.3.2.tar.bz2"
diff --git a/main/libcdio/APKBUILD b/main/libcdio/APKBUILD
new file mode 100644
index 000000000..dc7fbaa0d
--- /dev/null
+++ b/main/libcdio/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libcdio
+pkgver=0.82
+pkgrel=0
+pkgdesc="GNU Compact Disc Input and Control Library"
+url="http://www.gnu.org/software/libcdio/"
+license="GPL3"
+depends=
+makedepends="libcddb-dev ncurses-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnu.org/gnu/libcdio/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-vcd-info \
+ --enable-cpp-progs
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+md5sums="1c29b18e01ab2b966162bc727bf3c360 libcdio-0.82.tar.gz"
diff --git a/main/libiconv/APKBUILD b/main/libiconv/APKBUILD
index f53a01996..21bf1ef17 100644
--- a/main/libiconv/APKBUILD
+++ b/main/libiconv/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=libiconv
pkgver=1.12
-pkgrel=3
+pkgrel=4
pkgdesc="GNU charset conversion library for libc which doesn't implement it"
url="http://www.gnu.org/software/libiconv"
license='LGPL'
@@ -11,15 +11,23 @@ subpackages="$pkgname-doc $pkgname-dev"
build() {
cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --mandir=/usr/share/man
- make || return 1
+ #only build if we need it
+ if [ "$ALPINE_LIBC" != "eglibc" ]; then
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man
+ make || return 1
+ fi
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ #if we use eglibc we install dummy libiconv
+ if [ "$ALPINE_LIBC" = "eglibc" ]; then
+ mkdir -p "$pkgdir"/usr/include "$pkgdir"/usr/share/doc
+ else
+ make DESTDIR="$pkgdir/" install
+ fi
}
+
md5sums="c2be282595751535a618ae0edeb8f648 libiconv-1.12.tar.gz"
diff --git a/main/libmicrohttpd/APKBUILD b/main/libmicrohttpd/APKBUILD
new file mode 100644
index 000000000..3c5fb9da0
--- /dev/null
+++ b/main/libmicrohttpd/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libmicrohttpd
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="a small C library that is supposed to make it easy to run an HTTP server as part of another application."
+url="http://www.gnu.org/software/libmicrohttpd/"
+license="GPL"
+depends=
+makedepends="curl-dev libgcrypt-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/libmicrohttpd/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-largefile \
+ --enable-curl \
+ --enable-messages
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/src/include/platform.h \
+ ${pkgdir}/usr/include/platform.h
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/src/include/plibc.h \
+ ${pkgdir}/usr/include/plibc.h
+}
+
+md5sums="9c0d681ee88cdbe332919e102ad27953 libmicrohttpd-0.9.0.tar.gz"
diff --git a/main/libmms/APKBUILD b/main/libmms/APKBUILD
new file mode 100644
index 000000000..0a133834f
--- /dev/null
+++ b/main/libmms/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libmms
+pkgver=0.6
+pkgrel=0
+pkgdesc="MMS stream protocol library"
+url="http://sourceforge.net/projects/libmms/"
+license="LGPL"
+depends=
+makedepends="pkgconfig glib-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ libmms-0.5-this-keyword.patch
+"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/libmms-0.5-this-keyword.patch || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="650ad04a4c8bd79246390b81b29680b6 libmms-0.6.tar.gz
+5266259060f5723d8ee639b8a541f835 libmms-0.5-this-keyword.patch"
diff --git a/main/libmms/libmms-0.5-this-keyword.patch b/main/libmms/libmms-0.5-this-keyword.patch
new file mode 100644
index 000000000..9d5ae762e
--- /dev/null
+++ b/main/libmms/libmms-0.5-this-keyword.patch
@@ -0,0 +1,18 @@
+diff -Nurp libmms-0.5.orig//src/mmsx.h libmms-0.5//src/mmsx.h
+--- libmms-0.5.orig//src/mmsx.h 2010-03-03 11:42:14.000000000 +0100
++++ libmms-0.5//src/mmsx.h 2010-03-03 11:42:46.000000000 +0100
+@@ -55,11 +55,11 @@ int mmsx_peek_header (mmsx_t *inst
+
+ mms_off_t mmsx_get_current_pos (mmsx_t *instance);
+
+-uint32_t mmsx_get_asf_header_len (mmsx_t *this);
++uint32_t mmsx_get_asf_header_len (mmsx_t *instance);
+
+-uint64_t mmsx_get_asf_packet_len (mmsx_t *this);
++uint64_t mmsx_get_asf_packet_len (mmsx_t *instance);
+
+-int mmsx_get_seekable (mmsx_t *this);
++int mmsx_get_seekable (mmsx_t *instance);
+
+ #ifdef __cplusplus
+ }
diff --git a/main/libmodplug/APKBUILD b/main/libmodplug/APKBUILD
new file mode 100644
index 000000000..931c1e1f0
--- /dev/null
+++ b/main/libmodplug/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libmodplug
+pkgver=0.8.8.1
+pkgrel=0
+pkgdesc="A MOD playing library"
+url="http://modplug-xmms.sourceforge.net/"
+license="custom"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/modplug-xmms/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+md5sums="f7fa53a60c650024ff51cca88341776b libmodplug-0.8.8.1.tar.gz"
diff --git a/main/libssh/APKBUILD b/main/libssh/APKBUILD
new file mode 100644
index 000000000..0d40683ad
--- /dev/null
+++ b/main/libssh/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libssh
+pkgver=0.4.5
+pkgrel=0
+pkgdesc="Library for accessing ssh client services through C libraries"
+url="http://www.libssh.org/"
+license="LGPL"
+depends=
+makedepends="openssl-dev cmake"
+subpackages="$pkgname-dev"
+source="http://www.libssh.org/files/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$srcdir"
+
+ mkdir build && cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="156bf2402f3251b50b15fe8598c9031d libssh-0.4.5.tar.gz"
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
new file mode 100644
index 000000000..b38a2d42f
--- /dev/null
+++ b/main/libvdpau/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=libvdpau
+pkgver=0.4
+pkgrel=0
+pkgdesc="Nvidia VDPAU library"
+url="http://cgit.freedesktop.org/~aplattner/libvdpau"
+license="custom"
+depends=
+makedepends="libx11-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}
+
+md5sums="06da6f81ad37708b33a20ed177a44d81 libvdpau-0.4.tar.gz"
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index 272d63ce0..d4db2d3d3 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -2,12 +2,16 @@
pkgname=linux-headers
pkgver=2.6.32.2
_kernver=2.6.32
-pkgrel=2
+pkgrel=3
pkgdesc="Linux system headers"
url="http://kernel.org"
license='GPL-2'
makedepends="perl"
-replaces="uclibc-dev"
+if [ "$ALPINE_LIBC" = "eglibc" ]; then
+ replaces="eglibc-dev"
+else
+ replaces="uclibc-dev"
+fi
options="!strip !tracedeps"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
diff --git a/main/rtmpdump/APKBUILD b/main/rtmpdump/APKBUILD
new file mode 100644
index 000000000..df8558728
--- /dev/null
+++ b/main/rtmpdump/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Carlo Landmetere
+# Maintainer:
+pkgname=rtmpdump
+pkgver=2.3
+pkgrel=0
+pkgdesc="A tool to download rtmp:// and rtmpe:// streams"
+url="http://rtmpdump.mplayerhq.hu/"
+license="GPL"
+depends=
+makedepends="openssl-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://mirrors.kernel.org/gentoo/distfiles/$pkgname-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i 's/^install_so.0:.*/& install_base/' librtmp/Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make prefix=/usr MANDIR="$pkgdir/usr/share/man" DESTDIR="$pkgdir" install
+
+}
+
+md5sums="eb961f31cd55f0acf5aad1a7b900ef59 rtmpdump-2.3.tgz"
diff --git a/main/sdl_image/APKBUILD b/main/sdl_image/APKBUILD
new file mode 100644
index 000000000..5b9faef5d
--- /dev/null
+++ b/main/sdl_image/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=sdl_image
+pkgver=1.2.10
+pkgrel=0
+pkgdesc="A simple library to load images of various formats as SDL surfaces"
+url="http://www.libsdl.org/projects/SDL_image/"
+license="LGPL"
+depends=
+makedepends="sdl-dev libpng-dev jpeg-dev tiff-dev zlib-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://www.libsdl.org/projects/SDL_image/release/SDL_image-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/SDL_image-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="6c06584b31559e2b59f2b982d0d1f628 SDL_image-1.2.10.tar.gz"
diff --git a/main/sdl_mixer/APKBUILD b/main/sdl_mixer/APKBUILD
new file mode 100644
index 000000000..bbab864d3
--- /dev/null
+++ b/main/sdl_mixer/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=sdl_mixer
+pkgver=1.2.11
+pkgrel=0
+pkgdesc="A simple multi-channel audio mixer"
+url="http://www.libsdl.org/projects/SDL_mixer/"
+license="GPL"
+depends=
+makedepends="sdl-dev libvorbis-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/SDL_mixer-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -e "/CONFIG_FILE_ETC/s/\/etc\/timidity.cfg/\/etc\/timidity++\/timidity.cfg/" \
+ -e "/DEFAULT_PATH/s/\/etc\/timidity/\/etc\/timidity++/" \
+ -e "/DEFAULT_PATH2/s/\/usr\/local\/lib\/timidity/\/usr\/lib\/timidity/" \
+ -i timidity/config.h
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="65ada3d997fe85109191a5fb083f248c SDL_mixer-1.2.11.tar.gz"
diff --git a/main/wavpack/APKBUILD b/main/wavpack/APKBUILD
new file mode 100644
index 000000000..1e3907555
--- /dev/null
+++ b/main/wavpack/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter
+# Maintainer:
+pkgname=wavpack
+pkgver=4.60.1
+pkgrel=0
+pkgdesc="Audio compression format with lossless, lossy, and hybrid compression modes"
+url="http://www.wavpack.com/"
+license="custom"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.wavpack.com/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-mmx \
+ --disable-static
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname} || return 1
+ install -m644 license.txt ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+}
+
+md5sums="7bb1528f910e4d0003426c02db856063 wavpack-4.60.1.tar.bz2"