summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-25 14:28:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-25 14:28:26 +0000
commitcbb44c61af6b07d5d19a78fe47ba8d20baff85ae (patch)
tree15b3ad229f4a533246f32b83a9ebc276285369c6
parentef54f83392012b97de706ed592897f6cd1d43f80 (diff)
downloadaports-cbb44c61af6b07d5d19a78fe47ba8d20baff85ae.tar.bz2
aports-cbb44c61af6b07d5d19a78fe47ba8d20baff85ae.tar.xz
testing/libwbxml: new aport
libwbxml is a library to encode and decode WAP Binary XML https://libwbxml.opensync.org
-rw-r--r--testing/libwbxml/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libwbxml/APKBUILD b/testing/libwbxml/APKBUILD
new file mode 100644
index 000000000..d8b2f0c36
--- /dev/null
+++ b/testing/libwbxml/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libwbxml
+pkgver=0.10.8
+pkgrel=0
+pkgdesc="libwbxml is a library to encode and decode WAP Binary XML"
+url="https://libwbxml.opensync.org"
+license="LGPL"
+depends=
+makedepends="cmake"
+depends_dev="libxml2-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/libwbxml/libwbxml-$pkgver.tar.bz2"
+
+_srcdir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/build
+
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_srcdir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="7b51c425fc2ff9f502cd9b1e291b1955 libwbxml-0.10.8.tar.bz2"