summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-24 14:00:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-24 14:00:03 +0000
commitebd12851bc537f03b3c983a11d02c0970a50c665 (patch)
tree94ca982b8bff0ff3d9164a9fa2de6dfc64f89842
parent04a99e6c78ff37cc52a4d1029b2a63be4efa8760 (diff)
downloadaports-ebd12851bc537f03b3c983a11d02c0970a50c665.tar.bz2
aports-ebd12851bc537f03b3c983a11d02c0970a50c665.tar.xz
testing/openvpn-auth-ldap: new aport
LDAP authentication and authorization plugin for OpenVPN 2.x http://code.google.com/p/openvpn-auth-ldap/ ref #395
-rw-r--r--testing/openvpn-auth-ldap/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/openvpn-auth-ldap/APKBUILD b/testing/openvpn-auth-ldap/APKBUILD
new file mode 100644
index 000000000..e3c141707
--- /dev/null
+++ b/testing/openvpn-auth-ldap/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openvpn-auth-ldap
+pkgver=2.0.3
+_openvpnver=2.1.3
+pkgrel=0
+pkgdesc="LDAP authentication and authorization plugin for OpenVPN 2.x"
+url="http://code.google.com/p/openvpn-auth-ldap/"
+license="GPL"
+depends=
+makedepends="openvpn re2c openldap-dev"
+install=
+subpackages=
+source="http://openvpn-auth-ldap.googlecode.com/files/auth-ldap-$pkgver.tar.gz
+ http://openvpn.net/release/openvpn-$_openvpnver.tar.gz
+ "
+_builddir="$srcdir"/auth-ldap-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-openvpn="$srcdir"/openvpn-$_openvpnver
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/lib
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="03dedc57efc8d4fc2ffe2c014121299d auth-ldap-2.0.3.tar.gz
+7486d3e270ba4b033e311d3e022a0ad7 openvpn-2.1.3.tar.gz"