summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-24 13:44:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-24 13:44:26 +0000
commit04a99e6c78ff37cc52a4d1029b2a63be4efa8760 (patch)
treec55d2729a690ce435eac506734782e0dcfb9eb13
parent3691f9a90c57dc73a15860259b88d6a8dd8d87b1 (diff)
downloadaports-04a99e6c78ff37cc52a4d1029b2a63be4efa8760.tar.bz2
aports-04a99e6c78ff37cc52a4d1029b2a63be4efa8760.tar.xz
testing/obexftp: new aport
A tool for transfer files to/from any OBEX enabled device http://openobex.triq.net/obexftp/obexftp
-rw-r--r--testing/obexftp/APKBUILD48
-rw-r--r--testing/obexftp/obexftp-0.23-gentoo.patch24
2 files changed, 72 insertions, 0 deletions
diff --git a/testing/obexftp/APKBUILD b/testing/obexftp/APKBUILD
new file mode 100644
index 000000000..653906b3b
--- /dev/null
+++ b/testing/obexftp/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=obexftp
+pkgver=0.23
+pkgrel=0
+pkgdesc="A tool for transfer files to/from any OBEX enabled device"
+url="http://openobex.triq.net/obexftp/obexftp"
+license="GPL"
+depends=
+makedepends="pkgconfig openobex-dev"
+subpackages="$pkgname-dev $pkgname-doc libobexftp"
+source="http://downloads.sourceforge.net/sourceforge/openobex/obexftp-$pkgver.tar.bz2
+ obexftp-0.23-gentoo.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-perl \
+ --disable-python \
+ --disable-ruby || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libobexftp() {
+ pkgdesc="OBEX shared library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib
+}
+
+md5sums="f20762061b68bc921e80be4aebc349eb obexftp-0.23.tar.bz2
+90b4fadb913673c339bbd04cebc4f9d2 obexftp-0.23-gentoo.patch"
diff --git a/testing/obexftp/obexftp-0.23-gentoo.patch b/testing/obexftp/obexftp-0.23-gentoo.patch
new file mode 100644
index 000000000..b805bc625
--- /dev/null
+++ b/testing/obexftp/obexftp-0.23-gentoo.patch
@@ -0,0 +1,24 @@
+diff -Nru obexftp-0.23.orig/obexftp/client.c obexftp-0.23/obexftp/client.c
+--- obexftp-0.23.orig/obexftp/client.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/obexftp/client.c 2009-03-22 16:12:05.000000000 +0000
+@@ -51,8 +51,6 @@
+
+ #ifdef HAVE_BLUETOOTH
+ #include "bt_kit.h"
+-#else
+-#define ESOCKTNOSUPPORT WSAESOCKTNOSUPPORT
+ #endif /* HAVE_BLUETOOTH */
+
+ #include <openobex/obex.h>
+diff -Nru obexftp-0.23.orig/apps/obexftp.c obexftp-0.23/apps/obexftp.c
+--- obexftp-0.23.orig/apps/obexftp.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/apps/obexftp.c 2009-03-22 16:19:29.000000000 +0000
+@@ -29,6 +29,8 @@
+
+ #include <sys/types.h>
+
++#include <config.h>
++
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif