summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-16 09:06:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-16 10:21:06 +0000
commit03bf0af45bcde46319e4c81abf1eee440a573ace (patch)
treebe7626b800ad9470c7394412c84007d4e7bcaa6a
parent66ef745e031af5613e81dda39de1ffae141492a2 (diff)
downloadaports-03bf0af45bcde46319e4c81abf1eee440a573ace.tar.bz2
aports-03bf0af45bcde46319e4c81abf1eee440a573ace.tar.xz
main/alpine-baselayout: upgrade to 2.1.0 and fix modprobe.d
Newer versions of module-init-tools requires files in modprobe.d to have .conf extension. In order for upgraders to keep their module configs we need to rename our files in /etc/modprobe.d. We do so in a pre-upgrade script.
-rw-r--r--main/alpine-baselayout/0001-profile-change-default-path.patch22
-rw-r--r--main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch21
-rw-r--r--main/alpine-baselayout/APKBUILD17
-rw-r--r--main/alpine-baselayout/alpine-baselayout.pre-upgrade15
4 files changed, 23 insertions, 52 deletions
diff --git a/main/alpine-baselayout/0001-profile-change-default-path.patch b/main/alpine-baselayout/0001-profile-change-default-path.patch
deleted file mode 100644
index 8f6945ce7..000000000
--- a/main/alpine-baselayout/0001-profile-change-default-path.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 963370a09dba86b661d4fec6f9152c219419f861 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 17 Jul 2009 12:35:21 +0000
-Subject: [PATCH] profile: change default path
-
----
- profile | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/profile b/profile
-index ef97cc8..a292008 100644
---- a/profile
-+++ b/profile
-@@ -1,4 +1,4 @@
--export PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
-+export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
- export PAGER=less
- export PS1='\h:\w\$ '
- umask 022
---
-1.6.3.3
-
diff --git a/main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch b/main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch
deleted file mode 100644
index ee7f1c542..000000000
--- a/main/alpine-baselayout/0001-profile-set-system-environment-charset-to-UTF-8.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 43c026c2ef8e63726aff987b7c7b65039aa8d455 Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Mon, 14 Mar 2011 11:32:45 -0500
-Subject: [PATCH] profile: set system environment charset to UTF-8
-
----
- profile | 1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/profile b/profile
-index a292008..3480248 100644
---- a/profile
-+++ b/profile
-@@ -1,3 +1,4 @@
-+export CHARSET=UTF-8
- export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
- export PAGER=less
- export PS1='\h:\w\$ '
---
-1.7.4.1
-
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index 67b8a9adf..325384697 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -1,30 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-baselayout
-pkgver=2.0_rc1
-pkgrel=3
+pkgver=2.1.0
+pkgrel=0
pkgdesc="Alpine base dir structure and init scripts"
url=http://git.alpinelinux.org/cgit/alpine-baselayout
depends=
+install="$pkgname.pre-upgrade"
source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
- 0001-profile-set-system-environment-charset-to-UTF-8.patch
"
arch="all"
license=GPL-2
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -p1 < "$srcdir"/0001-profile-set-system-environment-charset-to-UTF-8.patch
+ cd "$_builddir"
}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
rm -f src/mkmntdirs
make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make install PREFIX= DESTDIR="$pkgdir" || return 1
}
-md5sums="76d61057c9e21d8e3ef85933a20b814d alpine-baselayout-2.0_rc1.tar.bz2
-b4eb3fdb4ca0aa136c87ca0c32e25742 0001-profile-set-system-environment-charset-to-UTF-8.patch"
+md5sums="94fb785dbfbee6daebf2ada54573403b alpine-baselayout-2.1.0.tar.bz2"
diff --git a/main/alpine-baselayout/alpine-baselayout.pre-upgrade b/main/alpine-baselayout/alpine-baselayout.pre-upgrade
new file mode 100644
index 000000000..7ba635eb9
--- /dev/null
+++ b/main/alpine-baselayout/alpine-baselayout.pre-upgrade
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+# we need to have our modprobe.d files with .conf suffix
+for i in /etc/modprobe.d/*; do
+ # ignore files that does not exist (i.e if modprobe.d is empty)
+ [ -r "$i" ] || continue
+
+ # ignore files that has an extention
+ case "$i" in
+ *.*) continue;;
+ esac
+
+ # append extension
+ mv "$i" "$i".conf
+done