summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2011-03-17 13:30:52 +0000
committerTed Trask <ttrask01@yahoo.com>2011-03-17 20:15:24 +0000
commitb8d2cfa10f3b739e02e8d834549b4ed20b14a676 (patch)
treef44e04c7d14e781b28fd681ca7810ed89811fdb4
parent1ac53c1d3b0de5eaf8135a7ffcb3ad5be7665219 (diff)
downloadaports-b8d2cfa10f3b739e02e8d834549b4ed20b14a676.tar.bz2
aports-b8d2cfa10f3b739e02e8d834549b4ed20b14a676.tar.xz
main/acf-alpine-baselayout: upgrade to 0.8.0
-rw-r--r--main/acf-alpine-baselayout/APKBUILD17
-rw-r--r--main/acf-alpine-baselayout/busybox-1.18-compat.patch27
2 files changed, 5 insertions, 39 deletions
diff --git a/main/acf-alpine-baselayout/APKBUILD b/main/acf-alpine-baselayout/APKBUILD
index 6ba1032a5..0d507973a 100644
--- a/main/acf-alpine-baselayout/APKBUILD
+++ b/main/acf-alpine-baselayout/APKBUILD
@@ -1,25 +1,18 @@
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-alpine-baselayout
-pkgver=0.7.3
-pkgrel=5
+pkgver=0.8.0
+pkgrel=0
pkgdesc="A web-based system administration interface for alpine-baselayout"
url="http://git.alpinelinux.org/cgit/acf-alpine-baselayout"
arch="noarch"
license="GPL-2"
-depends="acf-core lua lua-json4 lua-posix procps"
-source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
- busybox-1.18-compat.patch"
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < "$srcdir"/busybox-1.18-compat.patch
-}
+depends="acf-core lua lua-json4 lua-posix"
+source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2"
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-md5sums="b462fa1ff228f3552c2eea2d0a4fed96 acf-alpine-baselayout-0.7.3.tar.bz2
-5445216b479bdd4800cf960aef933a67 busybox-1.18-compat.patch"
+md5sums="59d428712072fd286ec651ca185de205 acf-alpine-baselayout-0.8.0.tar.bz2"
diff --git a/main/acf-alpine-baselayout/busybox-1.18-compat.patch b/main/acf-alpine-baselayout/busybox-1.18-compat.patch
deleted file mode 100644
index ddeae946b..000000000
--- a/main/acf-alpine-baselayout/busybox-1.18-compat.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 96aa7d8650f4de9f1d009e10d45df01d5e7a1331 Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Mon, 21 Feb 2011 10:11:48 -0600
-Subject: [PATCH] health model: work with procps and busybox 1.18
-
----
- health-model.lua | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/health-model.lua b/health-model.lua
-index 2749e2a..bb70073 100644
---- a/health-model.lua
-+++ b/health-model.lua
-@@ -49,8 +49,8 @@ get_system = function (self)
- system.version = cfe({ value=indexver or fs.read_file("/etc/alpine-release") or "Unknown", label="Version" })
- system.timezone = cfe({ value=date.what_tz(), label="Time Zone" })
- system.uname = cfe({ value=querycmd("uname -a"), label="UName" })
-- system.memory = cfe({ value=querycmd("free"), label="Memory usage" })
-- system.memory.used = getpercentage(querycmd("free"), "Total:", 3, 4)
-+ system.memory = cfe({ value=querycmd("free -o -t"), label="Memory usage" })
-+ system.memory.used = getpercentage(querycmd("free -o -t"), "Total:", 3, 4)
- return cfe({ type="group", value=system })
- end
-
---
-1.7.4.1
-