summaryrefslogtreecommitdiffstats
path: root/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-16 07:45:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-16 07:45:15 +0000
commitcb0a6194fe8a614e7b91ce6772005d924031e438 (patch)
tree8ab797496f04777dd6fd99dde7679df42063d064 /main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
parent6b19453ed2db40f0d9f976385abbc96e72704977 (diff)
downloadaports-cb0a6194fe8a614e7b91ce6772005d924031e438.tar.bz2
aports-cb0a6194fe8a614e7b91ce6772005d924031e438.tar.xz
main/apk-tools: build fix
added missing patch
Diffstat (limited to 'main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch')
-rw-r--r--main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch b/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
new file mode 100644
index 000000000..52ef14186
--- /dev/null
+++ b/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
@@ -0,0 +1,42 @@
+From fc4c60f233ebe9fe85b7b03d0cf5deec4ab1b32d Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 16 Jun 2010 07:37:17 +0000
+Subject: [PATCH] Makefile: do not require lua pkgconfig unless you intend build lua module
+
+---
+ src/Makefile | 11 ++++++-----
+ 1 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 50f9664..bea288e 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,12 +1,9 @@
+-PKGDEPS := openssl zlib lua
+-
+-ifeq ($(shell pkg-config --print-errors --exists $(PKGDEPS) || echo fail),fail)
+-$(error Build dependencies are not met)
+-endif
++PKGDEPS := openssl zlib
+
+ # lua module
+ ifneq ($(LUAAPK),)
+ LIBAPK := YesPlease
++PKGDEPS += lua
+ shlibs-y += apk.so
+ apk.so-objs := lua-apk.o
+ CFLAGS_lua-apk.o := -DAPK_VERSION=\"$(FULL_VERSION)\"
+@@ -16,6 +13,10 @@ install-LUA_LIB-y := $(INSTALLDIR) $(DESTDIR)$(LUA_LIBDIR) \
+ $(INSTALL) $(LUA_LIB-y) $(DESTDIR)$(LUA_LIBDIR)
+ endif
+
++ifeq ($(shell pkg-config --print-errors --exists $(PKGDEPS) || echo fail),fail)
++$(error Build dependencies are not met)
++endif
++
+ progs-y += apk
+ apk-objs := apk.o add.o del.o fix.o update.o info.o \
+ search.o upgrade.o cache.o ver.o index.o fetch.o \
+--
+1.7.1
+