summaryrefslogtreecommitdiffstats
path: root/extra/wget
diff options
context:
space:
mode:
Diffstat (limited to 'extra/wget')
-rw-r--r--extra/wget/APKBUILD9
-rw-r--r--extra/wget/wget.post-deinstall3
2 files changed, 9 insertions, 3 deletions
diff --git a/extra/wget/APKBUILD b/extra/wget/APKBUILD
index 93e4c3375..b6581fa48 100644
--- a/extra/wget/APKBUILD
+++ b/extra/wget/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=wget
pkgver=1.11.4
-pkgrel=0
+pkgrel=1
pkgdesc="A network utility to retrieve files from the Web"
url="http://www.gnu.org/software/wget/wget.html"
license="GPL3"
depends="openssl"
makedepends="openssl-dev"
subpackages="$pkgname-doc"
-source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+install="wget.post-deinstall"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ $install"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -23,4 +25,5 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="69e8a7296c0e12c53bd9ffd786462e87 wget-1.11.4.tar.gz"
+md5sums="69e8a7296c0e12c53bd9ffd786462e87 wget-1.11.4.tar.gz
+b84506d253e04db3c5af9016fead45a3 wget.post-deinstall"
diff --git a/extra/wget/wget.post-deinstall b/extra/wget/wget.post-deinstall
new file mode 100644
index 000000000..99b57c463
--- /dev/null
+++ b/extra/wget/wget.post-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+busybox --install -s