aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-10-23 23:51:16 -0400
committerTimo Teräs <timo.teras@iki.fi>2016-11-04 07:43:17 +0000
commit0f259798d39acfb64b80786fbdeab6061bf3bc01 (patch)
treebc6aaf857b2611485249c34a23e8444bdb2ba09b
parent3d74bc8d55eceb058678c89be80a75302a060bff (diff)
downloadaports-0f259798d39acfb64b80786fbdeab6061bf3bc01.tar.bz2
aports-0f259798d39acfb64b80786fbdeab6061bf3bc01.tar.xz
testing/mupdf: allow both x11 and gl backends
ref #5921 Default mupdf symlink to mupdf-x11
-rw-r--r--testing/mupdf/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/mupdf/APKBUILD b/testing/mupdf/APKBUILD
index ad0d84877..725d305ac 100644
--- a/testing/mupdf/APKBUILD
+++ b/testing/mupdf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Zhou <zhoumichaely@gmail.com>
pkgname=mupdf
pkgver=1.9a
-pkgrel=6
+pkgrel=7
pkgdesc="A lightweight PDF and XPS viewer"
url="http://mupdf.com"
arch="all"
@@ -48,7 +48,7 @@ package() {
_x11() {
pkgdesc="A lightweight PDF and XPS viewer with X11 backend"
- depends="!mupdf-gl mupdf"
+ depends="mupdf"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/mupdf-x11 \
"$subpkgdir"/usr/bin/ || return 1
@@ -57,11 +57,10 @@ _x11() {
_gl() {
pkgdesc="A lightweight PDF and XPS viewer with OpenGL backend"
- depends="!mupdf-x11 mupdf"
+ depends="mupdf"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/mupdf-gl \
"$subpkgdir"/usr/bin/ || return 1
- ln -s /usr/bin/mupdf-gl "$subpkgdir"/usr/bin/mupdf
}
_tools() {