aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/eio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/eio/APKBUILD')
-rw-r--r--unmaintained/eio/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/eio/APKBUILD b/unmaintained/eio/APKBUILD
new file mode 100644
index 000000000..3fab3d04d
--- /dev/null
+++ b/unmaintained/eio/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=eio
+pkgver=1.7.9
+pkgrel=0
+pkgdesc="An async I/O library"
+url="http://trac.enlightenment.org/e/wiki/Eina"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="eet-dev eina-dev ecore-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/eio-$pkgver.tar.gz"
+
+_builddir="$srcdir"/eio-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f4d6cbd216a9ae5983fa8ee8dadf04cb eio-1.7.9.tar.gz"
+sha256sums="35ce08ecf6afd5faa4fe857764537e15aede2b0d2c37922e55e97e2dff3352de eio-1.7.9.tar.gz"
+sha512sums="0c3d8420af12324397584001d352f67e0077bfb61f1180d0ab9efd61e758d71ee1fe08a307538493371cb2c154cb9e30a3731f776b7ff7ee929d82f15d0ff90d eio-1.7.9.tar.gz"