summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-11 10:24:04 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-11 14:07:33 +0000
commita9b3d7ac7fd3450449cd61d51df9cad3a4c54834 (patch)
tree5895722a4321ad7b51896bc7a6e771c6dd550c26
parentadc7a994172c58df927259ebf781c4ec73ab0794 (diff)
downloadaports-fcolista-a9b3d7ac7fd3450449cd61d51df9cad3a4c54834.tar.bz2
aports-fcolista-a9b3d7ac7fd3450449cd61d51df9cad3a4c54834.tar.xz
main/py-twisted-web: upgrade to 12.3.0
-rw-r--r--main/py-twisted-web/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/py-twisted-web/APKBUILD b/main/py-twisted-web/APKBUILD
index a96c93ffa0..a4feedcb2a 100644
--- a/main/py-twisted-web/APKBUILD
+++ b/main/py-twisted-web/APKBUILD
@@ -1,6 +1,5 @@
# Contributor: Jeff Bilyk <jbilyk@alpinelinux.org>
# Maintainer:
-
pkgname=py-twisted-web
_pkgname=TwistedWeb
pkgver=12.0.0
@@ -11,12 +10,19 @@ arch="noarch"
license="MIT"
depends="py-twisted"
makedepends="python-dev"
-source="http://twistedmatrix.com/Releases/Web/12.0/$_pkgname-$pkgver.tar.bz2"
+source="http://twistedmatrix.com/Releases/Web/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$srcdir"/$_pkgname-$pkgver/
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="e253566d86305bd1335874e69803d4f6 TwistedWeb-12.0.0.tar.bz2"
+sha256sums="ff6d0dad12f1928deca23c8d05a0cb9a340abbb6e2cd8bc503e4092a0a873859 TwistedWeb-12.0.0.tar.bz2"
+sha512sums="8a3e39989efa179e08ce4e15287fe0f12315b296fa7216d8444f6470e5860fb57e95c5173c30bdf1afa25304b411358ff1516069d486fd72559adfb89892b742 TwistedWeb-12.0.0.tar.bz2"