summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-11 09:07:06 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-11 14:07:31 +0000
commitfa1b39101ab8bf2318c0a5409d21a9703b6271c7 (patch)
treeb10ce26448e863c5cb1fe87cee6ec9a0147f8151
parentde5ad8f446d48415f93ec9ca763fcb3cbab03495 (diff)
downloadaports-fcolista-fa1b39101ab8bf2318c0a5409d21a9703b6271c7.tar.bz2
aports-fcolista-fa1b39101ab8bf2318c0a5409d21a9703b6271c7.tar.xz
testing/py-apache-libcloud: upgrade to 0.12.1
-rw-r--r--testing/py-apache-libcloud/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/testing/py-apache-libcloud/APKBUILD b/testing/py-apache-libcloud/APKBUILD
index 29b69e2147..f24d67dca8 100644
--- a/testing/py-apache-libcloud/APKBUILD
+++ b/testing/py-apache-libcloud/APKBUILD
@@ -2,29 +2,30 @@
# Maintainer:
pkgname=py-apache-libcloud
_pkgname=apache-libcloud
-pkgver=0.11.4
+pkgver=0.12.1
pkgrel=0
-pkgdesc="Apache Libcloud is a standard Python library that abstracts away differences among multiple cloud provider APIs"
+pkgdesc="A Python library that abstracts away differences among multiple cloud provider APIs"
url="https://libcloud.apache.org"
arch="noarch"
-license="APACHE"
+license="Apache2"
depends=""
-depends_dev="python-dev"
-makedepends="$depends_dev"
+depends_dev=""
+makedepends="python-dev py-setuptools"
install=""
subpackages=""
source="http://www.mirrorservice.org/sites/ftp.apache.org/libcloud/$_pkgname-$pkgver.tar.bz2"
+
_builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$_builddir"
- python setup.py build
+ python setup.py build || return 1
}
package() {
cd "$_builddir"
- python setup.py install --root="$pkgdir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-md5sums="94b4bebbe500cf4747623e9503213a4a apache-libcloud-0.11.4.tar.bz2"
-sha256sums="5987f20c256608ee757b1a097b6392afbd18058cfc21ce761c078b44da95c532 apache-libcloud-0.11.4.tar.bz2"
-sha512sums="b761e6b1d29f60c382602b552c48268f1cf0a27e2a51bdf6603179f085a160b10c51eaa2d089bc868ae2147dc246ada43d0142edf03a786de20ef3468e23db1e apache-libcloud-0.11.4.tar.bz2"
+md5sums="293bcae58ed98e354756ef2166b5d281 apache-libcloud-0.12.1.tar.bz2"
+sha256sums="26cc9e13d627a58c78894e6982125ffb8418b94ab5854694e4c2f844bf1a2ca3 apache-libcloud-0.12.1.tar.bz2"
+sha512sums="fcb0555bf078bf3cf548d7903f8dc7d2d49b9aa08e00c36ccb3e1da710e3f3a1885a5db7612ceaeb658e1b126214342c0fde678b90e7052490ff0412e360d024 apache-libcloud-0.12.1.tar.bz2"