summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-31 10:26:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-31 10:46:24 +0000
commit1adc6ca97d7bcb20e390fef8ce21c7395c87c742 (patch)
treeee6424fc4ced1b63925e5abb0ae2ca608d8fb918 /testing
parent9a8edeb425e938c7e5af0626185455f61431bbbf (diff)
downloadaports-fcolista-1adc6ca97d7bcb20e390fef8ce21c7395c87c742.tar.bz2
aports-fcolista-1adc6ca97d7bcb20e390fef8ce21c7395c87c742.tar.xz
testing/cups-filters: upgrade to 1.0.29
Diffstat (limited to 'testing')
-rw-r--r--testing/cups-filters/APKBUILD22
-rw-r--r--testing/cups-filters/cups-filters-1.0.29-poppler_022.patch58
-rw-r--r--testing/cups-filters/isnan.patch17
3 files changed, 70 insertions, 27 deletions
diff --git a/testing/cups-filters/APKBUILD b/testing/cups-filters/APKBUILD
index 8adae040a3..ab3766e091 100644
--- a/testing/cups-filters/APKBUILD
+++ b/testing/cups-filters/APKBUILD
@@ -1,21 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups-filters
-pkgver=1.0.24
-pkgrel=1
+pkgver=1.0.29
+pkgrel=0
pkgdesc="OpenPrinting CUPS filters and backends"
url="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format"
arch="all"
license="GPLv2 and GPLv2+ and GPLv3 and MIT"
depends="poppler-utils"
depends_dev=""
-makedepends="$depends_dev cups-dev jpeg-dev poppler-dev zlib-dev libpng-dev
- tiff-dev lcms-dev freetype-dev ghostscript-dev fontconfig-dev
- qpdf-dev"
+makedepends="$depends_dev cups-dev libjpeg-turbo-dev poppler-dev zlib-dev
+ libpng-dev tiff-dev lcms-dev freetype-dev ghostscript-dev fontconfig-dev
+ qpdf-dev avahi-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-patches="isnan.patch"
source="http://www.openprinting.org/download/cups-filters/cups-filters-$pkgver.tar.xz
- $patches"
+ cups-filters-1.0.29-poppler_022.patch"
_builddir="$srcdir"/cups-filters-$pkgver
prepare() {
@@ -37,6 +36,8 @@ build() {
--localstatedir=/var \
--disable-static \
--with-pdftops=pdftops \
+ --without-rcdir \
+ --without-rclevels \
|| return 1
make || return 1
}
@@ -44,7 +45,8 @@ build() {
package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
+ rm -f "$pkgdir"/usr/lib/*.la \
+
}
libs() {
@@ -53,5 +55,5 @@ libs() {
mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
}
-md5sums="4c638c1f1875c984c3d97179e89380c8 cups-filters-1.0.24.tar.xz
-63dc308cb6e650a5c3dc2a3fbdab5057 isnan.patch"
+md5sums="01e2d9abc4ea69521334a0ee2f70d98a cups-filters-1.0.29.tar.xz
+82281b049a5ef4aca479cac104de1af0 cups-filters-1.0.29-poppler_022.patch"
diff --git a/testing/cups-filters/cups-filters-1.0.29-poppler_022.patch b/testing/cups-filters/cups-filters-1.0.29-poppler_022.patch
new file mode 100644
index 0000000000..e75f38fa3c
--- /dev/null
+++ b/testing/cups-filters/cups-filters-1.0.29-poppler_022.patch
@@ -0,0 +1,58 @@
+diff -urbB cups-filters-1.0.29/filter/pdftoopvp/oprs/OPRS.cxx cups-filters-1.0-20130119/filter/pdftoopvp/oprs/OPRS.cxx
+--- cups-filters-1.0.29/filter/pdftoopvp/oprs/OPRS.cxx 2012-09-10 14:52:00.000000000 -0500
++++ cups-filters-1.0-20130119/filter/pdftoopvp/oprs/OPRS.cxx 2013-01-18 18:40:36.000000000 -0600
+@@ -5,6 +5,9 @@
+ //========================================================================
+
+ #include <config.h>
++#ifdef HAVE_CPP_POPPLER_VERSION_H
++#include "cpp/poppler-version.h"
++#endif
+
+ #ifdef USE_GCC_PRAGMAS
+ #pragma implementation
+@@ -235,7 +238,11 @@
+ SplashColorMode srcMode, GBool srcAlpha,
+ int w, int h, SplashCoord *mat) {
+ if (rasterMode) {
++#if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
+ return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
++#else
++ return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
++#endif
+ } else {
+ return opvpSplash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
+ }
+diff -urbB cups-filters-1.0.29/filter/pdftoopvp/OPVPOutputDev.cxx cups-filters-1.0-20130119/filter/pdftoopvp/OPVPOutputDev.cxx
+--- cups-filters-1.0.29/filter/pdftoopvp/OPVPOutputDev.cxx 2012-07-20 03:22:23.000000000 -0500
++++ cups-filters-1.0-20130119/filter/pdftoopvp/OPVPOutputDev.cxx 2013-01-18 18:40:36.000000000 -0600
+@@ -1804,8 +1804,14 @@
+ maskSplash = new Splash(maskBitmap, gFalse);
+ maskColor[0] = 0;
+ maskSplash->clear(maskColor);
++#if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
+ maskSplash->drawImage(&imageSrc, &imgMaskData,
+ splashModeMono8, gFalse, maskWidth, maskHeight, mat);
++#else
++ maskSplash->drawImage(&imageSrc, &imgMaskData,
++ splashModeMono8, gFalse, maskWidth, maskHeight,
++ mat,gFalse);
++#endif
+ delete imgMaskData.imgStr;
+ maskStr->close();
+ gfree(imgMaskData.lookup);
+diff -urbB cups-filters-1.0.29/NEWS cups-filters-1.0-20130119/NEWS
+--- cups-filters-1.0.29/NEWS 2013-01-02 12:23:13.000000000 -0600
++++ cups-filters-1.0-20130119/NEWS 2013-01-18 18:40:36.000000000 -0600
+@@ -1,6 +1,11 @@
+ NEWS - OpenPrinting CUPS Filters v1.0.29 - 2013-01-02
+ -----------------------------------------------------
+
++CHANGES IN V1.0.30
++
++ - pdftoopvp: Let it build with Poppler 0.22.x. Thanks to Koji Otani
++ from BBR Inc. (Bug #1089).
++
+ CHANGES IN V1.0.29
+
+ - Fixed ./configure option "--with-rcdir=no". Thanks to Jiri
diff --git a/testing/cups-filters/isnan.patch b/testing/cups-filters/isnan.patch
deleted file mode 100644
index 187201fb98..0000000000
--- a/testing/cups-filters/isnan.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./filter/pdftopdf/pptypes.cc.orig
-+++ ./filter/pdftopdf/pptypes.cc
-@@ -163,10 +163,10 @@
-
- void PageRect::set(const PageRect &rhs) // {{{
- {
-- if (!isnan(rhs.top)) top=rhs.top;
-- if (!isnan(rhs.left)) left=rhs.left;
-- if (!isnan(rhs.right)) right=rhs.right;
-- if (!isnan(rhs.bottom)) bottom=rhs.bottom;
-+ if (!std::isnan(rhs.top)) top=rhs.top;
-+ if (!std::isnan(rhs.left)) left=rhs.left;
-+ if (!std::isnan(rhs.right)) right=rhs.right;
-+ if (!std::isnan(rhs.bottom)) bottom=rhs.bottom;
- }
- // }}}
-