summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-02-04 14:13:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-02-04 14:13:05 +0000
commit782cd3786389ac3e58ea1392408cace7be3538d0 (patch)
tree0591720fe1ea7f76804160f71f1ed4f3456fedfb /testing
parent8f6ccb5e66cb472de2469eef4afda9445d0cf773 (diff)
downloadaports-fcolista-782cd3786389ac3e58ea1392408cace7be3538d0.tar.bz2
aports-fcolista-782cd3786389ac3e58ea1392408cace7be3538d0.tar.xz
testing/libva-intel-driver: install if libva and xf86-video-intel
Diffstat (limited to 'testing')
-rw-r--r--testing/libva-intel-driver/APKBUILD11
-rw-r--r--testing/libva-intel-driver/automake.patch11
2 files changed, 18 insertions, 4 deletions
diff --git a/testing/libva-intel-driver/APKBUILD b/testing/libva-intel-driver/APKBUILD
index 68be5b9d58..922e7263f8 100644
--- a/testing/libva-intel-driver/APKBUILD
+++ b/testing/libva-intel-driver/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libva-intel-driver
pkgver=1.0.19
-pkgrel=0
+pkgrel=1
pkgdesc="VA-API implementation for Intel G45 chipsets and Intel HD Graphics for Intel Core processor family"
url="http://freedesktop.org/wiki/Software/vaapi"
arch="all"
@@ -12,7 +12,9 @@ depends_dev="libdrm-dev libva-dev"
makedepends="$depends_dev autoconf automake m4 libtool"
install=""
subpackages=""
-source="http://www.freedesktop.org/software/vaapi/releases/libva-intel-driver/libva-intel-driver-$pkgver.tar.bz2"
+install_if="libva xf86-video-intel"
+source="http://www.freedesktop.org/software/vaapi/releases/libva-intel-driver/libva-intel-driver-$pkgver.tar.bz2
+ automake.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -37,4 +39,5 @@ package() {
rm -f "$pkgdir"/usr/lib/*/*.la
}
-md5sums="a4a668c86ef8c9fb3bde087857d74bf6 libva-intel-driver-1.0.19.tar.bz2"
+md5sums="a4a668c86ef8c9fb3bde087857d74bf6 libva-intel-driver-1.0.19.tar.bz2
+9a73efa34ff3eda7771560e3429ae5fd automake.patch"
diff --git a/testing/libva-intel-driver/automake.patch b/testing/libva-intel-driver/automake.patch
new file mode 100644
index 0000000000..cd076bd81a
--- /dev/null
+++ b/testing/libva-intel-driver/automake.patch
@@ -0,0 +1,11 @@
+--- ./configure.ac.orig 2013-02-04 14:08:59.494227977 +0000
++++ ./configure.ac 2013-02-04 14:09:10.617659753 +0000
+@@ -22,7 +22,7 @@
+ AC_CONFIG_SRCDIR([Makefile.am])
+ AM_INIT_AUTOMAKE([1.9 tar-ustar])
+
+-AM_CONFIG_HEADER([src/config.h])
++AC_CONFIG_HEADER([src/config.h])
+
+ INTEL_DRIVER_MAJOR_VERSION=intel_driver_major_version
+ INTEL_DRIVER_MINOR_VERSION=intel_driver_minor_version