summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-10-13 12:33:07 +0000
committerMichael Mason <ms13sp@gmail.com>2009-10-13 12:33:07 +0000
commitc09a8f931dced1c662fde492a9969a9ca5634978 (patch)
treedabc902d45a0dc8f81010039ead16c86096511a8 /unstable
parentdd0595e5f4d36b5549a5a80a8a7bcb8eccb33e7d (diff)
downloadaports-fcolista-c09a8f931dced1c662fde492a9969a9ca5634978.tar.bz2
aports-fcolista-c09a8f931dced1c662fde492a9969a9ca5634978.tar.xz
unstable/gnump3d Initial Commit
Diffstat (limited to 'unstable')
-rw-r--r--unstable/gnump3d/APKBUILD29
-rw-r--r--unstable/gnump3d/gnump3d.confd6
-rw-r--r--unstable/gnump3d/gnump3d.initd37
3 files changed, 72 insertions, 0 deletions
diff --git a/unstable/gnump3d/APKBUILD b/unstable/gnump3d/APKBUILD
new file mode 100644
index 0000000000..b367432942
--- /dev/null
+++ b/unstable/gnump3d/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=gnump3d
+pkgver=3.0
+pkgrel=0
+pkgdesc="A streaming server for MP3, OGG vorbis and other streamable files"
+url="http://www.gnump3d.org/"
+license="GPL-2"
+depends="perl"
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="http://savannah.gnu.org/download/gnump3d/$pkgname-$pkgver.tar.gz
+ gnump3d.confd
+ gnump3d.initd"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make PREFIX="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ mv "$pkgdir"/usr/local "$pkgdir"-doc/
+}
+
+md5sums="d2b665c3267253cc8cae29659131b9b4 gnump3d-3.0.tar.gz
+59f0286d4c943226a67ab7b7787547c6 gnump3d.confd
+5202488dff1c7e6c6788fb00fb32f071 gnump3d.initd"
diff --git a/unstable/gnump3d/gnump3d.confd b/unstable/gnump3d/gnump3d.confd
new file mode 100644
index 0000000000..1d6cf397d2
--- /dev/null
+++ b/unstable/gnump3d/gnump3d.confd
@@ -0,0 +1,6 @@
+# Set this to 0 to stop the init script from indexing your mp3s.
+# It takes the longest on the first time, but after that, it only does
+# updates.
+
+DO_INDEX=1
+
diff --git a/unstable/gnump3d/gnump3d.initd b/unstable/gnump3d/gnump3d.initd
new file mode 100644
index 0000000000..43290ee30a
--- /dev/null
+++ b/unstable/gnump3d/gnump3d.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/media-sound/gnump3d/files/gnump3d.init.d,v 1.4 2008/06/03 14:52:33 beandog Exp $
+
+opts="start stop index"
+
+depend() {
+ need net
+ after netmount nfsmount
+}
+
+start() {
+ ebegin "Starting gnump3d"
+
+ if [ ${DO_INDEX} -eq 1 ]; then
+ ebegin "Updating index of music files (may take a while for the first time)"
+ /usr/bin/gnump3d-index
+ eend $?
+ fi
+
+ start-stop-daemon --start --quiet --exec /usr/bin/gnump3d2 --make-pidfile \
+ --pidfile /var/run/gnump3d.pid --background -- --quiet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --pidfile /var/run/gnump3d.pid
+ eend $?
+}
+
+index() {
+ ebegin "Indexing music files"
+ /usr/bin/gnump3d-index
+ eend $?
+}