summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/sudo/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/sudo/APKBUILD b/main/sudo/APKBUILD
index 15992d9330..ea42e5d9d2 100644
--- a/main/sudo/APKBUILD
+++ b/main/sudo/APKBUILD
@@ -6,7 +6,7 @@ if [ "${pkgver%_*}" != "$pkgver" ]; then
else
_realver=$pkgver
fi
-pkgrel=0
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
url="http://www.sudo.ws/sudo/"
arch="all"
@@ -40,6 +40,9 @@ build() {
package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
+ # the sudo's mkinstalldir script miscreates the leading
+ # path components with bad permissions. fix this.
+ chmod 0755 "$pkgdir"/var "$pkgdir"/var/lib || return 1
}
md5sums="6d4282a1530c541f7900fa8dfcf2a882 sudo-1.8.3p2.tar.gz