summaryrefslogtreecommitdiffstats
path: root/main/tzdata/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/tzdata/Makefile.patch')
-rw-r--r--main/tzdata/Makefile.patch46
1 files changed, 18 insertions, 28 deletions
diff --git a/main/tzdata/Makefile.patch b/main/tzdata/Makefile.patch
index 9044162948..9caefcbfbf 100644
--- a/main/tzdata/Makefile.patch
+++ b/main/tzdata/Makefile.patch
@@ -1,7 +1,6 @@
-diff -Naur src/Makefile src-p/Makefile
---- src/Makefile 2007-08-20 16:47:41.000000000 +0200
-+++ src-p/Makefile 2007-10-02 04:07:44.000000000 +0200
-@@ -34,17 +34,17 @@
+--- ./Makefile.orig 2013-02-27 17:20:35.000000000 +0000
++++ ./Makefile 2013-03-13 15:03:39.518555524 +0000
+@@ -45,17 +45,17 @@
# Everything gets put in subdirectories of. . .
@@ -22,7 +21,7 @@ diff -Naur src/Makefile src-p/Makefile
# If you "make INSTALL", the "date" command gets installed in. . .
-@@ -52,7 +52,7 @@
+@@ -63,7 +63,7 @@
# Manual pages go in subdirectories of. . .
@@ -31,7 +30,7 @@ diff -Naur src/Makefile src-p/Makefile
# Library functions are put in an archive in LIBDIR.
-@@ -83,7 +83,7 @@
+@@ -94,7 +94,7 @@
# Non-default libraries needed to link.
# Add -lintl if you want to use `gettext' on Solaris.
@@ -39,17 +38,17 @@ diff -Naur src/Makefile src-p/Makefile
+LDLIBS=$(LDFLAGS)
# Add the following to the end of the "CFLAGS=" line as needed.
- # -Dconst= if `const' does not work (SunOS 4.x cc, OSF1 V5.0 cc)
-@@ -211,7 +211,7 @@
+ # -DHAVE_ADJTIME=0 if `adjtime' does not exist (SVR0?)
+@@ -228,7 +228,7 @@
# before the first Monday in January when a "%V" format is used and January 1
# falls on a Friday, Saturday, or Sunday.
-CFLAGS=
+CFLAGS += -std=gnu99
- # If you want zic's -s option used when installing, uncomment the next line
- # ZFLAGS= -s
-@@ -241,8 +241,10 @@
+ # Linker flags. Default to $(LFLAGS) for backwards compatibility
+ # to tzcode2012h and earlier.
+@@ -289,8 +289,10 @@
###############################################################################
@@ -62,7 +61,7 @@ diff -Naur src/Makefile src-p/Makefile
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
-@@ -282,14 +284,16 @@
+@@ -331,14 +333,16 @@
ALL: all date
@@ -83,7 +82,7 @@ diff -Naur src/Makefile src-p/Makefile
$(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
-rm -f $(MANDIR)/man3/newctime.3 \
$(MANDIR)/man3/newtzset.3 \
-@@ -298,13 +302,11 @@
+@@ -347,13 +351,11 @@
$(MANDIR)/man8/zdump.8 \
$(MANDIR)/man8/zic.8
cp newctime.3 newtzset.3 $(MANDIR)/man3/.
@@ -99,7 +98,7 @@ diff -Naur src/Makefile src-p/Makefile
-rm -f $(MANDIR)/man1/date.1
cp date.1 $(MANDIR)/man1/.
-@@ -334,9 +336,9 @@
+@@ -388,9 +390,9 @@
# You must replace all of $(TZDIR) to switch from not using leap seconds
# to using them, or vice versa.
other_two: zic leapseconds $(TDATA)
@@ -111,21 +110,12 @@ diff -Naur src/Makefile src-p/Makefile
posix_right: posix_only other_two
-@@ -367,7 +369,7 @@
+@@ -418,7 +420,7 @@
<$? >$@
chmod +x $@
--check: check_tables check_web
-+check: check_tables
-
- check_tables: checktab.awk $(PRIMARY_YDATA)
- $(AWK) -f checktab.awk $(PRIMARY_YDATA)
-diff -Naur src/tzselect.ksh src-p/tzselect.ksh
---- src/tzselect.ksh 2007-08-20 16:47:42.000000000 +0200
-+++ src-p/tzselect.ksh 2007-10-02 04:07:44.000000000 +0200
-@@ -1,4 +1,4 @@
--#! /bin/ksh
-+#! /bin/bash
-
- # '@(#)tzselect.ksh 8.1'
+-check: check_character_set check_tables check_web
++check: check_character_set check_tables
+ check_character_set: $(ENCHILADA)
+ sharp='#'; ! grep -n $(INVALID_CHAR) $(ENCHILADA)