summaryrefslogtreecommitdiffstats
path: root/testing/py-pycountry/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-pycountry/APKBUILD')
-rw-r--r--testing/py-pycountry/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/testing/py-pycountry/APKBUILD b/testing/py-pycountry/APKBUILD
index ae47d628d8..47cb7ed22f 100644
--- a/testing/py-pycountry/APKBUILD
+++ b/testing/py-pycountry/APKBUILD
@@ -2,15 +2,15 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-pycountry
_pkgname=pycountry
-pkgver=0.14.5
-pkgrel=1
+pkgver=0.14.8
+pkgrel=0
pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
url="http://pypi.python.org/pypi/pycountry"
arch="noarch"
-license="LGPL2"
-depends=
-depends_dev="python-dev py-lxml py-setuptools"
-makedepends="$depends_dev"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="python-dev py-lxml py-setuptools"
install=""
subpackages=""
source="http://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-$pkgver.zip"
@@ -26,9 +26,16 @@ prepare() {
done
}
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
package() {
cd "$_builddir"
python setup.py install --root=$pkgdir/ || return 1
}
-md5sums="1834b32f2b4ca3f1b6518388959f2bbc pycountry-0.14.5.zip"
+md5sums="2c775e379ba5ca2363f4f595ac9304ba pycountry-0.14.8.zip"
+sha256sums="5252b5378ba6f1971aa718248d797fb1e2a33d0bdb975400e4b801549102e2fa pycountry-0.14.8.zip"
+sha512sums="99d8ded3addd3dbd03e15d6ed31bd53d3c369c4b516c03f3e7bfa7ed42feda769153f6df0a43fd9129f8123b8ebc22341722dc5883c885b0f4a42ba591b475cd pycountry-0.14.8.zip"