summaryrefslogtreecommitdiffstats
path: root/testing/rpmlint
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rpmlint')
-rw-r--r--testing/rpmlint/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/rpmlint/APKBUILD b/testing/rpmlint/APKBUILD
new file mode 100644
index 0000000000..abb06ad9a7
--- /dev/null
+++ b/testing/rpmlint/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=rpmlint
+pkgver=1.3
+pkgrel=0
+pkgdesc="A tool for checking common errors in RPM packages"
+url="http://rpmlint.zarb.org"
+arch="noarch"
+license="GPL2"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://rpmlint.zarb.org/download/$pkgname-$pkgver.tar.xz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="afe1b906776d1ab8148888c25fd31006 rpmlint-1.3.tar.xz"