summaryrefslogtreecommitdiffstats
path: root/testing/urlwatch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/urlwatch/APKBUILD')
-rw-r--r--testing/urlwatch/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/urlwatch/APKBUILD b/testing/urlwatch/APKBUILD
new file mode 100644
index 0000000000..8927ac8a16
--- /dev/null
+++ b/testing/urlwatch/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=urlwatch
+pkgver=1.14
+pkgrel=0
+pkgdesc="A tool for monitoring webpages for updates"
+url="http://thpinfo.com/2008/urlwatch/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://thp.io/2008/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6bff9dab50fe4c45521d0b8e36d604a5 urlwatch-1.14.tar.gz"