summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-09-15 12:15:41 +0000
committerMichael Mason <ms13sp@gmail.com>2009-09-15 12:15:41 +0000
commit8a04f8069889659a4c461defc6face364740b674 (patch)
tree7e56f9f6334413a9d630e7de3a8c4bf4bd2e0198
parentdf53d0bf968a23ad61b15814dd338e1b2932cd59 (diff)
parent334ba4029aa89519fda0915bc31e1446f8c84b2e (diff)
downloadaports-8a04f8069889659a4c461defc6face364740b674.tar.bz2
aports-8a04f8069889659a4c461defc6face364740b674.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/alpine-conf/0001-setup-alpine-add-the-hostname-to-etc-hosts.patch50
-rw-r--r--main/alpine-conf/APKBUILD8
-rw-r--r--main/neon/APKBUILD5
-rw-r--r--x11/a52dec/APKBUILD27
-rw-r--r--x11/a52dec/a52dec-0.7.4-build.patch27
-rw-r--r--x11/gst-plugins-bad/APKBUILD31
-rw-r--r--x11/gst-plugins-ugly/APKBUILD26
-rw-r--r--x11/libmpeg2/APKBUILD31
-rw-r--r--x11/swfdec-mozilla/APKBUILD22
-rw-r--r--x11/swfdec/APKBUILD4
10 files changed, 226 insertions, 5 deletions
diff --git a/main/alpine-conf/0001-setup-alpine-add-the-hostname-to-etc-hosts.patch b/main/alpine-conf/0001-setup-alpine-add-the-hostname-to-etc-hosts.patch
new file mode 100644
index 000000000..2b01b0ead
--- /dev/null
+++ b/main/alpine-conf/0001-setup-alpine-add-the-hostname-to-etc-hosts.patch
@@ -0,0 +1,50 @@
+From d1f2db71733268da8097db02326e7f5332671f86 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 15 Sep 2009 08:57:32 +0000
+Subject: [PATCH] setup-alpine: add the hostname to /etc/hosts
+
+---
+ setup-alpine.in | 23 +++++++++++++++++++++++
+ 1 files changed, 23 insertions(+), 0 deletions(-)
+
+diff --git a/setup-alpine.in b/setup-alpine.in
+index 3472f53..712a950 100644
+--- a/setup-alpine.in
++++ b/setup-alpine.in
+@@ -6,6 +6,16 @@ VERSION=@VERSION@
+ PREFIX=
+ . $PREFIX/lib/libalpine.sh
+
++# Extract fully qualified domain name from current hostname. If none is
++# currently set, use 'my.domain'.
++get_fqdn() {
++ local _dn
++ _dn=$(hostname -f 2>/dev/null)
++ _dn=${_dn#$(hostname -s 2>/dev/null)}
++ _dn=${_dn#.}
++ echo "${_dn:=my.domain}"
++}
++
+ while getopts "ah" opt ; do
+ case $opt in
+ a) ARCHIVE=yes;;
+@@ -42,3 +52,16 @@ rc-update -q add networking boot
+ rc boot
+ rc default
+
++# update /etc/hosts - after we have got dhcp address
++# Get default fully qualified domain name from *first* domain
++# given on *last* search or domain statement.
++_dn=$(sed -n \
++-e '/^domain[[:space:]][[:space:]]*/{s///;s/\([^[:space:]]*\).*$/\1/;h;}' \
++-e '/^search[[:space:]][[:space:]]*/{s///;s/\([^[:space:]]*\).*$/\1/;h;}' \
++-e '${g;p;}' /etc/resolv.conf 2>/dev/null)
++
++_hn=$(hostname)
++_hn=${_hn%%.*}
++
++sed -i -e "s/^127\.0\.0\.1.*/127.0.0.1\t${_hn}.${_dn:-$(get_fqdn)} ${_hn} localhost.localdomain localhost/" /etc/hosts
++
+--
+1.6.4.2
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index d7dfc4e26..aa6575496 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,16 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=2.0_rc3
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
depends="openrc"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-setup-alpine-add-the-hostname-to-etc-hosts.patch
"
license="GPL-2"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i ../0001-setup-alpine-add-the-hostname-to-etc-hosts.patch \
+ || return 1
make || return 1
make install PREFIX= DESTDIR="$pkgdir"
@@ -18,4 +21,5 @@ build() {
ln -s lbu "$pkgdir"/sbin/lbu_$i
done
}
-md5sums="54810ee972f0d9c9a992f706af8feb43 alpine-conf-2.0_rc3.tar.bz2"
+md5sums="54810ee972f0d9c9a992f706af8feb43 alpine-conf-2.0_rc3.tar.bz2
+c91b9ca722dfbb479e0739d905211f94 0001-setup-alpine-add-the-hostname-to-etc-hosts.patch"
diff --git a/main/neon/APKBUILD b/main/neon/APKBUILD
index 76d099e47..979a4186b 100644
--- a/main/neon/APKBUILD
+++ b/main/neon/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=neon
pkgver=0.28.4
-pkgrel=1
+pkgrel=2
pkgdesc="HTTP and WebDAV client library with a C interface"
url="http://www.webdav.org/neon/"
license="GPL LGPL"
-depends="openssl zlib expat"
makedepends="expat-dev openssl-dev zlib-dev"
+depends=
+depends_dev="$makedepends"
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.webdav.org/$pkgname/$pkgname-$pkgver.tar.gz"
diff --git a/x11/a52dec/APKBUILD b/x11/a52dec/APKBUILD
new file mode 100644
index 000000000..8d3b868d2
--- /dev/null
+++ b/x11/a52dec/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=a52dec
+pkgver=0.7.4
+pkgrel=0
+pkgdesc="liba52 is a free library for decoding ATSC A/52 streams."
+url="http://liba52.sourceforge.net/"
+license="GPL2"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="autoconf automake libtool"
+source="http://liba52.sourceforge.net/files/$pkgname-$pkgver.tar.gz
+ $pkgname-$pkgver-build.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/a52dec-0.7.4-build.patch || return 1
+ ./bootstrap || return 1
+ ./configure --prefix=/usr \
+ --enable-shared \
+ || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 liba52/a52_internal.h "$pkgdir"/usr/include/a52dec/ || return 1
+}
+md5sums="caa9f5bc44232dc8aeea773fea56be80 a52dec-0.7.4.tar.gz
+fa16f224a7dceb7613824380abef0052 a52dec-0.7.4-build.patch"
diff --git a/x11/a52dec/a52dec-0.7.4-build.patch b/x11/a52dec/a52dec-0.7.4-build.patch
new file mode 100644
index 000000000..f3a29f303
--- /dev/null
+++ b/x11/a52dec/a52dec-0.7.4-build.patch
@@ -0,0 +1,27 @@
+diff -Naur a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am
+--- a52dec-0.7.4.orig/liba52/Makefile.am 2002-01-27 20:36:48.000000000 -0800
++++ a52dec-0.7.4/liba52/Makefile.am 2004-11-05 01:10:21.317401872 -0800
+@@ -1,4 +1,3 @@
+-CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
+
+ lib_LTLIBRARIES = liba52.la
+
+diff -Naur a52dec-0.7.4.orig/liba52/configure.incl a52dec-0.7.4/liba52/configure.incl
+--- a52dec-0.7.4.orig/liba52/configure.incl 2002-01-27 20:36:48.000000000 -0800
++++ a52dec-0.7.4/liba52/configure.incl 2004-11-05 01:11:38.172672216 -0800
+@@ -2,7 +2,6 @@
+ AC_SUBST([LIBA52_LIBS])
+
+ dnl avoid -fPIC when possible
+-LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic"
+
+ AC_ARG_ENABLE([double],
+ [ --enable-double use double-precision samples])
+diff -Naur a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am
+--- a52dec-0.7.4.orig/src/Makefile.am 2002-06-22 18:51:57.000000000 -0700
++++ a52dec-0.7.4/src/Makefile.am 2004-11-05 01:10:21.320401375 -0800
+@@ -1,4 +1,3 @@
+-CFLAGS = @A52DEC_CFLAGS@
+
+ bin_PROGRAMS = a52dec extract_a52
+ a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c
diff --git a/x11/gst-plugins-bad/APKBUILD b/x11/gst-plugins-bad/APKBUILD
new file mode 100644
index 000000000..97eb64f26
--- /dev/null
+++ b/x11/gst-plugins-bad/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-bad
+pkgver=0.10.14
+pkgrel=0
+pkgdesc="GStreamer bad plugins"
+url="http://gstreamer.freedesktop.org/"
+license="LGPL GPL"
+depends=""
+makedepends="pkgconfig gst-plugins-base-dev gstreamer-dev xvidcore-dev
+ bzip2-dev neon-dev faac-dev libexif-dev faad2-dev glib-dev liboil-dev
+ alsa-lib-dev libx11-dev sdl-dev"
+
+#'libdca>=0.0.5' 'bzip2' 'libdc1394>=2.1.0' 'exempi>=2.1.0' 'jack-audio-connection-kit>=0.116.2' 'neon>=0.28.4' 'faac>=1.28' 'libexif>=0.6.17' 'musicbrainz>=2.1.5' 'faad2>=2.7' 'libmms>=0.4' 'libcdaudio>=0.99.12' 'libmpcdec>=1.2.6' 'mjpegtools>=1.9.0' 'libdvdnav>=4.1.3' 'libmodplug>=0.8.7' 'jasper>=1.900.1' 'liblrdf>=0.4.0' 'libofa>=0.9.3')
+source="http://gstreamer.freedesktop.org//src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.bz2"
+
+build ()
+{
+ cd ""$srcdir"/gst-plugins-bad-$pkgver"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" \
+ || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="6be38b04fc76cdfef3a3b02b8434efa2 gst-plugins-bad-0.10.14.tar.bz2"
diff --git a/x11/gst-plugins-ugly/APKBUILD b/x11/gst-plugins-ugly/APKBUILD
new file mode 100644
index 000000000..290180409
--- /dev/null
+++ b/x11/gst-plugins-ugly/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-ugly
+pkgver=0.10.11
+pkgrel=0
+pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
+url="http://gstreamer.freedesktop.org/"
+license="LGPL"
+depends= #"gstreamer0.10-ugly>=0.10.11 libdvdread>=4.1.3 lame>=3.98.2 libmpeg2>=0.5.1 a52dec>=0.7.4 libid3tag>=0.15.1b libmad>=0.15.1b libsidplay>=1.36.59 libcdio>=0.81"
+makedepends="pkgconfig lame-dev libmpeg2-dev a52dec-dev libid3tag-dev
+ libmad-dev glib-dev liboil-dev gstreamer-dev gst-plugins-base-dev"
+source="http://gstreamer.freedesktop.org//src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="dfe2e201e066a3e86a9598b6769d9739 gst-plugins-ugly-0.10.11.tar.bz2"
diff --git a/x11/libmpeg2/APKBUILD b/x11/libmpeg2/APKBUILD
new file mode 100644
index 000000000..8b44458e3
--- /dev/null
+++ b/x11/libmpeg2/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmpeg2
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="libmpeg2 is a library for decoding MPEG-1 and MPEG-2 video streams."
+url="http://libmpeg2.sourceforge.net/"
+license="GPL2"
+subpackages="$pkgname-dev $pkgname-doc mpeg2dec"
+depends=
+makedepends="libx11-dev libice-dev libsm-dev libxext-dev libxv-dev"
+source="http://$pkgname.sourceforge.net/files/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static || return 1
+ make OPT_CFLAGS="${CFLAGS}" \
+ MPEG2DEC_CFLAGS="${CFLAGS}" \
+ LIBMPEG2_CFLAGS="" || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+mpeg2dec() {
+ pkgdesc="a test program for libmpeg2"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mpeg2dec "$subpkgdir"/usr/bin/
+}
+
+md5sums="0f92c7454e58379b4a5a378485bbd8ef libmpeg2-0.5.1.tar.gz"
diff --git a/x11/swfdec-mozilla/APKBUILD b/x11/swfdec-mozilla/APKBUILD
new file mode 100644
index 000000000..b2409e8da
--- /dev/null
+++ b/x11/swfdec-mozilla/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=swfdec-mozilla
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="free plugin for Mozilla browsers that uses the Swfdec library for playing SWF files"
+url="http://swfdec.freedesktop.org"
+license="LGPL"
+makedepends="swfdec-dev"
+depends=
+source="http://swfdec.freedesktop.org/download/$pkgname/0.8/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static \
+ --with-plugin-dir=/usr/lib/mozilla/plugins/
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="716632e0d35b3c1582c180569ba30346 swfdec-mozilla-0.8.2.tar.gz"
diff --git a/x11/swfdec/APKBUILD b/x11/swfdec/APKBUILD
index b785c63b3..3225d0a46 100644
--- a/x11/swfdec/APKBUILD
+++ b/x11/swfdec/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=swfdec
pkgver=0.8.4
-pkgrel=0
+pkgrel=1
pkgdesc="free library for decoding and rendering Flash animations"
url="http://swfdec.freedesktop.org"
license="LGPL"
@@ -9,6 +9,8 @@ subpackages="$pkgname-dev $pkgname-doc"
makedepends="alsa-lib-dev liboil-dev gtk+-dev libsoup-dev gstreamer-dev
gst-plugins-base-dev"
depends=
+depends_dev="glib-dev liboil-dev cairo-dev pango-dev gtk+-dev libsoup-dev
+ gstreamer-dev gst-plugins-base-dev alsa-lib-dev"
source="http://$pkgname.freedesktop.org/download/$pkgname/0.8/$pkgname-$pkgver.tar.gz"
build ()