summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot <root@b-25-6elab-vsrv-1.(none)>2009-05-06 14:52:29 +0000
committerroot <root@b-25-6elab-vsrv-1.(none)>2009-05-06 14:52:29 +0000
commit6a4d7e81f3565b5c531abedf0b81d988391f5e92 (patch)
tree923f0cdc4358259ec631f3ea343a400e029bced4
parent049ee43b7be8ce7acf3653595b547d9c79b0f60a (diff)
parentadc39c7834978ec3a4466d7d24c4ecf7e3a6cdb8 (diff)
downloadaports-6a4d7e81f3565b5c531abedf0b81d988391f5e92.tar.bz2
aports-6a4d7e81f3565b5c531abedf0b81d988391f5e92.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--core/alpine-conf/APKBUILD12
-rw-r--r--core/alpine-conf/alpine-conf-cdrom.patch13
-rw-r--r--core/apk-tools/APKBUILD5
-rw-r--r--extra/imagemagick/APKBUILD6
-rw-r--r--extra/libtasn1/APKBUILD4
-rw-r--r--extra/mpg123/APKBUILD4
-rw-r--r--extra/sed/APKBUILD6
-rw-r--r--extra/shorewall-common/APKBUILD4
-rw-r--r--extra/shorewall-lite/APKBUILD4
-rw-r--r--extra/shorewall-perl/APKBUILD7
-rw-r--r--extra/shorewall-shell/APKBUILD7
-rw-r--r--extra/shorewall/APKBUILD2
12 files changed, 30 insertions, 44 deletions
diff --git a/core/alpine-conf/APKBUILD b/core/alpine-conf/APKBUILD
index df67426a4..ccc0985fc 100644
--- a/core/alpine-conf/APKBUILD
+++ b/core/alpine-conf/APKBUILD
@@ -1,25 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
-pkgver=2.0_alpha7
-pkgrel=1
+pkgver=2.0_alpha8
+pkgrel=0
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
depends="openrc"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
- alpine-conf-cdrom.patch
"
license="GPL-2"
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < ../alpine-conf-cdrom.patch || return 1
-
- make PREFIX= || return 1
+ make || return 1
make install PREFIX= DESTDIR="$pkgdir"
for i in commit exclude include status update; do
ln -s lbu "$pkgdir"/sbin/lbu_$i
done
}
-md5sums="f9eb1fa25b25f2e0c5597642dfca8a2e alpine-conf-2.0_alpha7.tar.bz2
-3c31743872275262350dde3b813df9f8 alpine-conf-cdrom.patch"
+md5sums="d1cd127629dd9f15739bdbce28583f6f alpine-conf-2.0_alpha8.tar.bz2"
diff --git a/core/alpine-conf/alpine-conf-cdrom.patch b/core/alpine-conf/alpine-conf-cdrom.patch
deleted file mode 100644
index 2748273a4..000000000
--- a/core/alpine-conf/alpine-conf-cdrom.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup-disk b/setup-disk
-index 96a87bb..b7d8323 100644
---- a/setup-disk
-+++ b/setup-disk
-@@ -44,7 +44,7 @@ useall() {
- echo ""
- # make things bootable
- kernel=$(ls /mnt/lib/modules)
-- chroot /mnt /sbin/mkinitfs -F "ata base bootchart ext3 ide scsi usb" $kernel
-+ chroot /mnt /sbin/mkinitfs -F "ata base bootchart cdrom ext3 ide scsi usb" $kernel
-
- # create an extlinux.conf
- sed '/append initrd/d' /media/*/syslinux.cfg > /mnt/boot/extlinux.conf
diff --git a/core/apk-tools/APKBUILD b/core/apk-tools/APKBUILD
index 3cfc3984c..d518586ae 100644
--- a/core/apk-tools/APKBUILD
+++ b/core/apk-tools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.0_pre10
+pkgver=2.0_pre11
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
depends="uclibc"
@@ -11,6 +11,7 @@ license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's:-Werror::' Make.rules
make
make DESTDIR="$pkgdir" install
cd "$pkgdir/sbin"
@@ -22,4 +23,4 @@ build() {
ln -s apk apk_version
}
-md5sums="7469f5e314109fba4c4e7d43889964ca apk-tools-2.0_pre10.tar.bz2"
+md5sums="1befa14958bebfe141bbb027937e3043 apk-tools-2.0_pre11.tar.bz2"
diff --git a/extra/imagemagick/APKBUILD b/extra/imagemagick/APKBUILD
index b42bdbcd2..6df8f894a 100644
--- a/extra/imagemagick/APKBUILD
+++ b/extra/imagemagick/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imagemagick
-pkgver=6.5.0.10
-_pkgver=6.5.0-10
+pkgver=6.5.2.1
+_pkgver=6.5.2-1
pkgrel=0
pkgdesc="A collection of tools and libraries for many image formats"
url="http://www.imagemagick.org/"
@@ -32,4 +32,4 @@ build() {
}
-md5sums="2d9d4440e3ae5c8da4b39402e9ce4d4a ImageMagick-6.5.0-10.tar.gz"
+md5sums="e6e691002f15b1490983752cc61238cc ImageMagick-6.5.2-1.tar.gz"
diff --git a/extra/libtasn1/APKBUILD b/extra/libtasn1/APKBUILD
index b4bc24f21..c4148df92 100644
--- a/extra/libtasn1/APKBUILD
+++ b/extra/libtasn1/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtasn1
-pkgver=2.0
+pkgver=2.1
pkgrel=0
pkgdesc="The ASN.1 library used in GNUTLS"
url="http://www.gnu.org/software/gnutls/"
@@ -17,4 +17,4 @@ build() {
make || return 1
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="e9b1462f04b2586b03905b0ed9528261 libtasn1-2.0.tar.gz"
+md5sums="9c6869cca08b7392415c7939ffd2bbae libtasn1-2.1.tar.gz"
diff --git a/extra/mpg123/APKBUILD b/extra/mpg123/APKBUILD
index f359b7b38..51d252c53 100644
--- a/extra/mpg123/APKBUILD
+++ b/extra/mpg123/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpg123
-pkgver=1.7.2
+pkgver=1.7.3
pkgrel=0
pkgdesc="A console based real time MPEG Audio Player for Layer 1, 2 and 3"
url="http://sourceforge.net/projects/mpg123"
@@ -22,4 +22,4 @@ build() {
make || return 1
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="0942f50498e024687811f663e8bf4790 mpg123-1.7.2.tar.bz2"
+md5sums="2123db16c22a1fe3c5517c1551aa9d8b mpg123-1.7.3.tar.bz2"
diff --git a/extra/sed/APKBUILD b/extra/sed/APKBUILD
index 7d0a064b8..653790c02 100644
--- a/extra/sed/APKBUILD
+++ b/extra/sed/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sed
-pkgver=4.1.5
-pkgrel=3
+pkgver=4.2
+pkgrel=0
subpackages="$pkgname-doc"
pkgdesc="GNU stream editor"
url="http://www.gnu.org/software/sed"
@@ -23,5 +23,5 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="7a1cbbbb3341287308e140bd4834c3ba sed-4.1.5.tar.gz
+md5sums="31580bee0c109c0fc8f31c4cf204757e sed-4.2.tar.gz
b84506d253e04db3c5af9016fead45a3 sed.post-deinstall"
diff --git a/extra/shorewall-common/APKBUILD b/extra/shorewall-common/APKBUILD
index 2203df86f..ce0562f3a 100644
--- a/extra/shorewall-common/APKBUILD
+++ b/extra/shorewall-common/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-common
-pkgver=4.2.7
+pkgver=4.2.8
pkgrel=0
pkgdesc="Shoreline Firewall is an iptables-based firewall for Linux."
url="http://www.shorewall.net/"
@@ -17,5 +17,5 @@ build() {
PREFIX="${pkgdir}" ./install.sh || return 1
install -Dm755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
-md5sums="47f51b083bdea3904ffaf3a3c9317526 shorewall-common-4.2.7.tar.bz2
+md5sums="e5d0eb7539b7c96b381ff2680eac5888 shorewall-common-4.2.8.tar.bz2
71fb6da1f50f5c6e9dd35b60b3629531 shorewall.initd"
diff --git a/extra/shorewall-lite/APKBUILD b/extra/shorewall-lite/APKBUILD
index d77d4accc..1b5ff834f 100644
--- a/extra/shorewall-lite/APKBUILD
+++ b/extra/shorewall-lite/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-lite
-pkgver=4.2.7
+pkgver=4.2.8
pkgrel=0
pkgdesc="An iptables-based firewall whose config is handled by a normal Shorewall"
url="http://www.shorewall.net/"
@@ -16,5 +16,5 @@ build() {
PREFIX="$pkgdir" ./install.sh || return 1
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="7a18ae9de56aa1836e67b394a5176fc4 shorewall-lite-4.2.7.tar.bz2
+md5sums="09fe67bae13d14638b97a9e769a87e73 shorewall-lite-4.2.8.tar.bz2
17a37c934aeb601ce288f77000253e1e shorewall-lite.initd"
diff --git a/extra/shorewall-perl/APKBUILD b/extra/shorewall-perl/APKBUILD
index c56228d7b..d74c622de 100644
--- a/extra/shorewall-perl/APKBUILD
+++ b/extra/shorewall-perl/APKBUILD
@@ -1,15 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-perl
-pkgver=4.2.7.3
+pkgver=4.2.8.2
+_v=4.2.8
pkgrel=0
pkgdesc="Shoreline Firewall Perl-based compiler"
url="http://www.shorewall.net/"
license="GPL-2"
depends="shorewall-common"
-source="http://www1.shorewall.net/pub/shorewall/4.2/shorewall-4.2.7/$pkgname-$pkgver.tar.bz2"
+source="http://www1.shorewall.net/pub/shorewall/${_v%.*}/shorewall-${_v}/$pkgname-$pkgver.tar.bz2"
build() {
cd "$srcdir"/$pkgname-$pkgver
PREFIX="$pkgdir" ./install.sh || return 1
}
-md5sums="40f2e1a0b10a5fb40bf177f2653ed38b shorewall-perl-4.2.7.3.tar.bz2"
+md5sums="9b5bdb36e2f8fd98dc15a29da0da14b7 shorewall-perl-4.2.8.2.tar.bz2"
diff --git a/extra/shorewall-shell/APKBUILD b/extra/shorewall-shell/APKBUILD
index 04117e66a..f7b6aaa64 100644
--- a/extra/shorewall-shell/APKBUILD
+++ b/extra/shorewall-shell/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall-shell
-pkgver=4.2.7
+_v=4.2.8
+pkgver=4.2.8
pkgrel=0
pkgdesc="Shoreline Firewall shell-based compiler."
url="http://www.shorewall.net/"
license="GPL-2"
depends="shorewall-common"
#subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/4.2/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2"
+source="http://www.shorewall.net/pub/shorewall/${_v%.*}/shorewall-$_v/$pkgname-$pkgver.tar.bz2"
build() {
cd "$srcdir"/$pkgname-$pkgver
PREFIX="$pkgdir" ./install.sh || return 1
}
-md5sums="c5555ef10e493af3d3ad40785bf33caa shorewall-shell-4.2.7.tar.bz2"
+md5sums="b20e72f4ec39f0cd13e5389627d20a42 shorewall-shell-4.2.8.tar.bz2"
diff --git a/extra/shorewall/APKBUILD b/extra/shorewall/APKBUILD
index cc01fdea7..9b3fa0cac 100644
--- a/extra/shorewall/APKBUILD
+++ b/extra/shorewall/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.2.7
+pkgver=4.2.8
pkgrel=0
pkgdesc="Meta package for shorewall"
url="http://www.shorewall.net/"