summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-17 12:52:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-17 13:14:43 +0000
commit8feb1753e77ef4b03303598e018aa44746f7e8e9 (patch)
tree35c9f302aa5e6ef03c48af41d7eb5c996d5fe219
parent67e77b0b7891f1ee6351952ff38835c7b9cb749d (diff)
downloadaports-8feb1753e77ef4b03303598e018aa44746f7e8e9.tar.bz2
aports-8feb1753e77ef4b03303598e018aa44746f7e8e9.tar.xz
main/linux-grsec: hyper-v fix for synthetic NIC driver
-rw-r--r--main/linux-grsec/0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch42
-rw-r--r--main/linux-grsec/APKBUILD6
2 files changed, 47 insertions, 1 deletions
diff --git a/main/linux-grsec/0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch b/main/linux-grsec/0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch
new file mode 100644
index 000000000..3ba0a1e31
--- /dev/null
+++ b/main/linux-grsec/0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch
@@ -0,0 +1,42 @@
+Subject: [PATCH] staging: hv: fix netvsc sleeping while atomic
+Date: Fri, 17 Dec 2010 11:40:24 +0200
+Message-Id: <1292578824-14408-1-git-send-email-timo.teras@iki.fi>
+X-Mailer: git-send-email 1.7.1
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+X-Virus-Scanned: ClamAV using ClamSMTP
+Status: O
+Content-Length: 845
+Lines: 29
+
+The channel callbacks are called directly from vmbus_event_dpc
+which runs in tasklet context. These callbacks need to use
+GFP_ATOMIC.
+
+Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=16701
+
+Cc: Hank Janssen <hjanssen@microsoft.com>
+Cc: Haiyang Zhang <haiyangz@microsoft.com>
+Signed-off-by: Timo Teräs <timo.teras@iki.fi>
+---
+ drivers/staging/hv/netvsc.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/drivers/staging/hv/netvsc.c b/drivers/staging/hv/netvsc.c
+index 8022781..3784923 100644
+--- a/drivers/staging/hv/netvsc.c
++++ b/drivers/staging/hv/netvsc.c
+@@ -1236,7 +1236,7 @@ static void NetVscOnChannelCallback(void *Context)
+ /* ASSERT(device); */
+
+ packet = kzalloc(NETVSC_PACKET_SIZE * sizeof(unsigned char),
+- GFP_KERNEL);
++ GFP_ATOMIC);
+ if (!packet)
+ return;
+ buffer = packet;
+--
+1.7.1
+
+
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 37bf39d0a..4021b6a4b 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.35.9
_kernver=2.6.35
-pkgrel=3
+pkgrel=5
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -20,7 +20,10 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
0004-arp-flush-arp-cache-on-device-change.patch
r8169-fix-rx-checksum-offload.patch
r8169-add-gro-support.patch
+
0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
+ 0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch
+
setlocalversion.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -153,6 +156,7 @@ ea7a7eb2775b71ae5ef24d029a4905bd xfrm-fix-gre-key-endianess.patch
0ccecafd4123dcad0b0cd7787553d734 r8169-fix-rx-checksum-offload.patch
139b39da44ecb577275be53d7d365949 r8169-add-gro-support.patch
648d8b477248f233c318a3b7a961febf 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
+7cae2d1e1947fa57d7aaaf31c649471c 0004-staging-hv-fix-netvsc-sleeping-while-atomic.patch
8c224ba0cdf0aa572c7eb50379435be4 setlocalversion.patch
a9494f66196bc6308da0f129221d31b8 kernelconfig.x86
b38f1f99f8f3b75c52d4a1ab2b0d13fd kernelconfig.x86_64"