summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-10-08 20:02:19 +0000
committerMichael Mason <ms13sp@gmail.com>2009-10-08 20:02:19 +0000
commita3f80a81f393f8509fbc2f6ff5e89ba04c7e5f2b (patch)
tree4b83cccd2b7c1723f4571e2033ab33c13d638776
parent87283e2153e3ffbbbd2375cc300674e9fc2ea424 (diff)
parent0e73bc9f5f2c536807b52ad12ff70cb03cd9e7bf (diff)
downloadaports-a3f80a81f393f8509fbc2f6ff5e89ba04c7e5f2b.tar.bz2
aports-a3f80a81f393f8509fbc2f6ff5e89ba04c7e5f2b.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/quagga/APKBUILD14
-rw-r--r--main/quagga/quagga-0.99.11-fd-leak.patch19
-rw-r--r--main/quagga/quagga-0.99.11-ipv6-only.patch29
-rw-r--r--main/quagga/quagga-0.99.11-zombie.patch29
-rw-r--r--main/quagga/quagga-revert-confed-check.patch97
-rw-r--r--main/squid/APKBUILD11
-rw-r--r--main/squid/squid-2.7-ims-content-type.patch11
-rw-r--r--testing/kqemu-grsec/APKBUILD (renamed from main/kqemu-grsec/APKBUILD)0
-rw-r--r--testing/kqemu-vserver/APKBUILD33
-rw-r--r--testing/linux-vserver/APKBUILD6
-rw-r--r--testing/linux-vserver/kernelconfig24
-rw-r--r--testing/util-vserver/APKBUILD24
-rw-r--r--testing/util-vserver/alpine.patch21
-rw-r--r--testing/util-vserver/chmod.patch12
-rw-r--r--testing/util-vserver/ensc_pathprog.patch14
-rw-r--r--testing/util-vserver/validate.patch10
16 files changed, 245 insertions, 109 deletions
diff --git a/main/quagga/APKBUILD b/main/quagga/APKBUILD
index 0b28d992e..a823126c0 100644
--- a/main/quagga/APKBUILD
+++ b/main/quagga/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quagga
-pkgver=0.99.13
-pkgrel=2
+pkgver=0.99.15
+pkgrel=1
pkgdesc="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP."
url="http://quagga.net/"
license="GPL-2"
@@ -12,10 +12,8 @@ install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.quagga.net/download/$pkgname-$pkgver.tar.gz
$pkgname-0.99.11-link-libcap.patch
- $pkgname-0.99.11-ipv6-only.patch
$pkgname-0.99.11-del-routes.patch
- $pkgname-0.99.11-zombie.patch
- $pkgname-0.99.11-fd-leak.patch
+ quagga-revert-confed-check.patch
bgpd.initd
ospf6d.initd
ospfd.initd
@@ -61,12 +59,10 @@ build() {
done
install -Dm644 "$srcdir/zebra.confd" "$pkgdir"/etc/conf.d/zebra
}
-md5sums="55a7d2dcf016580a7c7412b3518cd942 quagga-0.99.13.tar.gz
+md5sums="8975414c76a295f4855a417af0b5ddce quagga-0.99.15.tar.gz
8f99d41a8ed79e51704e8f655d255f29 quagga-0.99.11-link-libcap.patch
-44c517e988273e0e5076d24f3959a125 quagga-0.99.11-ipv6-only.patch
1cbcf60a637b2577dee4d6df711e1247 quagga-0.99.11-del-routes.patch
-ce345725f2e7240cebe0fd5ac2b2fc48 quagga-0.99.11-zombie.patch
-e2391e19b542ec1743776ca9e36ac11a quagga-0.99.11-fd-leak.patch
+9a9ad8ac543901f3eab6a6f2a914b69d quagga-revert-confed-check.patch
c4c3b174b1e3400a143407fcc3d27cf5 bgpd.initd
92aba039c049050c48abf984c2db7e2b ospf6d.initd
878328ead225e6eb5f5f77f05ab39106 ospfd.initd
diff --git a/main/quagga/quagga-0.99.11-fd-leak.patch b/main/quagga/quagga-0.99.11-fd-leak.patch
deleted file mode 100644
index e558d30a6..000000000
--- a/main/quagga/quagga-0.99.11-fd-leak.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- quagga-0.99.11.DIST/bgpd/bgp_fsm.c 2008-09-09 16:18:57.000000000 -0400
-+++ quagga-0.99.11/bgpd/bgp_fsm.c 2009-04-13 13:09:25.000000000 -0400
-@@ -1013,11 +1013,11 @@
- {
- /* Clearing, */
- {bgp_ignore, Clearing}, /* BGP_Start */
-- {bgp_ignore, Clearing}, /* BGP_Stop */
-- {bgp_ignore, Clearing}, /* TCP_connection_open */
-- {bgp_ignore, Clearing}, /* TCP_connection_closed */
-- {bgp_ignore, Clearing}, /* TCP_connection_open_failed */
-- {bgp_ignore, Clearing}, /* TCP_fatal_error */
-+ {bgp_stop, Clearing}, /* BGP_Stop */
-+ {bgp_stop, Clearing}, /* TCP_connection_open */
-+ {bgp_stop, Clearing}, /* TCP_connection_closed */
-+ {bgp_stop, Clearing}, /* TCP_connection_open_failed */
-+ {bgp_stop, Clearing}, /* TCP_fatal_error */
- {bgp_ignore, Clearing}, /* ConnectRetry_timer_expired */
- {bgp_ignore, Clearing}, /* Hold_Timer_expired */
- {bgp_ignore, Clearing}, /* KeepAlive_timer_expired */
diff --git a/main/quagga/quagga-0.99.11-ipv6-only.patch b/main/quagga/quagga-0.99.11-ipv6-only.patch
deleted file mode 100644
index 53636d6b5..000000000
--- a/main/quagga/quagga-0.99.11-ipv6-only.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-On Linux the default behaviour of getaddrinfo is to provide both IPV4 and IPV6
-addresses if available. But the default behaviour of binding to an IPV6 address
-is to handle both the native IPV6 address and IPV4 to IPV6 mapped addresses.
-Without this patch what happens is:
- 1. First address is IPV6, bind succeeds.
- 2. Second address is IPV4, bind fails (port already used by IPV6)
- 3. incoming connections come in on IPV6 listen socket, as IPV4 mapped
- addresses then BGP gets confused because of client with unexpected address.
-
-The fix is to force IPV6 socket as IPV6 only.
-
---- a/bgpd/bgp_network.c 2008-08-27 17:59:20.000000000 -0700
-+++ b/bgpd/bgp_network.c 2008-08-27 18:02:46.000000000 -0700
-@@ -412,6 +412,15 @@ bgp_socket (struct bgp *bgp, unsigned sh
- setsockopt_ipv4_tos (sock, IPTOS_PREC_INTERNETCONTROL);
- #endif
-
-+#ifdef IPV6_V6ONLY
-+ /* Want only IPV6 on ipv6 socket (not mapped addresses) */
-+ if (ainfo->ai_family == AF_INET6) {
-+ int on = 1;
-+ setsockopt (sock, IPPROTO_IPV6, IPV6_V6ONLY,
-+ (void *) &on, sizeof (on));
-+ }
-+#endif
-+
- if (bgpd_privs.change (ZPRIVS_RAISE) )
- zlog_err ("bgp_socket: could not raise privs");
-
diff --git a/main/quagga/quagga-0.99.11-zombie.patch b/main/quagga/quagga-0.99.11-zombie.patch
deleted file mode 100644
index ad562df00..000000000
--- a/main/quagga/quagga-0.99.11-zombie.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-
-Currently, when accepting the connection, it can be left as zombie,
-when the peer just initiates a connection, but never sends data (and
-the TCP connection end packets are lost). This happens because for
-accepted connections a temporary new peer entry is created until OPEN
-message is exchanged, and this temporary peer entry does not get the
-hold time parameter set at all.
-
-Signed-off-by: Timo Teras <timo.teras@iki.fi>
----
- bgpd/bgp_network.c | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/bgpd/bgp_network.c b/bgpd/bgp_network.c
-index 5dbd487..9a4c36d 100644
---- a/bgpd/bgp_network.c
-+++ b/bgpd/bgp_network.c
-@@ -185,6 +185,8 @@ bgp_accept (struct thread *thread)
- peer->fd = bgp_sock;
- peer->status = Active;
- peer->local_id = peer1->local_id;
-+ peer->v_holdtime = peer1->v_holdtime;
-+ peer->v_keepalive = peer1->v_keepalive;
-
- /* Make peer's address string. */
- sockunion2str (&su, buf, SU_ADDRSTRLEN);
---
-1.5.6.3
-
diff --git a/main/quagga/quagga-revert-confed-check.patch b/main/quagga/quagga-revert-confed-check.patch
new file mode 100644
index 000000000..3c76d1dd1
--- /dev/null
+++ b/main/quagga/quagga-revert-confed-check.patch
@@ -0,0 +1,97 @@
+From b6c5e59e39e9513232c4e26faf30218e820f38a8 Mon Sep 17 00:00:00 2001
+From: Timo Teras <timo.teras@iki.fi>
+Date: Thu, 8 Oct 2009 21:46:28 +0300
+Subject: [PATCH] Revert "bgpd: Implement BGP confederation error handling (RFC5065, Par. 5)"
+
+This reverts commit ca87e1d37b3c30648e9bacb476a3c89729512f6d.
+---
+ bgpd/bgp_aspath.c | 36 ------------------------------------
+ bgpd/bgp_aspath.h | 2 --
+ bgpd/bgp_attr.c | 11 -----------
+ 3 files changed, 0 insertions(+), 49 deletions(-)
+
+diff --git a/bgpd/bgp_aspath.c b/bgpd/bgp_aspath.c
+index 440815b..e43d1f1 100644
+--- a/bgpd/bgp_aspath.c
++++ b/bgpd/bgp_aspath.c
+@@ -1122,42 +1122,6 @@ aspath_private_as_check (struct aspath *aspath)
+ return 1;
+ }
+
+-/* AS path confed check. If aspath contains confed set or sequence then return 1. */
+-int
+-aspath_confed_check (struct aspath *aspath)
+-{
+- struct assegment *seg;
+-
+- if ( !(aspath && aspath->segments) )
+- return 0;
+-
+- seg = aspath->segments;
+-
+- while (seg)
+- {
+- if (seg->type == AS_CONFED_SET || seg->type == AS_CONFED_SEQUENCE)
+- return 1;
+- seg = seg->next;
+- }
+- return 0;
+-}
+-
+-/* Leftmost AS path segment confed check. If leftmost AS segment is of type
+- AS_CONFED_SEQUENCE or AS_CONFED_SET then return 1. */
+-int
+-aspath_left_confed_check (struct aspath *aspath)
+-{
+-
+- if ( !(aspath && aspath->segments) )
+- return 0;
+-
+- if ( (aspath->segments->type == AS_CONFED_SEQUENCE)
+- || (aspath->segments->type == AS_CONFED_SET) )
+- return 1;
+-
+- return 0;
+-}
+-
+ /* Merge as1 to as2. as2 should be uninterned aspath. */
+ static struct aspath *
+ aspath_merge (struct aspath *as1, struct aspath *as2)
+diff --git a/bgpd/bgp_aspath.h b/bgpd/bgp_aspath.h
+index 9854d18..2b4625c 100644
+--- a/bgpd/bgp_aspath.h
++++ b/bgpd/bgp_aspath.h
+@@ -88,8 +88,6 @@ extern unsigned int aspath_key_make (void *);
+ extern int aspath_loop_check (struct aspath *, as_t);
+ extern int aspath_private_as_check (struct aspath *);
+ extern int aspath_firstas_check (struct aspath *, as_t);
+-extern int aspath_confed_check (struct aspath *);
+-extern int aspath_left_confed_check (struct aspath *);
+ extern unsigned long aspath_count (void);
+ extern unsigned int aspath_count_hops (struct aspath *);
+ extern unsigned int aspath_count_confeds (struct aspath *);
+diff --git a/bgpd/bgp_attr.c b/bgpd/bgp_attr.c
+index 5e7536a..0668e9a 100644
+--- a/bgpd/bgp_attr.c
++++ b/bgpd/bgp_attr.c
+@@ -872,17 +872,6 @@ static int bgp_attr_aspath_check( struct peer *peer,
+
+ bgp = peer->bgp;
+
+- /* Confederation sanity check. */
+- if ((peer_sort (peer) == BGP_PEER_CONFED && ! aspath_left_confed_check (attr->aspath)) ||
+- (peer_sort (peer) == BGP_PEER_EBGP && aspath_confed_check (attr->aspath)))
+- {
+- zlog (peer->log, LOG_ERR, "Malformed AS path from %s", peer->host);
+- bgp_notify_send (peer,
+- BGP_NOTIFY_UPDATE_ERR,
+- BGP_NOTIFY_UPDATE_MAL_AS_PATH);
+- return -1;
+- }
+-
+ /* First AS check for EBGP. */
+ if (bgp != NULL && bgp_flag_check (bgp, BGP_FLAG_ENFORCE_FIRST_AS))
+ {
+--
+1.6.0.4
+
diff --git a/main/squid/APKBUILD b/main/squid/APKBUILD
index 01f7bfa74..66be7961f 100644
--- a/main/squid/APKBUILD
+++ b/main/squid/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=squid
-pkgver=2.7.6
-_ver=2.7.STABLE6
-pkgrel=12
+pkgver=2.7.7
+_ver=2.7.STABLE7
+pkgrel=0
pkgdesc="A full-featured Web proxy cache server."
url="http://www.squid-cache.org"
install="squid.pre-install squid.pre-upgrade squid.post-install"
@@ -52,6 +52,7 @@ source="http://www.squid-cache.org/Versions/v2/2.7/${pkgname}-${_ver}.tar.bz2
squid.initd
squid.confd
squid-2.7-gentoo.patch
+ squid-2.7-ims-content-type.patch
$pkgname.logrotate
"
pkgusers="squid"
@@ -61,6 +62,7 @@ build() {
cd "$srcdir/$pkgname-$_ver"
patch -p1 -i "$srcdir"/squid-2.7-gentoo.patch || return 1
+ patch -p1 -i "$srcdir"/squid-2.7-ims-content-type.patch || return 1
touch NEWS AUTHORS
aclocal && autoconf && automake -a || return 1
@@ -278,8 +280,9 @@ errors_ukrainian_utf8() {
}
-md5sums="6de3a6a7a56a7ecae092f2d31a04f039 squid-2.7.STABLE6.tar.bz2
+md5sums="c18b0371fca813d5e7c7e0baf87baa22 squid-2.7.STABLE7.tar.bz2
57fed05adc40acab6a5480ec7a014154 squid.initd
44b052db7910f386ef88ddcf69c9ba4e squid.confd
3827f71d940b47eb385a1a1d92a51d66 squid-2.7-gentoo.patch
+549377b5a6b673bf19ea6c34003d122c squid-2.7-ims-content-type.patch
58823e0b86bc2dc71d270208b7b284b4 squid.logrotate"
diff --git a/main/squid/squid-2.7-ims-content-type.patch b/main/squid/squid-2.7-ims-content-type.patch
new file mode 100644
index 000000000..8b66197e7
--- /dev/null
+++ b/main/squid/squid-2.7-ims-content-type.patch
@@ -0,0 +1,11 @@
+--- a/src/HttpReply.c.orig Wed Oct 7 07:08:08 2009
++++ b/src/HttpReply.c Wed Oct 7 07:08:20 2009
+@@ -43,7 +43,7 @@
+ static http_hdr_type Denied304HeadersArr[] =
+ {
+ HDR_CONTENT_ENCODING, HDR_CONTENT_LANGUAGE, HDR_CONTENT_LENGTH,
+- HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE
++ HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE, HDR_CONTENT_TYPE
+ };
+
+ /* local routines */
diff --git a/main/kqemu-grsec/APKBUILD b/testing/kqemu-grsec/APKBUILD
index b9527fa87..b9527fa87 100644
--- a/main/kqemu-grsec/APKBUILD
+++ b/testing/kqemu-grsec/APKBUILD
diff --git a/testing/kqemu-vserver/APKBUILD b/testing/kqemu-vserver/APKBUILD
new file mode 100644
index 000000000..eccb63bf4
--- /dev/null
+++ b/testing/kqemu-vserver/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+_flavor=vserver
+_realname=kqemu
+# source the kernel version
+if [ -f ../../testing/linux-$_flavor/APKBUILD ]; then
+ . ../../testing/linux-$_flavor/APKBUILD
+fi
+_kernelver=$pkgver-r$pkgrel
+_abi_release=$pkgver-${_flavor}
+
+pkgname=${_realname}-${_flavor}
+pkgver=1.4.0_pre1
+_realver=1.4.0pre1
+pkgrel=0
+pkgdesc="$_flavor kernel modules for kemu"
+url="http://www.nongnu.org/qemu/"
+license="GPL"
+depends="linux-${_flavor}=${_kernelver}"
+install=
+makedepends="linux-${_flavor}-dev=${_kernelver}"
+subpackages=
+source="http://www.nongnu.org/qemu/kqemu-$_realver.tar.gz"
+
+build() {
+ cd "$srcdir"/$_realname-$_realver
+ ./configure --kernel-path=/lib/modules/${_abi_release}/build
+ make || return 1
+ install -D -m644 kqemu.ko \
+ "$pkgdir"/lib/modules/${_abi_release}/misc/kqemu.ko \
+ || return 1
+}
+md5sums="d738d8ca7332211ab716ec3213d82ee1 kqemu-1.4.0pre1.tar.gz"
diff --git a/testing/linux-vserver/APKBUILD b/testing/linux-vserver/APKBUILD
index 245d1b11e..ba925b87f 100644
--- a/testing/linux-vserver/APKBUILD
+++ b/testing/linux-vserver/APKBUILD
@@ -4,11 +4,11 @@ _flavor=vserver
pkgname=linux-${_flavor}
pkgver=2.6.30.8
_kernver=2.6.30
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with vserver"
url="http://linux-vserver.org/"
depends="mkinitfs linux-firmware"
-makedepends="perl installkernel"
+makedepends="perl installkernel bash"
_config=${config:-kernelconfig}
install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
@@ -119,4 +119,4 @@ md5sums="7a80058a6382e5108cdb5554d1609615 linux-2.6.30.tar.bz2
7e9b405b840bf5ecc70d208bfccee5f9 patch-2.6.30.8.bz2
37e45dcf0eb69e8cc8665522dde28f1a patch-2.6.30.6-vs2.3.0.36.14-pre8.diff
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
-5db2d023915e69fbcab0e1eec4f31402 kernelconfig"
+0f32935a865e6b2ab9e4623a02f9d85a kernelconfig"
diff --git a/testing/linux-vserver/kernelconfig b/testing/linux-vserver/kernelconfig
index 2a3501250..b6db32b21 100644
--- a/testing/linux-vserver/kernelconfig
+++ b/testing/linux-vserver/kernelconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.30.7-vs2.3.0.36.14-pre8
-# Tue Sep 22 11:34:29 2009
+# Linux kernel version: 2.6.30.8-vs2.3.0.36.14-pre8
+# Mon Oct 5 08:18:08 2009
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -200,7 +200,6 @@ CONFIG_PARAVIRT_GUEST=y
CONFIG_VMI=y
# CONFIG_KVM_CLOCK is not set
CONFIG_KVM_GUEST=y
-CONFIG_LGUEST_GUEST=y
CONFIG_PARAVIRT=y
# CONFIG_PARAVIRT_SPINLOCKS is not set
# CONFIG_PARAVIRT_CLOCK is not set
@@ -245,6 +244,7 @@ CONFIG_X86_BSWAP=y
CONFIG_X86_POPAD_OK=y
CONFIG_X86_ALIGNMENT_16=y
CONFIG_X86_INTEL_USERCOPY=y
+CONFIG_X86_CMPXCHG64=y
CONFIG_X86_MINIMUM_CPU_FAMILY=4
# CONFIG_PROCESSOR_SELECT is not set
CONFIG_CPU_SUP_INTEL=y
@@ -280,8 +280,8 @@ CONFIG_X86_MSR=m
CONFIG_X86_CPUID=m
CONFIG_X86_CPU_DEBUG=m
# CONFIG_NOHIGHMEM is not set
-CONFIG_HIGHMEM4G=y
-# CONFIG_HIGHMEM64G is not set
+# CONFIG_HIGHMEM4G is not set
+CONFIG_HIGHMEM64G=y
CONFIG_VMSPLIT_3G=y
# CONFIG_VMSPLIT_3G_OPT is not set
# CONFIG_VMSPLIT_2G is not set
@@ -289,7 +289,8 @@ CONFIG_VMSPLIT_3G=y
# CONFIG_VMSPLIT_1G is not set
CONFIG_PAGE_OFFSET=0xC0000000
CONFIG_HIGHMEM=y
-# CONFIG_ARCH_PHYS_ADDR_T_64BIT is not set
+CONFIG_X86_PAE=y
+CONFIG_ARCH_PHYS_ADDR_T_64BIT=y
CONFIG_ARCH_FLATMEM_ENABLE=y
CONFIG_ARCH_SPARSEMEM_ENABLE=y
CONFIG_ARCH_SELECT_MEMORY_MODEL=y
@@ -302,7 +303,7 @@ CONFIG_FLAT_NODE_MEM_MAP=y
CONFIG_SPARSEMEM_STATIC=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_SPLIT_PTLOCK_CPUS=4
-# CONFIG_PHYS_ADDR_T_64BIT is not set
+CONFIG_PHYS_ADDR_T_64BIT=y
CONFIG_ZONE_DMA_FLAG=1
CONFIG_BOUNCE=y
CONFIG_VIRT_TO_BUS=y
@@ -1551,6 +1552,7 @@ CONFIG_IEEE1394_DV1394=m
CONFIG_I2O=m
CONFIG_I2O_LCT_NOTIFY_ON_CHANGES=y
CONFIG_I2O_EXT_ADAPTEC=y
+CONFIG_I2O_EXT_ADAPTEC_DMA64=y
CONFIG_I2O_CONFIG=m
CONFIG_I2O_CONFIG_OLD_IOCTL=y
CONFIG_I2O_BUS=m
@@ -2262,7 +2264,7 @@ CONFIG_PRINTER=m
# CONFIG_LP_CONSOLE is not set
CONFIG_PPDEV=m
CONFIG_HVC_DRIVER=y
-CONFIG_VIRTIO_CONSOLE=y
+CONFIG_VIRTIO_CONSOLE=m
CONFIG_IPMI_HANDLER=m
# CONFIG_IPMI_PANIC_EVENT is not set
CONFIG_IPMI_DEVICE_INTERFACE=m
@@ -3772,7 +3774,6 @@ CONFIG_RTC_DRV_PCF50633=m
#
# on-CPU RTC drivers
#
-# CONFIG_DMADEVICES is not set
CONFIG_AUXDISPLAY=y
CONFIG_KS0108=m
CONFIG_KS0108_PORT=0x378
@@ -4314,9 +4315,8 @@ CONFIG_KVM=m
CONFIG_KVM_INTEL=m
CONFIG_KVM_AMD=m
# CONFIG_KVM_TRACE is not set
-CONFIG_LGUEST=m
-CONFIG_VIRTIO=y
-CONFIG_VIRTIO_RING=y
+CONFIG_VIRTIO=m
+CONFIG_VIRTIO_RING=m
CONFIG_VIRTIO_PCI=m
CONFIG_VIRTIO_BALLOON=m
CONFIG_BINARY_PRINTF=y
diff --git a/testing/util-vserver/APKBUILD b/testing/util-vserver/APKBUILD
index 802315b95..31b076f4e 100644
--- a/testing/util-vserver/APKBUILD
+++ b/testing/util-vserver/APKBUILD
@@ -2,31 +2,47 @@
pkgname=util-vserver
pkgver=0.30.216_pre2841
_realver=0.30.216-pre2841
-pkgrel=1
+pkgrel=3
pkgdesc="Linux-VServer admin utilities"
url="http://www.nongnu.org/util-vserver/"
license="GPL"
# needs coreutils for touch -t
makedepends="iptables-dev e2fsprogs-dev beecrypt-dev autoconf automake
- pkgconfig coreutils"
+ pkgconfig libtool"
depends="bash"
source="http://people.linux-vserver.org/~dhozac/t/uv-testing/util-vserver-$_realver.tar.bz2
+ chmod.patch
+ ensc_pathprog.patch
+ validate.patch
+ alpine.patch
"
subpackages="$pkgname-doc $pkgname-dev"
build() {
local i
cd "$srcdir"/$pkgname-$_realver
+ patch -p1 -i ../chmod.patch || return 1
+ patch -p1 -i ../ensc_pathprog.patch || return 1
+ patch -p1 -i ../validate.patch || return 1
+ aclocal -I m4 && autoconf && automake && libtoolize || return 1
+
+ # this is an ugly workaround
+ sed -i -e "s:as_echo=.*:as_echo=echo:g" configure
./configure --prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc \
--with-initscripts=gentoo \
- --localstatedir=/var
+ --localstatedir=/var \
+ || return 1
make || return 1
make DESTDIR="$pkgdir/" install install-distribution
}
-md5sums="71c3f2012d0159aac22fee098be063e9 util-vserver-0.30.216-pre2841.tar.bz2"
+md5sums="71c3f2012d0159aac22fee098be063e9 util-vserver-0.30.216-pre2841.tar.bz2
+73c7437dea6937a57cf38d166ef83c09 chmod.patch
+ff8f561f672524eb46fe633f584ef60e ensc_pathprog.patch
+da8b70c4fd40e68894b3903ffd121397 validate.patch
+65fee3e086d2dd413526609c9ee782e5 alpine.patch"
diff --git a/testing/util-vserver/alpine.patch b/testing/util-vserver/alpine.patch
new file mode 100644
index 000000000..a9914a4b8
--- /dev/null
+++ b/testing/util-vserver/alpine.patch
@@ -0,0 +1,21 @@
+diff -ru a/distrib/alpine/initpost b/distrib/alpine/initpost
+--- a/distrib/alpine/initpost 2009-10-02 18:36:00.000000000 +0000
++++ b/distrib/alpine/initpost 2009-10-02 18:42:35.000000000 +0000
+@@ -24,7 +24,7 @@
+ cd "$vdir"
+
+ echo ">>> Creating missing dirs..."
+-$_CHROOT_SH mkdir proc sys dev home etc etc/rcL.d etc/rcK.d 2>/dev/null
++$_CHROOT_SH mkdir -p proc sys dev home etc 2>/dev/null
+
+ # remove mtab which is a link
+ if test -e "$vdir/etc/mtab"; then
+@@ -37,7 +37,7 @@
+ $_VSERVER "$vserver" stop &>/dev/null || true
+ $_VSERVER "$vserver" start --rescue --rescue-init /bin/busybox sh -c '
+ /bin/busybox --install -s
+- /sbin/rc_add -s 20 -k syslog
++ /sbin/rc-update add syslog boot
+ '
+
+ # set up hostname
diff --git a/testing/util-vserver/chmod.patch b/testing/util-vserver/chmod.patch
new file mode 100644
index 000000000..53861e893
--- /dev/null
+++ b/testing/util-vserver/chmod.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2009-09-29 13:48:10.000000000 +0000
++++ b/Makefile.am 2009-09-29 13:50:00.000000000 +0000
+@@ -149,7 +149,7 @@
+ @mkdir -p $$(dirname '$@')
+ @echo "$(SED) -e '...' $*.pathsubst >$*"
+ @$(SED) -e '$(pathsubst_RULES)' '$<' >'$@.tmp'
+- @-chmod --reference='$<' '$@.tmp'
++ @-chmod $$(stat -c %a '$<') '$@.tmp'
+ @if cmp -s '$@.tmp' '$*'; then \
+ echo "... no changes, reusing old version"; \
+ rm -f '$@.tmp'; \
diff --git a/testing/util-vserver/ensc_pathprog.patch b/testing/util-vserver/ensc_pathprog.patch
new file mode 100644
index 000000000..e14c1f6da
--- /dev/null
+++ b/testing/util-vserver/ensc_pathprog.patch
@@ -0,0 +1,14 @@
+diff -ru a/m4/ensc_pathprog.m4 b/m4/ensc_pathprog.m4
+--- a/m4/ensc_pathprog.m4 2009-10-02 17:25:49.000000000 +0000
++++ b/m4/ensc_pathprog.m4 2009-10-02 17:31:28.000000000 +0000
+@@ -61,7 +61,9 @@
+
+ if test "x$5" = x; then
+ if test -h "${$1}"; then
+- $1=`readlink -f "${$1}"`
++ case `readlink "{$1}"` in
++ ../*) $1=`readlink -f "${$1}"`;;
++ esac
+ fi
+ fi
+
diff --git a/testing/util-vserver/validate.patch b/testing/util-vserver/validate.patch
new file mode 100644
index 000000000..081dce5a3
--- /dev/null
+++ b/testing/util-vserver/validate.patch
@@ -0,0 +1,10 @@
+diff -ru a/m4/validate.am b/m4/validate.am
+--- a/m4/validate.am 2009-10-02 17:57:03.000000000 +0000
++++ b/m4/validate.am 2009-10-02 17:58:15.000000000 +0000
+@@ -26,5 +26,5 @@
+ .%-up-to-date:
+ @rm -f .*-up-to-date
+ @$(MAKE) -s clean
+- @touch -t 197001020000 '$@'
++ @cp -a Makefile.am '$@'
+ @$(MAKE) -s $(BUILT_SOURCES)