summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-19 11:13:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-19 11:13:53 +0000
commitbf59baf21557b9f59b37b56a7390327c0409fa6a (patch)
tree6e7dd68fdc9b867842a653f1aa4fae9e30b18791
parent71a341714a45c877b6860a2426af4604bfa89ac8 (diff)
downloadaports-bf59baf21557b9f59b37b56a7390327c0409fa6a.tar.bz2
aports-bf59baf21557b9f59b37b56a7390327c0409fa6a.tar.xz
testing/xz: new aport
Library and command line tools for XZ and LZMA compressed files http://tukaani.org/xz/
-rw-r--r--testing/xz/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/xz/APKBUILD b/testing/xz/APKBUILD
new file mode 100644
index 000000000..b28637630
--- /dev/null
+++ b/testing/xz/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xz
+pkgver=5.0.0
+pkgrel=0
+pkgdesc="Library and command line tools for XZ and LZMA compressed files"
+url="http://tukaani.org/xz/"
+arch="all"
+license="GPL LGPL custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://tukaani.org/xz/xz-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-rpath \
+ --enable-werror
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ pkgdesc="Libraries for decoding LZMA compression"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="f3c0706d100ad2b6d63327584d026c50 xz-5.0.0.tar.gz"