summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2010-10-26 15:04:34 +0300
committerTimo Teräs <timo.teras@iki.fi>2010-10-26 15:05:44 +0300
commit153c38dde26bbbac83b42b7b367c2e17c1cab7bc (patch)
tree12f4d437666bf0fa41f13450ad8005fd83fa28d4
parentf036d3c8ae9a0606d1a84ff9d16a259ad4bfffd8 (diff)
downloadaports-153c38dde26bbbac83b42b7b367c2e17c1cab7bc.tar.bz2
aports-153c38dde26bbbac83b42b7b367c2e17c1cab7bc.tar.xz
main/dahdi-linux-grsec: update to 2.4.0
and update zaphfc to compile with new dahdi
-rw-r--r--main/dahdi-linux-grsec/APKBUILD10
-rw-r--r--main/dahdi-linux-grsec/dahdi-zaphfc2.patch12
-rw-r--r--main/dahdi-linux-grsec/zaphfc-dahdi-2.4.0.patch58
3 files changed, 63 insertions, 17 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index cedaec5c4..4dee6d67b 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -16,8 +16,8 @@ _realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=$pkgver
# when chaning _dahdiver we *must* bump _mypkgrel
-_dahdiver=2.3.0.1
-_mypkgrel=4
+_dahdiver=2.4.0
+_mypkgrel=0
pkgrel=$(( $_kpkgrel + $_mypkgrel ))
pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver"
url="http://www.asterisk.org"
@@ -33,7 +33,7 @@ source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realna
dahdi-bri_dchan.patch
dahdi-zaphfc.patch
zaphfc-dahdi-flortz.diff
- dahdi-zaphfc2.patch
+ zaphfc-dahdi-2.4.0.patch
"
prepare() {
@@ -73,9 +73,9 @@ dev() {
ln -s /usr/include "$dir"/include
}
-md5sums="ac454f91d7e1267655ecd698832da414 dahdi-linux-2.3.0.1.tar.gz
+md5sums="0114826395f76713486142b90d772f82 dahdi-linux-2.4.0.tar.gz
c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
4b41a82ff390ac64c08092c5a3eab6a8 dahdi-bri_dchan.patch
a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch
291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff
-854008afc44b7a5c920f4ae4a2860e3b dahdi-zaphfc2.patch"
+0fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch"
diff --git a/main/dahdi-linux-grsec/dahdi-zaphfc2.patch b/main/dahdi-linux-grsec/dahdi-zaphfc2.patch
deleted file mode 100644
index 33ebafd99..000000000
--- a/main/dahdi-linux-grsec/dahdi-zaphfc2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: dahdi-linux-2.3.0.1/drivers/dahdi/zaphfc.c
- ===================================================================
- --- dahdi-linux-2.3.0.1.orig/drivers/dahdi/zaphfc.c 2010-08-19 14:50:10.000000000 +0300
- +++ dahdi-linux-2.3.0.1/drivers/dahdi/zaphfc.c 2010-08-19 14:50:44.000000000 +0300
- @@ -676,6 +676,7 @@
- sprintf(zthfc->span.desc, "HFC-S PCI A ISDN card %d [TE]", hfc_dev_count + 1);
- }
-
- + zthfc->span.owner = THIS_MODULE;
- zthfc->span.spanconfig = zthfc_spanconfig;
- zthfc->span.chanconfig = zthfc_chanconfig;
- zthfc->span.startup = zthfc_startup;
diff --git a/main/dahdi-linux-grsec/zaphfc-dahdi-2.4.0.patch b/main/dahdi-linux-grsec/zaphfc-dahdi-2.4.0.patch
new file mode 100644
index 000000000..80500a574
--- /dev/null
+++ b/main/dahdi-linux-grsec/zaphfc-dahdi-2.4.0.patch
@@ -0,0 +1,58 @@
+Index: dahdi-linux-2.4.0/drivers/dahdi/zaphfc.c
+===================================================================
+--- dahdi-linux-2.4.0.orig/drivers/dahdi/zaphfc.c 2010-10-26 14:41:21.000000000 +0300
++++ dahdi-linux-2.4.0/drivers/dahdi/zaphfc.c 2010-10-26 14:50:14.000000000 +0300
+@@ -617,7 +617,7 @@
+ }
+
+ static int zthfc_startup(struct dahdi_span *span) {
+- struct dahdi_hfc *zthfc = span->pvt;
++ struct dahdi_hfc *zthfc = container_of(span, struct dahdi_hfc, span);
+ struct hfc_card *hfctmp = zthfc->card;
+ int alreadyrunning;
+
+@@ -663,6 +663,19 @@
+ return 0;
+ }
+
++static const struct dahdi_span_ops zaphfc_span_ops = {
++ .owner = THIS_MODULE,
++ .spanconfig = zthfc_spanconfig,
++ .chanconfig = zthfc_chanconfig,
++ .startup = zthfc_startup,
++ .shutdown = zthfc_shutdown,
++ .maint = zthfc_maint,
++ .rbsbits = zthfc_rbsbits,
++ .open = zthfc_open,
++ .close = zthfc_close,
++ .ioctl = zthfc_ioctl,
++};
++
+ static int zthfc_initialize(struct dahdi_hfc *zthfc) {
+ struct hfc_card *hfctmp = zthfc->card;
+ int i;
+@@ -676,15 +689,7 @@
+ sprintf(zthfc->span.desc, "HFC-S PCI A ISDN card %d [TE]", hfc_dev_count + 1);
+ }
+
+- zthfc->span.spanconfig = zthfc_spanconfig;
+- zthfc->span.chanconfig = zthfc_chanconfig;
+- zthfc->span.startup = zthfc_startup;
+- zthfc->span.shutdown = zthfc_shutdown;
+- zthfc->span.maint = zthfc_maint;
+- zthfc->span.rbsbits = zthfc_rbsbits;
+- zthfc->span.open = zthfc_open;
+- zthfc->span.close = zthfc_close;
+- zthfc->span.ioctl = zthfc_ioctl;
++ zthfc->span.ops = &zaphfc_span_ops;
+
+ zthfc->span.channels = 3;
+ zthfc->span.chans = zthfc->_chans;
+@@ -695,7 +700,6 @@
+ zthfc->span.linecompat = DAHDI_CONFIG_AMI | DAHDI_CONFIG_CCS; // <--- this is really BS
+ zthfc->span.offset = 0;
+ init_waitqueue_head(&zthfc->span.maintq);
+- zthfc->span.pvt = zthfc;
+
+ for (i = 0; i < zthfc->span.channels; i++) {
+ memset(&(zthfc->chans[i]), 0x0, sizeof(struct dahdi_chan));