summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-26 13:24:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-26 13:24:44 +0000
commite5412705b673d7a1650741b4c45d87ef915674f1 (patch)
treed77e5c2ee0bc127e581037c24ef918f87b96f1ea
parent6434bb6a29a04d2a043b94acca7d038a313d44a0 (diff)
downloadaports-e5412705b673d7a1650741b4c45d87ef915674f1.tar.bz2
aports-e5412705b673d7a1650741b4c45d87ef915674f1.tar.xz
main/linux-grsec: fix localversion
it picked up the aports git repo by mistake
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/setlocalversion.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 37da9f895..84665e374 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.35.7
_kernver=2.6.35
-pkgrel=1
+pkgrel=2
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -18,6 +18,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
0004-arp-flush-arp-cache-on-device-change.patch
r8169-fix-rx-checksum-offload.patch
r8169-add-gro-support.patch
+ setlocalversion.patch
kernelconfig.x86
"
subpackages="$pkgname-dev linux-firmware:firmware"
@@ -143,4 +144,5 @@ md5sums="091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
0ccecafd4123dcad0b0cd7787553d734 r8169-fix-rx-checksum-offload.patch
139b39da44ecb577275be53d7d365949 r8169-add-gro-support.patch
+8c224ba0cdf0aa572c7eb50379435be4 setlocalversion.patch
f6b46f11945c77d01679c87e95d512ee kernelconfig.x86"
diff --git a/main/linux-grsec/setlocalversion.patch b/main/linux-grsec/setlocalversion.patch
new file mode 100644
index 000000000..d82eb170a
--- /dev/null
+++ b/main/linux-grsec/setlocalversion.patch
@@ -0,0 +1,11 @@
+--- ./scripts/setlocalversion.orig
++++ ./scripts/setlocalversion
+@@ -43,7 +43,7 @@
+ fi
+
+ # Check for git and a git repo.
+- if head=`git rev-parse --verify --short HEAD 2>/dev/null`; then
++ if [ -d "$srctree"/.git ] && head=`git rev-parse --verify --short HEAD 2>/dev/null`; then
+
+ # If we are at a tagged commit (like "v2.6.30-rc6"), we ignore
+ # it, because this version is defined in the top level Makefile.