summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-03 14:35:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-03 15:15:55 +0000
commit2a5132fc5dc109ee962ea3b14ba5864fcb1ec5f5 (patch)
tree37de0496a3cc2b7b035dd147d1f6342824ebe8aa
parentc1e754dce2c72cab5a8db18929109f882b73a6e3 (diff)
downloadaports-2a5132fc5dc109ee962ea3b14ba5864fcb1ec5f5.tar.bz2
aports-2a5132fc5dc109ee962ea3b14ba5864fcb1ec5f5.tar.xz
main/shorewall-shell: do not remove ip rule from addr when no gateway
We should not remove any ip rule that we have not created our selves (cherry picked from commit 3e9fded968c102a9150b8a3da32a8d13daa7f59f)
-rw-r--r--main/shorewall-shell/APKBUILD4
-rw-r--r--main/shorewall-shell/shorewall-shell-providers-gateway-none.patch11
2 files changed, 13 insertions, 2 deletions
diff --git a/main/shorewall-shell/APKBUILD b/main/shorewall-shell/APKBUILD
index c2e1eefa1..c23e11d14 100644
--- a/main/shorewall-shell/APKBUILD
+++ b/main/shorewall-shell/APKBUILD
@@ -2,7 +2,7 @@
pkgname=shorewall-shell
_v=4.2.11
pkgver=4.2.11
-pkgrel=3
+pkgrel=4
pkgdesc="Shoreline Firewall shell-based compiler."
url="http://www.shorewall.net/"
arch="noarch"
@@ -34,5 +34,5 @@ build() {
md5sums="518a7f389a6f606c109acb7dfbe18372 shorewall-shell-4.2.11.tar.bz2
64c01bc4f57203fb877bb334994eac38 shorewall-policyrouting.patch
79745ea284a08cb167b9a356ee0bff3b shorewall-shell-ipset.patch
-66b7249c5c56d104f62676c175e222d3 shorewall-shell-providers-gateway-none.patch
+0c6106a8cbb95d21c0c878a6235a65ac shorewall-shell-providers-gateway-none.patch
d5eadb6be45aa41f80669452baa853a6 shorewall-shell-rp_filter.patch"
diff --git a/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch b/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
index 531c37ed7..53459ab5f 100644
--- a/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
+++ b/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
@@ -36,3 +36,14 @@
fi
save_command "if [ -w /etc/iproute2/rt_tables ]; then"
+--- ./lib.providers.orig
++++ ./lib.providers
+@@ -267,7 +267,7 @@
+ rulenum=\$((\$rulenum + 1))
+ done
+ __EOF__
+- elif [ -n "$DELETE_THEN_ADD" ]; then
++ elif [ -n "$DELETE_THEN_ADD" ] && [ -n "$gateway" ]; then
+ indent >&3 << __EOF__
+
+ find_interface_addresses $interface | while read address; do