summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-17 10:46:42 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-03 09:54:34 +0000
commit43589c4faf2012d082133e193d21ca0fde6a8776 (patch)
tree1b8e6ca55b7859480ab623faef6a4224fa65f511
parent914b8d41706cc20762ab3fab068180c6de6237e8 (diff)
downloadaports-43589c4faf2012d082133e193d21ca0fde6a8776.tar.bz2
aports-43589c4faf2012d082133e193d21ca0fde6a8776.tar.xz
main/open-vm-tools: upgrade to 2011.11.20
(cherry picked from commit 30e5d90f5d575e5873becdf330af42ca67eec878)
-rw-r--r--main/open-vm-tools/APKBUILD27
-rw-r--r--main/open-vm-tools/ecvt.patch205
-rw-r--r--main/open-vm-tools/getloadavg-uclibc.patch19
-rw-r--r--main/open-vm-tools/procmgrposix.patch11
-rw-r--r--main/open-vm-tools/uclibc-stubs.patch11
5 files changed, 23 insertions, 250 deletions
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 866c3d5d6..b5093e01e 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=open-vm-tools
-pkgver=2011.09.23
-_pkgsubver=491607
-pkgrel=2
+pkgver=2011.11.20
+_pkgsubver=535097
+pkgrel=0
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
arch="all"
@@ -12,25 +12,24 @@ install="$pkgname.pre-install"
makedepends="procps-dev libdnet-dev icu-dev glib-dev pkgconfig bash
libtirpc-dev rpcgen icu-dev automake autoconf
gtk+-dev libxext-dev libxinerama-dev libxtst-dev gtkmm-dev
- libnotify-dev libxrandr-dev
+ libnotify-dev libxrandr-dev libxcomposite-dev
"
source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_pkgsubver.tar.gz
- getloadavg-uclibc.patch
codeset-uclibc.patch
- ecvt.patch
iconv-uclibc.patch
+ uclibc-stubs.patch
libm.patch
open-vm-tools.initd
- procmgrposix.patch
"
_builddir="$srcdir"/$pkgname-$pkgver-$_pkgsubver
prepare() {
cd "$_builddir"
- for i in "$srcdir"/*.patch; do
- [ -r "$i" ] || continue
- patch -p1 -i "$i" || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
sed -i -e 's/__unused1/st_atim.tv_nsec/g' \
@@ -81,11 +80,9 @@ gtk() {
"$subpkgdir"/usr/lib/open-vm-tools/plugins/
}
-md5sums="599342eee8d531b35ca1cc948b61868f open-vm-tools-2011.09.23-491607.tar.gz
-49e2e394d0b567fa71fcd295e96bc1c8 getloadavg-uclibc.patch
+md5sums="428d803f6fe3424af88768fc2f88f9ae open-vm-tools-2011.11.20-535097.tar.gz
82840b6bed002284b9bd2358707ee826 codeset-uclibc.patch
-840e4d6ff3f53fc22bdedf4d64aabc91 ecvt.patch
89c7449323ddac4666b73a8467baf95a iconv-uclibc.patch
+30a4161baf6274ac9cceb879460cd894 uclibc-stubs.patch
7d02fc25aba5c248f3d98dac238f175b libm.patch
-905ef6a3bac87c9ba2e5d3897ca230e7 open-vm-tools.initd
-7b833102a56009bdfc2fef2fb9ffa297 procmgrposix.patch"
+905ef6a3bac87c9ba2e5d3897ca230e7 open-vm-tools.initd"
diff --git a/main/open-vm-tools/ecvt.patch b/main/open-vm-tools/ecvt.patch
deleted file mode 100644
index 53e88e998..000000000
--- a/main/open-vm-tools/ecvt.patch
+++ /dev/null
@@ -1,205 +0,0 @@
-commit e996e91ca5951c50769dcaa8e074daa973006849
-Author: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu Jul 8 06:39:36 2010 +0000
-
- add ecvt() implementation
-
-diff --git a/lib/string/Makefile.am b/lib/string/Makefile.am
-index 1edab81..5f2e7ab 100644
---- a/lib/string/Makefile.am
-+++ b/lib/string/Makefile.am
-@@ -23,6 +23,7 @@ libString_la_SOURCES += bsd_vsnprintf.c
- libString_la_SOURCES += bsd_vsnwprintf.c
- libString_la_SOURCES += convertutf.c
- libString_la_SOURCES += str.c
-+libString_la_SOURCES += ecvt.c
-
- AM_CFLAGS = @LIB_STRING_CPPFLAGS@
-
-diff --git a/lib/string/bsd_output_shared.c b/lib/string/bsd_output_shared.c
-index 3616947..321d6f1 100644
---- a/lib/string/bsd_output_shared.c
-+++ b/lib/string/bsd_output_shared.c
-@@ -64,6 +64,9 @@
-
- #ifndef NO_FLOATING_POINT
-
-+extern char* ecvt(double arg, int ndigits, int *decptp, int *signp);
-+extern char* fcvt(double arg, int ndigits, int *decptp, int *signp);
-+
- /*
- *-----------------------------------------------------------------------------
- *
-diff --git a/lib/string/ecvt.c b/lib/string/ecvt.c
-new file mode 100644
-index 0000000..1979c3d
---- /dev/null
-+++ b/lib/string/ecvt.c
-@@ -0,0 +1,167 @@
-+/*
-+ * Copyright (c) 1999 Apple Computer, Inc. All rights reserved.
-+ *
-+ * @APPLE_LICENSE_HEADER_START@
-+ *
-+ * This file contains Original Code and/or Modifications of Original Code
-+ * as defined in and that are subject to the Apple Public Source License
-+ * Version 2.0 (the 'License'). You may not use this file except in
-+ * compliance with the License. Please obtain a copy of the License at
-+ * http://www.opensource.apple.com/apsl/ and read it before using this
-+ * file.
-+ *
-+ * The Original Code and all software distributed under the License are
-+ * distributed on an 'AS IS' basis, WITHOUT WARRANTY OF ANY KIND, EITHER
-+ * EXPRESS OR IMPLIED, AND APPLE HEREBY DISCLAIMS ALL SUCH WARRANTIES,
-+ * INCLUDING WITHOUT LIMITATION, ANY WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE, QUIET ENJOYMENT OR NON-INFRINGEMENT.
-+ * Please see the License for the specific language governing rights and
-+ * limitations under the License.
-+ *
-+ * @APPLE_LICENSE_HEADER_END@
-+ */
-+/*
-+ * ecvt converts to decimal
-+ * the number of digits is specified by ndigit
-+ * decptp is set to the position of the decimal point
-+ * signp is set to 0 for positive, 1 for negative
-+ */
-+
-+
-+static double ecvt_rint(double x);
-+
-+static char *cvt();
-+
-+/* big enough to handle %.20f conversion of 1e308 */
-+#define NDIG 350
-+
-+char*
-+ecvt(arg, ndigits, decptp, signp)
-+double arg;
-+int ndigits, *decptp, *signp;
-+{
-+ return(cvt(arg, ndigits, decptp, signp, 1));
-+}
-+
-+char*
-+fcvt(arg, ndigits, decptp, signp)
-+double arg;
-+int ndigits, *decptp, *signp;
-+{
-+ return(cvt(arg, ndigits, decptp, signp, 0));
-+}
-+
-+static char*
-+cvt(arg, ndigits, decptp, signp, eflag)
-+double arg;
-+int ndigits, *decptp, *signp;
-+int eflag;
-+{
-+ register int decpt;
-+ double fi, fj;
-+ register char *p, *p1;
-+ static char buf[NDIG] = { 0 };
-+ double modf();
-+
-+ if (ndigits < 0)
-+ ndigits = 0;
-+ if (ndigits >= NDIG-1)
-+ ndigits = NDIG-2;
-+
-+ decpt = 0;
-+ *signp = 0;
-+ p = &buf[0];
-+
-+ if (arg == 0) {
-+ *decptp = 0;
-+ while (p < &buf[ndigits])
-+ *p++ = '0';
-+ *p = '\0';
-+ return(buf);
-+ } else if (arg < 0) {
-+ *signp = 1;
-+ arg = -arg;
-+ }
-+
-+ arg = modf(arg, &fi);
-+ p1 = &buf[NDIG];
-+
-+ /*
-+ * Do integer part
-+ */
-+ if (fi != 0) {
-+ while (fi != 0) {
-+ fj = modf(fi/10, &fi);
-+ /**--p1 = (int)((fj+.03)*10) + '0';*/
-+ *--p1 = (int)ecvt_rint((fj)*10) + '0';
-+ decpt++;
-+ }
-+ while (p1 < &buf[NDIG])
-+ *p++ = *p1++;
-+ } else if (arg > 0) {
-+ while ((fj = arg*10) < 1) {
-+ arg = fj;
-+ decpt--;
-+ }
-+ }
-+ *decptp = decpt;
-+
-+ /*
-+ * do fraction part
-+ * p pts to where fraction should be concatenated
-+ * p1 is how far conversion must go to
-+ */
-+ p1 = &buf[ndigits];
-+ if (eflag==0) {
-+ /* fcvt must provide ndigits after decimal pt */
-+ p1 += decpt;
-+ /* if decpt was negative, we might done for fcvt */
-+ if (p1 < &buf[0]) {
-+ buf[0] = '\0';
-+ return(buf);
-+ }
-+ }
-+ while (p <= p1 && p < &buf[NDIG]) {
-+ arg *= 10;
-+ arg = modf(arg, &fj);
-+ *p++ = (int)fj + '0';
-+ }
-+ /*
-+ * if we converted all the way to the end of the
-+ * buf, don't mess with rounding since there's nothing
-+ * significant out here anyway
-+ */
-+ if (p1 >= &buf[NDIG]) {
-+ buf[NDIG-1] = '\0';
-+ return(buf);
-+ }
-+ /*
-+ * round by adding 5 to last digit and propagating
-+ * carries
-+ */
-+ p = p1;
-+ *p1 += 5;
-+ while (*p1 > '9') {
-+ *p1 = '0';
-+ if (p1 > buf)
-+ ++*--p1;
-+ else {
-+ *p1 = '1';
-+ (*decptp)++;
-+ if (eflag == 0) {
-+ if (p > buf)
-+ *p = '0';
-+ p++;
-+ }
-+ }
-+ }
-+ *p = '\0';
-+ return(buf);
-+}
-+
-+static double ecvt_rint(double x)
-+{
-+ asm("frndint" : "=t" (x) : "0" (x));
-+ return(x);
-+}
-+
diff --git a/main/open-vm-tools/getloadavg-uclibc.patch b/main/open-vm-tools/getloadavg-uclibc.patch
deleted file mode 100644
index ccc4c388e..000000000
--- a/main/open-vm-tools/getloadavg-uclibc.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/lib/misc/hostinfoPosix.c
-+++ b/lib/misc/hostinfoPosix.c
-@@ -1398,7 +1398,15 @@
- float *avg1, // IN/OUT:
- float *avg2) // IN/OUT:
- {
--#if defined(__linux__) || defined(__APPLE__)
-+#if defined(__UCLIBC__)
-+ FILE *f;
-+ if ((f = fopen("/proc/loadavg", "r")) == NULL)
-+ return FALSE;
-+ fscanf(f, "%f %f %f", avg0, avg1, avg2);
-+ fclose(f);
-+ return TRUE;
-+
-+#elif defined(GLIBC_VERSION_22) || defined(__APPLE__)
- double avg[3];
- int res;
-
diff --git a/main/open-vm-tools/procmgrposix.patch b/main/open-vm-tools/procmgrposix.patch
deleted file mode 100644
index 510c48a72..000000000
--- a/main/open-vm-tools/procmgrposix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/procMgr/procMgrPosix.c
-+++ b/lib/procMgr/procMgrPosix.c
-@@ -114,7 +114,7 @@
- #define SOLARIS_BASH_PATH "/usr/bin/bash"
- #endif
-
--#if defined(linux) && !defined(GLIBC_VERSION_23)
-+#if defined(linux) && !defined(GLIBC_VERSION_23) && !defined(__UCLIBC__)
- /*
- * Implements the system calls (they are not wrapped by glibc til 2.3.2).
- *
diff --git a/main/open-vm-tools/uclibc-stubs.patch b/main/open-vm-tools/uclibc-stubs.patch
new file mode 100644
index 000000000..0aeec6c94
--- /dev/null
+++ b/main/open-vm-tools/uclibc-stubs.patch
@@ -0,0 +1,11 @@
+--- ./lib/stubs/Makefile.am.orig
++++ ./lib/stubs/Makefile.am
+@@ -32,7 +32,5 @@
+ libStubsCS_la_SOURCES += stub-user-msg.c
+ libStubsCS_la_SOURCES += stub-user-panic.c
+
+-if !LINUX
+- libStubsCS_la_SOURCES += stub-msgfmt-fbsd.c
+-endif
++libStubsCS_la_SOURCES += stub-msgfmt-fbsd.c
+