summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-29 13:27:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-03 09:54:34 +0000
commitad83cb86a29b349b5b83c68a865c550224a09b5f (patch)
tree582a23836395c01213684f5c69e8d57ad251cca4
parent43589c4faf2012d082133e193d21ca0fde6a8776 (diff)
downloadaports-ad83cb86a29b349b5b83c68a865c550224a09b5f.tar.bz2
aports-ad83cb86a29b349b5b83c68a865c550224a09b5f.tar.xz
main/*-grsec: upgrade to grsecurity-2.2.2-3.0.12-unofficial
(cherry picked from commit 088254038bd02d3fe0336fe7b2d699627bb4e165)
-rw-r--r--main/dahdi-linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/APKBUILD8
-rw-r--r--main/linux-grsec/grsecurity-2.2.2-3.0.12-unofficial.patch (renamed from main/linux-grsec/grsecurity-2.2.2-3.0.10-unofficial.patch)72
-rw-r--r--main/open-iscsi-grsec/APKBUILD8
-rw-r--r--main/open-iscsi-grsec/Makefile-Alpine-kernels-support.patch2
-rw-r--r--main/open-vm-tools-grsec/APKBUILD6
-rw-r--r--main/xtables-addons-grsec/APKBUILD2
7 files changed, 52 insertions, 52 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index d807fe25c..79d5f7830 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -2,15 +2,15 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
_flavor=grsec
-_kver=3.0.10
+_kver=3.0.12
_kpkgrel=0
_mypkgrel=0
# verify the kernel version before entering chroot
if [ -f ../linux-${_flavor}/APKBUILD ]; then
. ../linux-${_flavor}/APKBUILD
- [ "$_kver" != "$pkgver" ] && die "please update _kver to $pkgver"
- [ "$_kpkgrel" != "$pkgrel" ] && die "please update _kpkgrel to $pkgrel"
+ [ "$_kver" != "$pkgver" ] && die "dahdi-linux-grsec: please update _kver to $pkgver"
+ [ "$_kpkgrel" != "$pkgrel" ] && die "dahdi-linuc-grsec: please update _kpkgrel to $pkgrel"
fi
_kpkgver="$_kver-r$_kpkgrel"
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 7b0261f04..c29fac6b6 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -2,7 +2,7 @@
_flavor=grsec
pkgname=linux-${_flavor}
-pkgver=3.0.10
+pkgver=3.0.12
_kernver=3.0
pkgrel=0
pkgdesc="Linux kernel with grsecurity"
@@ -14,7 +14,7 @@ _config=${config:-kernelconfig.${CARCH}}
install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v3.0/patch-$pkgver.bz2
- grsecurity-2.2.2-3.0.10-unofficial.patch
+ grsecurity-2.2.2-$pkgver-unofficial.patch
grsec-timblogiw-noconst.patch
0001-ip_gre-dont-increase-dev-needed_headroom-on-a-live-d.patch
@@ -139,8 +139,8 @@ dev() {
}
md5sums="398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
-8e0391dd935d838ee3023ab9daa6b447 patch-3.0.10.bz2
-cb9aa7ec8c615a5c3ba730ac951da9d2 grsecurity-2.2.2-3.0.10-unofficial.patch
+b3030035fcc87c55ede362a47113af5d patch-3.0.12.bz2
+a129184102c16a4ee39afe50cae43efd grsecurity-2.2.2-3.0.12-unofficial.patch
c41cf0ee9794f393423c6b2093072260 grsec-timblogiw-noconst.patch
ebb99ef6ad8cd2d9fd8f49d5c5849057 0001-ip_gre-dont-increase-dev-needed_headroom-on-a-live-d.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
diff --git a/main/linux-grsec/grsecurity-2.2.2-3.0.10-unofficial.patch b/main/linux-grsec/grsecurity-2.2.2-3.0.12-unofficial.patch
index ad5496b8f..8fad8f4f8 100644
--- a/main/linux-grsec/grsecurity-2.2.2-3.0.10-unofficial.patch
+++ b/main/linux-grsec/grsecurity-2.2.2-3.0.12-unofficial.patch
@@ -158,7 +158,7 @@ index aa47be7..1fbd18f 100644
pcd. [PARIDE]
diff --git a/Makefile b/Makefile
-index 36036d1..167a8c6 100644
+index 993fe05..8ddd85b 100644
--- a/Makefile
+++ b/Makefile
@@ -245,8 +245,9 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
@@ -27302,7 +27302,7 @@ index 7eef6e1..f8b411e 100644
return can_switch;
}
diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
-index ce7914c..2e5f051 100644
+index e0d0e27..f48e37e 100644
--- a/drivers/gpu/drm/i915/i915_drv.h
+++ b/drivers/gpu/drm/i915/i915_drv.h
@@ -219,7 +219,7 @@ struct drm_i915_display_funcs {
@@ -27323,7 +27323,7 @@ index ce7914c..2e5f051 100644
/* protects the irq masks */
spinlock_t irq_lock;
-@@ -874,7 +874,7 @@ struct drm_i915_gem_object {
+@@ -875,7 +875,7 @@ struct drm_i915_gem_object {
* will be page flipped away on the next vblank. When it
* reaches 0, dev_priv->pending_flip_queue will be woken up.
*/
@@ -27332,7 +27332,7 @@ index ce7914c..2e5f051 100644
};
#define to_intel_bo(x) container_of(x, struct drm_i915_gem_object, base)
-@@ -1247,7 +1247,7 @@ extern int intel_setup_gmbus(struct drm_device *dev);
+@@ -1248,7 +1248,7 @@ extern int intel_setup_gmbus(struct drm_device *dev);
extern void intel_teardown_gmbus(struct drm_device *dev);
extern void intel_gmbus_set_speed(struct i2c_adapter *adapter, int speed);
extern void intel_gmbus_force_bit(struct i2c_adapter *adapter, bool force_bit);
@@ -27404,7 +27404,7 @@ index 9b1d669..d88e72c 100644
INIT_WORK(&dev_priv->hotplug_work, i915_hotplug_work_func);
INIT_WORK(&dev_priv->error_work, i915_error_work_func);
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
-index cbf4c4c..76e1edc 100644
+index 853bddb..6afec46 100644
--- a/drivers/gpu/drm/i915/intel_display.c
+++ b/drivers/gpu/drm/i915/intel_display.c
@@ -1961,7 +1961,7 @@ intel_pipe_set_base(struct drm_crtc *crtc, int x, int y,
@@ -27416,7 +27416,7 @@ index cbf4c4c..76e1edc 100644
/* Big Hammer, we also need to ensure that any pending
* MI_WAIT_FOR_EVENT inside a user batch buffer on the
-@@ -2548,7 +2548,7 @@ static void intel_crtc_wait_for_pending_flips(struct drm_crtc *crtc)
+@@ -2550,7 +2550,7 @@ static void intel_crtc_wait_for_pending_flips(struct drm_crtc *crtc)
obj = to_intel_framebuffer(crtc->fb)->obj;
dev_priv = crtc->dev->dev_private;
wait_event(dev_priv->pending_flip_queue,
@@ -27425,7 +27425,7 @@ index cbf4c4c..76e1edc 100644
}
static bool intel_crtc_driving_pch(struct drm_crtc *crtc)
-@@ -6225,7 +6225,7 @@ static void do_intel_finish_page_flip(struct drm_device *dev,
+@@ -6257,7 +6257,7 @@ static void do_intel_finish_page_flip(struct drm_device *dev,
atomic_clear_mask(1 << intel_crtc->plane,
&obj->pending_flip.counter);
@@ -27434,7 +27434,7 @@ index cbf4c4c..76e1edc 100644
wake_up(&dev_priv->pending_flip_queue);
schedule_work(&work->work);
-@@ -6514,7 +6514,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
+@@ -6546,7 +6546,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
/* Block clients from rendering to the new back buffer until
* the flip occurs and the object is no longer visible.
*/
@@ -27443,7 +27443,7 @@ index cbf4c4c..76e1edc 100644
ret = dev_priv->display.queue_flip(dev, crtc, fb, obj);
if (ret)
-@@ -6527,7 +6527,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
+@@ -6559,7 +6559,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
return 0;
cleanup_pending:
@@ -34486,10 +34486,10 @@ index 8a0b330..b4286de 100644
if (dev->in_reset) {
dprintk((KERN_DEBUG"aacraid: send raw srb -EBUSY\n"));
diff --git a/drivers/scsi/aacraid/linit.c b/drivers/scsi/aacraid/linit.c
-index 3382475..9c8d000 100644
+index c7b6fed..4db0569 100644
--- a/drivers/scsi/aacraid/linit.c
+++ b/drivers/scsi/aacraid/linit.c
-@@ -92,7 +92,7 @@ static DECLARE_PCI_DEVICE_TABLE(aac_pci_tbl) = {
+@@ -93,7 +93,7 @@ static DECLARE_PCI_DEVICE_TABLE(aac_pci_tbl) = {
#elif defined(__devinitconst)
static const struct pci_device_id aac_pci_tbl[] __devinitconst = {
#else
@@ -34729,10 +34729,10 @@ index 351dc0b..951dc32 100644
/* These three are default values which can be overridden */
diff --git a/drivers/scsi/hpsa.c b/drivers/scsi/hpsa.c
-index 6689d5d..9cbea58 100644
+index 56a9f3f..a51d0fb 100644
--- a/drivers/scsi/hpsa.c
+++ b/drivers/scsi/hpsa.c
-@@ -498,7 +498,7 @@ static inline u32 next_command(struct ctlr_info *h)
+@@ -499,7 +499,7 @@ static inline u32 next_command(struct ctlr_info *h)
u32 a;
if (unlikely(!(h->transMethod & CFGTBL_Trans_Performant)))
@@ -34741,7 +34741,7 @@ index 6689d5d..9cbea58 100644
if ((*(h->reply_pool_head) & 1) == (h->reply_pool_wraparound)) {
a = *(h->reply_pool_head); /* Next cmd in ring buffer */
-@@ -2955,7 +2955,7 @@ static void start_io(struct ctlr_info *h)
+@@ -2956,7 +2956,7 @@ static void start_io(struct ctlr_info *h)
while (!list_empty(&h->reqQ)) {
c = list_entry(h->reqQ.next, struct CommandList, list);
/* can't do anything if fifo is full */
@@ -34750,7 +34750,7 @@ index 6689d5d..9cbea58 100644
dev_warn(&h->pdev->dev, "fifo full\n");
break;
}
-@@ -2965,7 +2965,7 @@ static void start_io(struct ctlr_info *h)
+@@ -2966,7 +2966,7 @@ static void start_io(struct ctlr_info *h)
h->Qdepth--;
/* Tell the controller execute command */
@@ -34759,7 +34759,7 @@ index 6689d5d..9cbea58 100644
/* Put job onto the completed Q */
addQ(&h->cmpQ, c);
-@@ -2974,17 +2974,17 @@ static void start_io(struct ctlr_info *h)
+@@ -2975,17 +2975,17 @@ static void start_io(struct ctlr_info *h)
static inline unsigned long get_next_completion(struct ctlr_info *h)
{
@@ -34780,7 +34780,7 @@ index 6689d5d..9cbea58 100644
(h->interrupts_enabled == 0);
}
-@@ -3881,7 +3881,7 @@ static int __devinit hpsa_pci_init(struct ctlr_info *h)
+@@ -3882,7 +3882,7 @@ static int __devinit hpsa_pci_init(struct ctlr_info *h)
if (prod_index < 0)
return -ENODEV;
h->product_name = products[prod_index].product_name;
@@ -34789,7 +34789,7 @@ index 6689d5d..9cbea58 100644
if (hpsa_board_disabled(h->pdev)) {
dev_warn(&h->pdev->dev, "controller appears to be disabled\n");
-@@ -4158,7 +4158,7 @@ reinit_after_soft_reset:
+@@ -4163,7 +4163,7 @@ reinit_after_soft_reset:
}
/* make sure the board interrupts are off */
@@ -34798,7 +34798,7 @@ index 6689d5d..9cbea58 100644
if (hpsa_request_irq(h, do_hpsa_intr_msi, do_hpsa_intr_intx))
goto clean2;
-@@ -4192,7 +4192,7 @@ reinit_after_soft_reset:
+@@ -4197,7 +4197,7 @@ reinit_after_soft_reset:
* fake ones to scoop up any residual completions.
*/
spin_lock_irqsave(&h->lock, flags);
@@ -34807,7 +34807,7 @@ index 6689d5d..9cbea58 100644
spin_unlock_irqrestore(&h->lock, flags);
free_irq(h->intr[h->intr_mode], h);
rc = hpsa_request_irq(h, hpsa_msix_discard_completions,
-@@ -4211,9 +4211,9 @@ reinit_after_soft_reset:
+@@ -4216,9 +4216,9 @@ reinit_after_soft_reset:
dev_info(&h->pdev->dev, "Board READY.\n");
dev_info(&h->pdev->dev,
"Waiting for stale completions to drain.\n");
@@ -34819,7 +34819,7 @@ index 6689d5d..9cbea58 100644
rc = controller_reset_failed(h->cfgtable);
if (rc)
-@@ -4234,7 +4234,7 @@ reinit_after_soft_reset:
+@@ -4239,7 +4239,7 @@ reinit_after_soft_reset:
}
/* Turn the interrupts on so we can service requests */
@@ -34828,7 +34828,7 @@ index 6689d5d..9cbea58 100644
hpsa_hba_inquiry(h);
hpsa_register_scsi(h); /* hook ourselves into SCSI subsystem */
-@@ -4287,7 +4287,7 @@ static void hpsa_shutdown(struct pci_dev *pdev)
+@@ -4292,7 +4292,7 @@ static void hpsa_shutdown(struct pci_dev *pdev)
* To write all data in the battery backed cache to disks
*/
hpsa_flush_cache(h);
@@ -34837,7 +34837,7 @@ index 6689d5d..9cbea58 100644
free_irq(h->intr[h->intr_mode], h);
#ifdef CONFIG_PCI_MSI
if (h->msix_vector)
-@@ -4450,7 +4450,7 @@ static __devinit void hpsa_enter_performant_mode(struct ctlr_info *h,
+@@ -4455,7 +4455,7 @@ static __devinit void hpsa_enter_performant_mode(struct ctlr_info *h,
return;
}
/* Change the access methods to the performant access methods */
@@ -36913,10 +36913,10 @@ index b44aef0..c5ad11d 100644
/*
diff --git a/drivers/tty/tty_ldisc.c b/drivers/tty/tty_ldisc.c
-index ef925d5..6ddb00e 100644
+index a76c808..ecbc743 100644
--- a/drivers/tty/tty_ldisc.c
+++ b/drivers/tty/tty_ldisc.c
-@@ -74,7 +74,7 @@ static void put_ldisc(struct tty_ldisc *ld)
+@@ -75,7 +75,7 @@ static void put_ldisc(struct tty_ldisc *ld)
if (atomic_dec_and_lock(&ld->users, &tty_ldisc_lock)) {
struct tty_ldisc_ops *ldo = ld->ops;
@@ -36925,7 +36925,7 @@ index ef925d5..6ddb00e 100644
module_put(ldo->owner);
spin_unlock_irqrestore(&tty_ldisc_lock, flags);
-@@ -109,7 +109,7 @@ int tty_register_ldisc(int disc, struct tty_ldisc_ops *new_ldisc)
+@@ -110,7 +110,7 @@ int tty_register_ldisc(int disc, struct tty_ldisc_ops *new_ldisc)
spin_lock_irqsave(&tty_ldisc_lock, flags);
tty_ldiscs[disc] = new_ldisc;
new_ldisc->num = disc;
@@ -36934,7 +36934,7 @@ index ef925d5..6ddb00e 100644
spin_unlock_irqrestore(&tty_ldisc_lock, flags);
return ret;
-@@ -137,7 +137,7 @@ int tty_unregister_ldisc(int disc)
+@@ -138,7 +138,7 @@ int tty_unregister_ldisc(int disc)
return -EINVAL;
spin_lock_irqsave(&tty_ldisc_lock, flags);
@@ -36943,7 +36943,7 @@ index ef925d5..6ddb00e 100644
ret = -EBUSY;
else
tty_ldiscs[disc] = NULL;
-@@ -158,7 +158,7 @@ static struct tty_ldisc_ops *get_ldops(int disc)
+@@ -159,7 +159,7 @@ static struct tty_ldisc_ops *get_ldops(int disc)
if (ldops) {
ret = ERR_PTR(-EAGAIN);
if (try_module_get(ldops->owner)) {
@@ -36952,7 +36952,7 @@ index ef925d5..6ddb00e 100644
ret = ldops;
}
}
-@@ -171,7 +171,7 @@ static void put_ldops(struct tty_ldisc_ops *ldops)
+@@ -172,7 +172,7 @@ static void put_ldops(struct tty_ldisc_ops *ldops)
unsigned long flags;
spin_lock_irqsave(&tty_ldisc_lock, flags);
@@ -37318,10 +37318,10 @@ index 1fc8f12..20647c1 100644
return 0;
}
diff --git a/drivers/usb/host/xhci-mem.c b/drivers/usb/host/xhci-mem.c
-index 104620b..af0338a 100644
+index ffeee57..22ca548 100644
--- a/drivers/usb/host/xhci-mem.c
+++ b/drivers/usb/host/xhci-mem.c
-@@ -1690,6 +1690,8 @@ static int xhci_check_trb_in_td_math(struct xhci_hcd *xhci, gfp_t mem_flags)
+@@ -1685,6 +1685,8 @@ static int xhci_check_trb_in_td_math(struct xhci_hcd *xhci, gfp_t mem_flags)
unsigned int num_tests;
int i, ret;
@@ -45971,7 +45971,7 @@ index 202f370..9d4565e 100644
server = kzalloc(sizeof(struct ncp_server), GFP_KERNEL);
if (!server)
diff --git a/fs/nfs/inode.c b/fs/nfs/inode.c
-index 6f4850d..875435e 100644
+index c48f9f6..17c27ce 100644
--- a/fs/nfs/inode.c
+++ b/fs/nfs/inode.c
@@ -150,7 +150,7 @@ static void nfs_zap_caches_locked(struct inode *inode)
@@ -48414,10 +48414,10 @@ index 54e623b..5c3fd7a 100644
if (error)
return -error;
diff --git a/fs/xfs/linux-2.6/xfs_iops.c b/fs/xfs/linux-2.6/xfs_iops.c
-index d44d92c..ef7ad2d 100644
+index f5b697b..a8de28d 100644
--- a/fs/xfs/linux-2.6/xfs_iops.c
+++ b/fs/xfs/linux-2.6/xfs_iops.c
-@@ -437,7 +437,7 @@ xfs_vn_put_link(
+@@ -445,7 +445,7 @@ xfs_vn_put_link(
struct nameidata *nd,
void *p)
{
@@ -75210,10 +75210,10 @@ index 4851e9e..d860e05 100644
return p;
diff --git a/net/mac80211/util.c b/net/mac80211/util.c
-index d3fe2d2..0affe0d 100644
+index 2124db8..8718fc2 100644
--- a/net/mac80211/util.c
+++ b/net/mac80211/util.c
-@@ -1147,7 +1147,7 @@ int ieee80211_reconfig(struct ieee80211_local *local)
+@@ -1151,7 +1151,7 @@ int ieee80211_reconfig(struct ieee80211_local *local)
#endif
/* restart hardware */
diff --git a/main/open-iscsi-grsec/APKBUILD b/main/open-iscsi-grsec/APKBUILD
index d42618a0e..ea049fa31 100644
--- a/main/open-iscsi-grsec/APKBUILD
+++ b/main/open-iscsi-grsec/APKBUILD
@@ -3,14 +3,14 @@
_flavor=grsec
_realname=open-iscsi
_realver=2.0-872
-_kver=3.0.10
+_kver=3.0.12
_kpkgrel=0
# verify the kernel version before entering chroot
if [ -f ../linux-${_flavor}/APKBUILD ]; then
. ../linux-${_flavor}/APKBUILD
- [ "$_kver" != "$pkgver" ] && die "please update _kver to $pkgver"
- [ "$_kpkgrel" != "$pkgrel" ] && die "please update _kpkgrel to $pkgrel"
+ [ "$_kver" != "$pkgver" ] && die "open-iscsi-$_flavor: please update _kver to $pkgver"
+ [ "$_kpkgrel" != "$pkgrel" ] && die "open-iscsi-$_flavor: please update _kpkgrel to $pkgrel"
fi
_kernelver="$_kver-r$_kpkgrel"
@@ -56,4 +56,4 @@ package() {
}
md5sums="b4df94f08c241352bb964043b3e44779 open-iscsi-2.0-872.tar.gz
-c28dfb108cec0399634d348132cee79a Makefile-Alpine-kernels-support.patch"
+7fc6493815ac899da83db3197e25d0b9 Makefile-Alpine-kernels-support.patch"
diff --git a/main/open-iscsi-grsec/Makefile-Alpine-kernels-support.patch b/main/open-iscsi-grsec/Makefile-Alpine-kernels-support.patch
index 95e9c9573..8308ba590 100644
--- a/main/open-iscsi-grsec/Makefile-Alpine-kernels-support.patch
+++ b/main/open-iscsi-grsec/Makefile-Alpine-kernels-support.patch
@@ -26,7 +26,7 @@
linux_2_6_35: $(unpatch_code)
+
-+linux_3_0_10: $(unpatch_code)
++linux_3_0_12: $(unpatch_code)
do_unpatch_code:
echo "Un-patching source code for use with linux-2.6.14 and up ..."
diff --git a/main/open-vm-tools-grsec/APKBUILD b/main/open-vm-tools-grsec/APKBUILD
index 133b3b783..d5d85c939 100644
--- a/main/open-vm-tools-grsec/APKBUILD
+++ b/main/open-vm-tools-grsec/APKBUILD
@@ -6,15 +6,15 @@ _mypkgrel=0
_realver=2011.09.23
_realsubver=491607
-_kver=3.0.10
+_kver=3.0.12
_kpkgrel=0
# source open-vm-tools version
if [ -f ../main/$_realname/APKBUILD ]; then
. ../main/$_realname/APKBUILD
- [ "$_realver" != "$pkgver" ] && die "please set _realver to $pkgver"
+ [ "$_realver" != "$pkgver" ] && die "$_realname-$_flavor: please set _realver to $pkgver"
[ "$_realsubver" != "$_pkgsubver" ] \
- && die "please set _realsubver to $_pkgsubver"
+ && die "$_realname-$_flavor: please set _realsubver to $_pkgsubver"
fi
# source the kernel version
diff --git a/main/xtables-addons-grsec/APKBUILD b/main/xtables-addons-grsec/APKBUILD
index 20738ab03..eec3eeff5 100644
--- a/main/xtables-addons-grsec/APKBUILD
+++ b/main/xtables-addons-grsec/APKBUILD
@@ -3,7 +3,7 @@ _flavor=${FLAVOR:-grsec}
_realname=xtables-addons
_name=$_realname-$_flavor
-_kver=3.0.10
+_kver=3.0.12
_kpkgrel=0
# source the kernel version