summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-01 13:52:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-01 13:52:10 +0000
commit39497978865c49fd42b63379b93f2bca58518b9e (patch)
tree2f702801331dd886a47ae1c95986ed39db47f0b1
parent6f6e2467917a263d14c833e107d2c6786188645a (diff)
downloadaports-39497978865c49fd42b63379b93f2bca58518b9e.tar.bz2
aports-39497978865c49fd42b63379b93f2bca58518b9e.tar.xz
main/openrc: hwdrivers: pull in fbcon if needed
-rw-r--r--main/openrc/APKBUILD4
-rw-r--r--main/openrc/hwdrivers.initd6
2 files changed, 8 insertions, 2 deletions
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index 1041b5562..4a78481ca 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openrc
pkgver=0.9.8.4
_ver=${pkgver/_git*/}
-pkgrel=0
+pkgrel=1
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
arch="all"
@@ -74,7 +74,7 @@ bc4f9ccd4036f9c458b89afe877fa8c2 0001-sysctl-Use-dev-null-instead-of-q.patch
ce6ccda132e579cd2464b8f72daa3d2e hwclock-hctosys.patch
ddb34ea87994df3126f5e6b7e8f9ac93 swap-umount-tmpfs.patch
c32e15b0858eef708497e7ee6355a055 hostname.initd
-b1e64885f301166df30be3e3cf5338ff hwdrivers.initd
+78e9f0df010ac8095c5e76a91a1d3b12 hwdrivers.initd
33ca3e558c42cdd17adccbc7807298f7 keymaps.initd
098a1f16812f56fcb56eb6b6f0fa31f6 modules.initd
d10c4fd412faf0b970bb470f493fe718 modloop.initd
diff --git a/main/openrc/hwdrivers.initd b/main/openrc/hwdrivers.initd
index 3d0ebf12b..d4551ca23 100644
--- a/main/openrc/hwdrivers.initd
+++ b/main/openrc/hwdrivers.initd
@@ -22,6 +22,12 @@ start() {
# we run it twice so we detect all devices
find /sys -name modalias | xargs sort -u \
| xargs modprobe -a 2> /dev/null
+
+ # check if framebuffer drivers got pulled in
+ if [ -e /sys/module/fb ] && ! [ -e /sys/module/fbcon ]; then
+ modprobe fbcon
+ fi
+
eend 0
}