summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-04-30 00:51:07 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-04-30 00:51:39 -0500
commitfbe190abc13e2b8c264045d64a180a81f3ea2854 (patch)
tree5544b27e810073448bc729aee8776ac3e93d6e90
parente8c1d7f2ad7d664cbc6b85e990f1171e3fac60c4 (diff)
downloadaports-fbe190abc13e2b8c264045d64a180a81f3ea2854.tar.bz2
aports-fbe190abc13e2b8c264045d64a180a81f3ea2854.tar.xz
main/xulrunner: enable newly-added uClibc execinfo support
-rw-r--r--main/xulrunner/APKBUILD6
-rw-r--r--main/xulrunner/ipc-chromium-execinfo.patch34
-rw-r--r--main/xulrunner/mozconfig2
-rw-r--r--main/xulrunner/xpcom-execinfo.patch23
4 files changed, 2 insertions, 63 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 05cb86cfe..1748daa56 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -3,7 +3,7 @@
pkgname=xulrunner
pkgver=2.0
_ffoxver=4.0
-pkgrel=2
+pkgrel=3
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -51,13 +51,9 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
fix-xulrunner-launcher.patch
mozilla-pkgconfig.patch
- ipc-chromium-execinfo.patch
-
xulrunner-mozalloc.patch
xulrunner-version.patch
- xpcom-execinfo.patch
-
mozjs-c99math.patch
gecko-c99math.patch
diff --git a/main/xulrunner/ipc-chromium-execinfo.patch b/main/xulrunner/ipc-chromium-execinfo.patch
deleted file mode 100644
index 4bbc143d8..000000000
--- a/main/xulrunner/ipc-chromium-execinfo.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- mozilla-2.0.orig/ipc/chromium/src/base/debug_util_posix.cc
-+++ mozilla-2.0/ipc/chromium/src/base/debug_util_posix.cc
-@@ -12,7 +12,6 @@
- #include <sys/types.h>
- #include <unistd.h>
- #ifndef ANDROID
--#include <execinfo.h>
- #include <sys/sysctl.h>
- #endif
-
-@@ -116,6 +115,7 @@
- }
-
- StackTrace::StackTrace() {
-+#if 0
- const int kMaxCallers = 256;
-
- void* callers[kMaxCallers];
-@@ -134,12 +134,15 @@
- } else {
- trace_.resize(0);
- }
-+#endif
- }
-
- void StackTrace::PrintBacktrace() {
-+#if 0
- fflush(stderr);
- #ifndef ANDROID
- backtrace_symbols_fd(&trace_[0], trace_.size(), STDERR_FILENO);
-+#endif
- #endif
- }
-
diff --git a/main/xulrunner/mozconfig b/main/xulrunner/mozconfig
index e8483b871..9bdde73f4 100644
--- a/main/xulrunner/mozconfig
+++ b/main/xulrunner/mozconfig
@@ -29,7 +29,7 @@ ac_add_options --enable-startup-notification
ac_add_options --enable-extensions=default
ac_add_options --enable-jemalloc
-export LIBS="-lfts"
+export LIBS="-lfts -lubacktrace"
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
diff --git a/main/xulrunner/xpcom-execinfo.patch b/main/xulrunner/xpcom-execinfo.patch
deleted file mode 100644
index 1fe320967..000000000
--- a/main/xulrunner/xpcom-execinfo.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- mozilla-2.0.orig/xpcom/threads/nsThread.cpp
-+++ mozilla-2.0/xpcom/threads/nsThread.cpp
-@@ -54,7 +54,9 @@
- && defined(_GNU_SOURCE)
- # define MOZ_CANARY
- # include <unistd.h>
--# include <execinfo.h>
-+# if !defined(__UCLIBC__)
-+# include <execinfo.h>
-+# endif
- # include <signal.h>
- # include <fcntl.h>
- # include "nsXULAppAPI.h"
-@@ -562,7 +564,9 @@
- const char msg[29] = "event took too long to run:\n";
- // use write to be safe in the signal handler
- write(Canary::sOutputFD, msg, sizeof(msg));
-+#if !defined(__UCLIBC__)
- backtrace_symbols_fd(array, backtrace(array, 30), Canary::sOutputFD);
-+#endif
- }
-
- #endif