summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-11 10:20:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-11 10:20:16 +0000
commitc9abfb39bd2a203eaa6c12b935f2b355603da2b1 (patch)
tree4cf02ed3661ad80b1e053c16e36341f2e6b56d73 /core
parent0a97a6f6becbfdb0da004caf051b76feb6592936 (diff)
downloadaports-c9abfb39bd2a203eaa6c12b935f2b355603da2b1.tar.bz2
aports-c9abfb39bd2a203eaa6c12b935f2b355603da2b1.tar.xz
core/binutils: new aport
Diffstat (limited to 'core')
-rw-r--r--core/binutils/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/core/binutils/APKBUILD b/core/binutils/APKBUILD
new file mode 100644
index 000000000..8c9c66637
--- /dev/null
+++ b/core/binutils/APKBUILD
@@ -0,0 +1,29 @@
+pkgname=binutils
+pkgver=2.19.50.0.1
+pkgdesc="Tools necessary to build programs"
+url=http://sources.redhat.com/binutils
+source=ftp://ftp.kernel.org/pub/linux/devel/binutils/$pkgname-$pkgver.tar.bz2
+depends=uclibc
+makedepends="bison flex texinfo"
+license=GPL
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --mandir /usr/share/man \
+ --build ${CHOST:-i486-gentoo-linux-uclibc}
+ --infodir /usr/share/info \
+ --enable-shared \
+ --enable-64-bit-bfd \
+ --disable-werror \
+ --disable-nls
+
+ # check build env
+ make configure-host || return 1
+
+ make || return 1
+ make install DESTDIR="$pkgdir"
+}
+md5sums="c71bf140587a5662bd1fa9d5a19556ed binutils-2.19.50.0.1.tar.bz2"