summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-11 12:16:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-11 12:16:31 +0000
commitddf3c6e66a851035cccb128aa474d49407d434a6 (patch)
treeb7296335c54227c59e31c97dd127c63f94389129 /main/libc0.9.32
parent44dbcdcdfb8dff139c089aad062aa0031a634a51 (diff)
downloadaports-ddf3c6e66a851035cccb128aa474d49407d434a6.tar.bz2
aports-ddf3c6e66a851035cccb128aa474d49407d434a6.tar.xz
main/libc0.9.32: bugfix for getservbyname()
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/0001-netdb-increase-line-size-for-etc-services.patch29
-rw-r--r--main/libc0.9.32/APKBUILD15
2 files changed, 39 insertions, 5 deletions
diff --git a/main/libc0.9.32/0001-netdb-increase-line-size-for-etc-services.patch b/main/libc0.9.32/0001-netdb-increase-line-size-for-etc-services.patch
new file mode 100644
index 000000000..612b03aa2
--- /dev/null
+++ b/main/libc0.9.32/0001-netdb-increase-line-size-for-etc-services.patch
@@ -0,0 +1,29 @@
+From e351f233334cb5484309133789646e165f4e64db Mon Sep 17 00:00:00 2001
+From: Natanael Copa <natanael.copa@gmail.com>
+Date: Wed, 11 Aug 2010 11:57:46 +0000
+Subject: [PATCH] netdb: increase line size for /etc/services
+
+If /etc/services has lines longer than 80 will getservbyname() fail
+so we set it up to 160.
+
+Signed-off-by: Natanael Copa <natanael.copa@gmail.com>
+---
+ libc/inet/getservice.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/libc/inet/getservice.c b/libc/inet/getservice.c
+index 03f5c29..8248f7a 100644
+--- a/libc/inet/getservice.c
++++ b/libc/inet/getservice.c
+@@ -29,7 +29,7 @@ aliases: case sensitive optional space or tab separated list of other names
+ __UCLIBC_MUTEX_STATIC(mylock, PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP);
+
+ #define MAXALIASES 35
+-#define BUFSZ (80) /* one line */
++#define BUFSZ (160) /* one line */
+ #define SBUFSIZE (BUFSZ + 1 + (sizeof(char *) * MAXALIASES))
+
+ static parser_t *servp = NULL;
+--
+1.7.2.1
+
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index d594deeb0..d54699032 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=1008060645
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=0
+pkgrel=1
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -21,6 +21,7 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
uclibc-resolv-tls.patch
0001-config-parser-fix-memory-corruption.patch
0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
+ 0001-netdb-increase-line-size-for-etc-services.patch
uclibcconfig.x86
uclibcconfig.i486
"
@@ -48,10 +49,13 @@ prepare() {
local i
cd "$_builddir"
# patches goes here
- for i in ../*.patch ../*.diff; do
- [ -r "$i" ] || continue
- msg "Applying $i..."
- patch -p1 < $i || return 1
+ for i in $source; do
+ case $i in
+ *.patch|*.diff)
+ msg "Applying $i..."
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
done
# set abi version and remove unsupported warnings c flag
sed -i -e "s/^ABI_VERSION.*/ABI_VERSION := $_abiver/" \
@@ -103,5 +107,6 @@ md5sums="2b3935c370307b806320e78883f9b07c libc0.9.32-0.9.32_alpha0_git100806064
d08831b452acdeaa3037525ee617edab uclibc-resolv-tls.patch
d351ca4e5c33f4a7a60d4f1d754db5c4 0001-config-parser-fix-memory-corruption.patch
653b046611f98c990f1b52a28968ece3 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
+39ac96d750ad058030f917912bfea466 0001-netdb-increase-line-size-for-etc-services.patch
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486"