summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-10 20:01:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-10 20:01:18 +0000
commit0cfedfd014e9681c080967c74baac1290365ae46 (patch)
tree04343c970636d68d0102d55c086cd14c26588d16 /main/linux-grsec
parentc19533a6b74526420e9ea8871f61cedc7959bdb6 (diff)
downloadaports-0cfedfd014e9681c080967c74baac1290365ae46.tar.bz2
aports-0cfedfd014e9681c080967c74baac1290365ae46.tar.xz
main/linux-vserver: fix for hyper-v drivers
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch38
-rw-r--r--main/linux-grsec/APKBUILD4
2 files changed, 41 insertions, 1 deletions
diff --git a/main/linux-grsec/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch b/main/linux-grsec/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
new file mode 100644
index 000000000..1133c7591
--- /dev/null
+++ b/main/linux-grsec/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
@@ -0,0 +1,38 @@
+From 6ee51b8d69833b3cd00901999c36c59fbfde24aa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 10 Dec 2010 16:23:26 +0200
+Subject: [PATCH] Staging: hv: fix sleeping while atomic issue
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+osd_schedule_callback() is called from VmbusOnMsgDPC() which runs
+in a tasklet. Avoid possible sleeping by using GFP_ATOMIC for the
+memory allocation.
+
+Seems to fix #16701.
+
+Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=16701
+Cc: Haiyang Zhang <haiyangz@microsoft.com>
+Cc: Hank Janssen <hjanssen@microsoft.com>
+Signed-off-by: Timo Teräs <timo.teras@iki.fi>
+---
+ drivers/staging/hv/osd.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/drivers/staging/hv/osd.c b/drivers/staging/hv/osd.c
+index 8c3eb27..eb9b20d 100644
+--- a/drivers/staging/hv/osd.c
++++ b/drivers/staging/hv/osd.c
+@@ -214,7 +214,7 @@ int osd_schedule_callback(struct workqueue_struct *wq,
+ {
+ struct osd_callback_struct *cb;
+
+- cb = kmalloc(sizeof(*cb), GFP_KERNEL);
++ cb = kmalloc(sizeof(*cb), GFP_ATOMIC);
+ if (!cb) {
+ printk(KERN_ERR "unable to allocate memory in osd_schedule_callback\n");
+ return -1;
+--
+1.7.1
+
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 74a4cd2de..bf1898d82 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.35.9
_kernver=2.6.35
-pkgrel=2
+pkgrel=3
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -20,6 +20,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
0004-arp-flush-arp-cache-on-device-change.patch
r8169-fix-rx-checksum-offload.patch
r8169-add-gro-support.patch
+ 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
setlocalversion.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -150,6 +151,7 @@ ea7a7eb2775b71ae5ef24d029a4905bd xfrm-fix-gre-key-endianess.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
0ccecafd4123dcad0b0cd7787553d734 r8169-fix-rx-checksum-offload.patch
139b39da44ecb577275be53d7d365949 r8169-add-gro-support.patch
+648d8b477248f233c318a3b7a961febf 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
8c224ba0cdf0aa572c7eb50379435be4 setlocalversion.patch
a9494f66196bc6308da0f129221d31b8 kernelconfig.x86
b38f1f99f8f3b75c52d4a1ab2b0d13fd kernelconfig.x86_64"