summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-03-29 13:15:21 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-03-29 13:15:21 +0000
commitd90ae88d13e52429005f70793b4a3120e9eafd98 (patch)
tree6bddb61166332287351e7726389d06fedf862dce /main/linux-grsec
parentcb56f896bc01e25c22a030e4619e7027e53e9999 (diff)
downloadaports-d90ae88d13e52429005f70793b4a3120e9eafd98.tar.bz2
aports-d90ae88d13e52429005f70793b4a3120e9eafd98.tar.xz
main/linux-grsec: add VMWARE 3d support aka vmwgfx
fixes #561
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/kernelconfig.x862
-rw-r--r--main/linux-grsec/kernelconfig.x86_642
3 files changed, 5 insertions, 5 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index af0dd9ad8..3a0a87e09 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.38.2
_kernver=2.6.38
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -139,5 +139,5 @@ md5sums="7d471477bfa67546f902da62227fa976 linux-2.6.38.tar.bz2
599badab31c4920d4122133208c810d7 patch-2.6.38.2.bz2
fac4f5fb386192c544fae27db6db18a7 grsecurity-2.2.2-2.6.38.2-201103281752.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
-697e8f0b6569195f9f43f40f30bedf07 kernelconfig.x86
-015190bc0022b1f9aad42a7cc2d5625a kernelconfig.x86_64"
+e845706e40b61847d141e7b29bc6aefe kernelconfig.x86
+d526ee0b9ebfad6bb4c4b49e79decfcf kernelconfig.x86_64"
diff --git a/main/linux-grsec/kernelconfig.x86 b/main/linux-grsec/kernelconfig.x86
index c84e5af3e..8ccb7702b 100644
--- a/main/linux-grsec/kernelconfig.x86
+++ b/main/linux-grsec/kernelconfig.x86
@@ -4365,7 +4365,7 @@ CONFIG_BRCM80211_PCI=y
CONFIG_AUTOFS_FS=m
# CONFIG_IDE_PHISON is not set
# CONFIG_LINE6_USB is not set
-# CONFIG_DRM_VMWGFX is not set
+CONFIG_DRM_VMWGFX=m
CONFIG_DRM_NOUVEAU=m
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
CONFIG_DRM_NOUVEAU_DEBUG=y
diff --git a/main/linux-grsec/kernelconfig.x86_64 b/main/linux-grsec/kernelconfig.x86_64
index c0cd98eae..27755b189 100644
--- a/main/linux-grsec/kernelconfig.x86_64
+++ b/main/linux-grsec/kernelconfig.x86_64
@@ -4325,7 +4325,7 @@ CONFIG_BRCM80211_PCI=y
CONFIG_AUTOFS_FS=m
# CONFIG_IDE_PHISON is not set
# CONFIG_LINE6_USB is not set
-# CONFIG_DRM_VMWGFX is not set
+CONFIG_DRM_VMWGFX=m
CONFIG_DRM_NOUVEAU=m
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
CONFIG_DRM_NOUVEAU_DEBUG=y