summaryrefslogtreecommitdiffstats
path: root/main/net-snmp/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-11-11 11:18:37 +0200
committerTimo Teräs <timo.teras@iki.fi>2011-11-11 11:18:37 +0200
commitac22212e8d4e2af30b3a2a2c898ae4664ea796f6 (patch)
tree3a57548a2367592fa3bcddcf8d64320e004488be /main/net-snmp/APKBUILD
parent0389c0810effbe38de6d05d68e3ab6bb08a8aaef (diff)
downloadaports-ac22212e8d4e2af30b3a2a2c898ae4664ea796f6.tar.bz2
aports-ac22212e8d4e2af30b3a2a2c898ae4664ea796f6.tar.xz
main/net-snmp: add some snmpd MIB implementation fixes
* IP-MIB::ipNetToPhysicalPhysAddress is fixed to display data properly even after first time * swinst patch prevents a crash during snmpwalk in default install
Diffstat (limited to 'main/net-snmp/APKBUILD')
-rw-r--r--main/net-snmp/APKBUILD20
1 files changed, 19 insertions, 1 deletions
diff --git a/main/net-snmp/APKBUILD b/main/net-snmp/APKBUILD
index 6968721dc..3928e0b96 100644
--- a/main/net-snmp/APKBUILD
+++ b/main/net-snmp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=net-snmp
pkgver=5.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="Simple Network Management Protocol"
url="http://www.net-snmp.org/"
arch="all"
@@ -12,6 +12,8 @@ depends_dev="openssl-dev"
makedepends="perl-dev openssl-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-tools"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ netsnmp-arp-netlink-fix.patch
+ netsnmp-swinst-crash.patch
snmpd.initd
snmpd.confd
snmptrapd.initd
@@ -20,6 +22,20 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ # patches goes here
+ for i in $source; do
+ case $i in
+ *.patch|*.diff)
+ msg "Applying $i..."
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
@@ -69,6 +85,8 @@ tools() {
md5sums="c95d08fd5d93df0c11a2e1bdf0e01e0b net-snmp-5.7.1.tar.gz
+58bdd8a68042be16c22d8b4b40d3ec9c netsnmp-arp-netlink-fix.patch
+bd7dc10ffb5839e35ec37effcc53c2ad netsnmp-swinst-crash.patch
198a4a7b80557fa8112394df5ec9914e snmpd.initd
96510a2f3bc9f21648b03f7e8d76c0d3 snmpd.confd
7ce3e9e880fc6313ae87eb000bae4bda snmptrapd.initd