summaryrefslogtreecommitdiffstats
path: root/main/py-sqlite
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-11 13:18:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-11 13:18:22 +0000
commit3a4b60e9e1c4fd340d6847f3f3d4b1380387026a (patch)
tree2316472742fcd3dffb5e1749b67084c626cd5a49 /main/py-sqlite
parent6be82ec40a642fc049398d571ce8394ca88d43ab (diff)
downloadaports-3a4b60e9e1c4fd340d6847f3f3d4b1380387026a.tar.bz2
aports-3a4b60e9e1c4fd340d6847f3f3d4b1380387026a.tar.xz
main/trac,py-sqlite,py-setuptools,py-genshi: moved from testing
Diffstat (limited to 'main/py-sqlite')
-rw-r--r--main/py-sqlite/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/py-sqlite/APKBUILD b/main/py-sqlite/APKBUILD
new file mode 100644
index 000000000..a0ae27156
--- /dev/null
+++ b/main/py-sqlite/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=py-sqlite
+_realname=pysqlite
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="A Python DB-API 2.0 interface for the SQLite embedded relational database engine"
+url="http://code.google.com/p/pysqlite/"
+license="MIT"
+depends="python sqlite"
+makedepends="sqlite-dev python-dev"
+install=
+source="http://pysqlite.googlecode.com/files/${_realname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+
+md5sums="fc92618b3b39d02e6ff10dc467c36640 pysqlite-2.6.0.tar.gz"