summaryrefslogtreecommitdiffstats
path: root/main/webkit/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-06 17:03:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-06 17:03:02 +0000
commit08927d07ec02e105a236333719fe255f4c54d93d (patch)
tree91884738ba6044671e0b8305b9a51218d27d27eb /main/webkit/APKBUILD
parent4f637b8b117f138bb8138812671af40e4a0de547 (diff)
downloadaports-08927d07ec02e105a236333719fe255f4c54d93d.tar.bz2
aports-08927d07ec02e105a236333719fe255f4c54d93d.tar.xz
main/webkit: fix textrels
ref #793
Diffstat (limited to 'main/webkit/APKBUILD')
-rw-r--r--main/webkit/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/main/webkit/APKBUILD b/main/webkit/APKBUILD
index c90bfb4bb..34534e7c3 100644
--- a/main/webkit/APKBUILD
+++ b/main/webkit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=webkit
pkgver=1.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="portable web rendering engine WebKit for GTK+"
url="http://webkitgtk.org/"
arch="all"
@@ -18,7 +18,9 @@ makedepends="
"
install=
subpackages="$pkgname-dev gtklauncher $pkgname-lang"
-source="http://webkitgtk.org/$pkgname-$pkgver.tar.gz"
+source="http://webkitgtk.org/$pkgname-$pkgver.tar.gz
+ webkit-1.6.1-alt-fix-TEXTREL.patch
+ "
depends_dev="gtk+-dev libsoup-dev gstreamer-dev"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -50,6 +52,11 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/*.la
+ # verify so we don't have textrels
+ if scanelf -qRt "$pkgdir" | grep TEXTREL; then
+ error "found textrels"
+ return 1
+ fi
}
gtklauncher() {
@@ -60,4 +67,5 @@ gtklauncher() {
"$subpkgdir"/usr/bin/GtkLauncher
}
-md5sums="c11743694b1b71dad287b2e7a9e73b05 webkit-1.6.1.tar.gz"
+md5sums="c11743694b1b71dad287b2e7a9e73b05 webkit-1.6.1.tar.gz
+4e47996e3bb87ca27c0e49ce6a2abbc7 webkit-1.6.1-alt-fix-TEXTREL.patch"