summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-10-03 11:45:17 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-10-03 11:45:52 -0500
commit429cdfcb54f28097f12c2879e67aa61f7a419c85 (patch)
tree6e02058fe92056e9e23ca65f3a22d6944e30bb00 /main/xulrunner
parentdc706204760c01a046c9ead2a83fe3849852d656 (diff)
downloadaports-429cdfcb54f28097f12c2879e67aa61f7a419c85.tar.bz2
aports-429cdfcb54f28097f12c2879e67aa61f7a419c85.tar.xz
main/xulrunner: upgrade to 7.0.1
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/APKBUILD10
-rw-r--r--main/xulrunner/fix-xulrunner-launcher.patch23
2 files changed, 4 insertions, 29 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index b0bde1349..8be015f2c 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
-pkgver=6.0
-_ffoxver=6.0
-pkgrel=1
+pkgver=7.0.1
+_ffoxver=7.0.1
+pkgrel=0
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -47,7 +47,6 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
mozconfig
- fix-xulrunner-launcher.patch
mozilla-pkgconfig.patch
xulrunner-jemalloc-aslr.patch
@@ -108,9 +107,8 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="1840185865a1a8975df4a3db59080ddc firefox-6.0.source.tar.bz2
+md5sums="5b212db48630ba93bb30ec63cca17f4d firefox-7.0.1.source.tar.bz2
cc43a2bd96bd2395aa72d0bbb88e5594 mozconfig
-86d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch
02c23dc4ebd88e445533314716331818 mozilla-pkgconfig.patch
30053b8b5811cc0676bfe7d7d7ffaa4a xulrunner-jemalloc-aslr.patch
d38ecbb7bb31032d3e1ced8939e26abd xulrunner-mozalloc.patch
diff --git a/main/xulrunner/fix-xulrunner-launcher.patch b/main/xulrunner/fix-xulrunner-launcher.patch
deleted file mode 100644
index 62af1ab30..000000000
--- a/main/xulrunner/fix-xulrunner-launcher.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/xulrunner/stub/nsXULStub.cpp 2008-07-17 21:43:11.000000000 +0200
-+++ b/xulrunner/stub/nsXULStub.cpp 2008-07-17 21:47:04.000000000 +0200
-@@ -208,8 +208,10 @@
- // 3) give up
-
- struct stat fileStat;
-+ char *testp;
-
-- if (!realpath(argv[0], iniPath) || stat(iniPath, &fileStat)) {
-+ testp = realpath(argv[0], iniPath);
-+ if (!(testp != NULL && stat(iniPath, &fileStat) == 0 && S_ISREG(fileStat.st_mode) && fileStat.st_mode & S_IXUSR) || (testp != NULL && stat(iniPath, &fileStat))) {
- const char *path = getenv("PATH");
- if (!path)
- return 1;
-@@ -222,7 +224,7 @@
- char *token = strtok(pathdup, ":");
- while (token) {
- sprintf(tmpPath, "%s/%s", token, argv[0]);
-- if (realpath(tmpPath, iniPath) && stat(iniPath, &fileStat) == 0) {
-+ if (realpath(tmpPath, iniPath) && stat(iniPath, &fileStat) == 0 && S_ISREG(fileStat.st_mode) && fileStat.st_mode & S_IXUSR) {
- found = PR_TRUE;
- break;
- }