summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-25 14:31:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-25 14:34:58 +0000
commit5862a42ac007cb6a8778d511a074f421a88dd993 (patch)
tree0c342d0cac7c7dfb2a5ba2ccd8ad97f8b1a21794 /main/xulrunner
parent986f52de429afaf6b1dca4b476c7b9038bccffc7 (diff)
downloadaports-5862a42ac007cb6a8778d511a074f421a88dd993.tar.bz2
aports-5862a42ac007cb6a8778d511a074f421a88dd993.tar.xz
main/xulrunner: upgrade to 18.0.1
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/APKBUILD10
-rw-r--r--main/xulrunner/mallctl.patch28
-rw-r--r--main/xulrunner/mozconfig1
3 files changed, 35 insertions, 4 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index 9f35d1fef..4c09d3c28 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xulrunner
-pkgver=17.0.1
+pkgver=18.0.1
_ffoxver=$pkgver
pkgrel=0
pkgdesc="runtime environment for xul-based applications"
@@ -56,6 +56,7 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
cairo.patch
getchar.patch
sysconf.patch
+ mallctl.patch
"
# help our shared-object scanner to find the libs
ldpath="/usr/lib/xulrunner-$pkgver"
@@ -116,11 +117,12 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="13d616028eb77de927c29b6655c832c9 firefox-17.0.1.source.tar.bz2
-36d8d42ae4375f1190c9558bb0d10fa7 mozconfig
+md5sums="8b400555fc7063163e3b99472d0c92a1 firefox-18.0.1.source.tar.bz2
+300ee7803d9426dc3c91e08830e73e23 mozconfig
f43c1f0ae57aa8289b130c6de8caf3ce 0002-Use-C99-math-isfinite.patch
e8b3a22d670241bb5c038729ac49a975 0003-xulrunner-jemalloc-aslr.patch
998b48fe73dc642065ab25230d739b2c uclibc-malloc_usable_size.patch
6a3942d96c7ce3c63251761cc12c8349 cairo.patch
a7b33d8b75306f225e3a8d1a8a403736 getchar.patch
-090ea4daeedfff2915da62a738c7e81d sysconf.patch"
+090ea4daeedfff2915da62a738c7e81d sysconf.patch
+2a8cb2d3065f4475ea463f8498ea2324 mallctl.patch"
diff --git a/main/xulrunner/mallctl.patch b/main/xulrunner/mallctl.patch
new file mode 100644
index 000000000..7c56f584e
--- /dev/null
+++ b/main/xulrunner/mallctl.patch
@@ -0,0 +1,28 @@
+https://bugzilla.mozilla.org/show_bug.cgi?id=815681
+
+diff --git a/xpcom/base/AvailableMemoryTracker.cpp b/xpcom/base/AvailableMemoryTracker.cpp
+index 69af67d..ef98fec 100644
+--- a/xpcom/base/AvailableMemoryTracker.cpp
++++ b/xpcom/base/AvailableMemoryTracker.cpp
+@@ -26,9 +26,7 @@
+ # include <windows.h>
+ #endif
+
+-#if defined(MOZ_MEMORY)
+ # include "jemalloc.h"
+-#endif // MOZ_MEMORY
+
+ using namespace mozilla;
+
+@@ -498,11 +496,7 @@ nsJemallocFreeDirtyPagesRunnable::Run()
+ {
+ MOZ_ASSERT(NS_IsMainThread());
+
+-#if defined(MOZ_JEMALLOC)
+- mallctl("arenas.purge", nullptr, 0, nullptr, 0);
+-#elif defined(MOZ_MEMORY)
+ jemalloc_free_dirty_pages();
+-#endif
+
+ return NS_OK;
+ }
diff --git a/main/xulrunner/mozconfig b/main/xulrunner/mozconfig
index 8c601d397..a6141fa60 100644
--- a/main/xulrunner/mozconfig
+++ b/main/xulrunner/mozconfig
@@ -10,6 +10,7 @@ ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --with-system-pixman
+ac_add_options --enable-system-pixman
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-cairo