summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-25 08:35:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-25 08:35:28 +0000
commit6d5ee10f7b60baccb08e8b9a985635207693198c (patch)
tree4206fc246f3d70d4f49fcbbe272baf2caaa22bb6 /main/xulrunner
parenta261cb29c4aef6f54b906b2d6705da455511333f (diff)
downloadaports-6d5ee10f7b60baccb08e8b9a985635207693198c.tar.bz2
aports-6d5ee10f7b60baccb08e8b9a985635207693198c.tar.xz
main/xulrunner: upgrade to 12.0
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/APKBUILD8
-rw-r--r--main/xulrunner/cairo.patch35
2 files changed, 40 insertions, 3 deletions
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index a186a9610..a0f60bf82 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
-pkgver=11.0
+pkgver=12.0
_ffoxver=$pkgver
pkgrel=0
pkgdesc="runtime environment for xul-based applications"
@@ -50,6 +50,7 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
0003-xulrunner-jemalloc-aslr.patch
0004-xulrunner-malloc_usable_size.patch
ff9-aslr-fix.patch
+ cairo.patch
"
_builddir="${srcdir}/mozilla-release"
@@ -104,9 +105,10 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="4b07acf47857aff72776d805409cdd1b firefox-11.0.source.tar.bz2
+md5sums="80c3e5927274de7f181fb5f931ac5fd4 firefox-12.0.source.tar.bz2
b0f7d491bc800b69ec718667a4b08acb mozconfig
1867db217d10722675c88b655db8c2d7 0002-Use-C99-math-isfinite.patch
7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
d12e0636e1f9877ef2d1df45d5834c87 0004-xulrunner-malloc_usable_size.patch
-96b40acd003a0a586e408bf09ae5af1d ff9-aslr-fix.patch"
+96b40acd003a0a586e408bf09ae5af1d ff9-aslr-fix.patch
+6a3942d96c7ce3c63251761cc12c8349 cairo.patch"
diff --git a/main/xulrunner/cairo.patch b/main/xulrunner/cairo.patch
new file mode 100644
index 000000000..19ba1ef8e
--- /dev/null
+++ b/main/xulrunner/cairo.patch
@@ -0,0 +1,35 @@
+--- firefox/gfx/thebes/gfxPlatform.cpp~ 2012-02-07 11:59:39.717184907 +0000
++++ firefox/gfx/thebes/gfxPlatform.cpp 2012-02-07 13:06:01.084668445 +0000
+@@ -446,6 +446,7 @@
+ static_cast<SourceSurface*>(srcBuffer)->Release();
+ }
+
++#ifdef MOZ_TREE_CAIRO
+ void SourceSnapshotDetached(cairo_surface_t *nullSurf)
+ {
+ gfxImageSurface* origSurf =
+@@ -453,6 +454,7 @@
+
+ origSurf->SetData(&kSourceSurface, NULL, NULL);
+ }
++#endif
+
+ RefPtr<SourceSurface>
+ gfxPlatform::GetSourceSurfaceForSurface(DrawTarget *aTarget, gfxASurface *aSurface)
+@@ -522,6 +524,7 @@
+ imgSurface->Stride(),
+ format);
+
++ #ifdef MOZ_TREE_CAIRO
+ cairo_surface_t *nullSurf =
+ cairo_null_surface_create(CAIRO_CONTENT_COLOR_ALPHA);
+ cairo_surface_set_user_data(nullSurf,
+@@ -530,6 +533,7 @@
+ NULL);
+ cairo_surface_attach_snapshot(imgSurface->CairoSurface(), nullSurf, SourceSnapshotDetached);
+ cairo_surface_destroy(nullSurf);
++ #endif
+ }
+
+ srcBuffer->AddRef();
+