summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-02-17 12:51:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-02-17 13:03:02 +0000
commit8d4950d3742f84d53b12cff41b90328d7dccc216 (patch)
treed57abd0f68d28c7d3849434fc2c5f153cada3ae0 /main
parent13e35e6d83e9638789e7fb6fd3f5193de627f719 (diff)
downloadaports-8d4950d3742f84d53b12cff41b90328d7dccc216.tar.bz2
aports-8d4950d3742f84d53b12cff41b90328d7dccc216.tar.xz
main/sox: upgrade to 14.4.1
Diffstat (limited to 'main')
-rw-r--r--main/sox/APKBUILD12
-rw-r--r--main/sox/sox-uclibc.patch22
2 files changed, 18 insertions, 16 deletions
diff --git a/main/sox/APKBUILD b/main/sox/APKBUILD
index 58744e502..5822e611a 100644
--- a/main/sox/APKBUILD
+++ b/main/sox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sox
-pkgver=14.4.0
-pkgrel=2
+pkgver=14.4.1
+pkgrel=0
pkgdesc="The Swiss Army knife of sound processing tools"
url="http://sox.sourceforge.net/"
arch="all"
@@ -43,5 +43,9 @@ package() {
"$pkgdir"/usr/lib/sox/*.la \
|| return 1
}
-md5sums="b0c15cff7a4ba0ec17fdc74e6a1f9cf1 sox-14.4.0.tar.gz
-d8267f718ba6b4fb2f48c5104af31364 sox-uclibc.patch"
+md5sums="670307f40763490a2bc0d1f322071e7a sox-14.4.1.tar.gz
+b734d72321470f9aaf44464878b1d12f sox-uclibc.patch"
+sha256sums="9a8c2c6fe51e608da346a157e111508a957af9e3ecf3de26781d36e9a67fa89b sox-14.4.1.tar.gz
+0d1447942cf64b0307baa7a16f0a91f553597be187d5c94eadc56d180615717d sox-uclibc.patch"
+sha512sums="a35c0f424ffaa51d06291e69b28ae7f2248a750fa8aded911dcd7e123877ecb5142c292f943eb723142c50dbd890b58163c6ef24c9c0573377855fad1b36fb25 sox-14.4.1.tar.gz
+08c55a0de96733e10544d450f39c2205b4057b9fc024503ec97b1906a075752ee8a4b0a1b4c5bbad2eebec17bcf8d069b22d243a63d28b77c23d545efcca6aec sox-uclibc.patch"
diff --git a/main/sox/sox-uclibc.patch b/main/sox/sox-uclibc.patch
index fb78cd096..5f4ed4abb 100644
--- a/main/sox/sox-uclibc.patch
+++ b/main/sox/sox-uclibc.patch
@@ -1,22 +1,20 @@
-diff --git a/src/formats.c b/src/formats.c
-index 556f611..6c2c5b0 100644
---- a/src/formats.c
-+++ b/src/formats.c
-@@ -395,7 +395,7 @@ static void UNUSED rewind_pipe(FILE * fp)
- #if defined _NEWLIB_VERSION || defined __APPLE__
- fp->_p -= AUTO_DETECT_SIZE;
- fp->_r += AUTO_DETECT_SIZE;
+--- ./src/formats.c.orig 2013-02-17 12:19:38.318344596 +0000
++++ ./src/formats.c 2013-02-17 12:50:31.560549872 +0000
+@@ -409,7 +409,7 @@
+ #if defined _FSTDIO || defined _NEWLIB_VERSION || defined __APPLE__
+ fp->_p -= PIPE_AUTO_DETECT_SIZE;
+ fp->_r += PIPE_AUTO_DETECT_SIZE;
-#elif defined __GLIBC__
+#elif defined __GLIBC__ && ! defined __UCLIBC__
fp->_IO_read_ptr = fp->_IO_read_base;
- #elif defined _MSC_VER || defined __MINGW_H || defined _ISO_STDIO_ISO_H
+ #elif defined _MSC_VER || defined _WIN32 || defined _WIN64 || defined _ISO_STDIO_ISO_H
fp->_ptr = fp->_base;
-@@ -403,7 +403,7 @@ static void UNUSED rewind_pipe(FILE * fp)
+@@ -417,7 +417,7 @@
/* To fix this #error, either simply remove the #error line and live without
* file-type detection with pipes, or add support for your compiler in the
- * lines above. Test with cat monkey.au | ./sox --info - */
+ * lines above. Test with cat monkey.wav | ./sox --info - */
- #error FIX NEEDED HERE
-+/* #error FIX NEEDED HERE */
++// #error FIX NEEDED HERE
#define NO_REWIND_PIPE
(void)fp;
#endif