summaryrefslogtreecommitdiffstats
path: root/testing/bsm-simple-themes/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-02-07 08:25:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-02-07 08:25:01 +0000
commit3797d2f0e98272cd984cd38a62cf8847b91cf4bd (patch)
treed01e85452b5d35724cf1f7d83b44aa1ae63c4272 /testing/bsm-simple-themes/APKBUILD
parentda93de541cf49144e45eda8b386c0d42435afa75 (diff)
downloadaports-3797d2f0e98272cd984cd38a62cf8847b91cf4bd.tar.bz2
aports-3797d2f0e98272cd984cd38a62cf8847b91cf4bd.tar.xz
testing/bsm-simple-themes: new aport
BSM Simple GTK Themes http://gnome-look.org/content/show.php/?content=121685
Diffstat (limited to 'testing/bsm-simple-themes/APKBUILD')
-rw-r--r--testing/bsm-simple-themes/APKBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/testing/bsm-simple-themes/APKBUILD b/testing/bsm-simple-themes/APKBUILD
new file mode 100644
index 000000000..67c7aa223
--- /dev/null
+++ b/testing/bsm-simple-themes/APKBUILD
@@ -0,0 +1,63 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bsm-simple-themes
+pkgver=1.3
+_ver=${pkgver/./}
+pkgrel=0
+pkgdesc="BSM Simple GTK Themes"
+url="http://gnome-look.org/content/show.php/?content=121685"
+arch="noarch"
+license="GPL"
+depends="gtk-engines-clearlooks faenza-icon-theme"
+makedepends=""
+install=""
+subpackages="$pkgname-xfwm4 $pkgname-metacity"
+source="http://gnome-look.org/CONTENT/content-files/121685-BSM%20Simple%20$_ver.tar.gz
+ bsm-simple-panel.patch"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/themes
+ for i in *; do
+ [ -L "$i" ] && continue
+ cp -ra "$i" "$pkgdir"/usr/share/themes/ || return 1
+ done
+}
+
+xfwm4() {
+ pkgdesc="BSM Simple GTK Themes - xfwm4"
+ install_if="$pkgname=$pkgver-r$pkgrel xfwm4"
+ cd "$pkgdir"
+ find -name 'xfwm4' -type d | while read dir; do
+ mkdir -p "$subpkgdir/${dir%/*}"
+ mv "$dir" "$subpkgdir/${dir%*}"
+ done
+}
+
+metacity() {
+ pkgdesc="BSM Simple GTK Themes - metacity"
+ install_if="$pkgname=$pkgver-r$pkgrel xfwm4"
+ cd "$pkgdir"
+ find -name 'metacity-?' -type d | while read dir; do
+ mkdir -p "$subpkgdir/${dir%/*}"
+ mv "$dir" "$subpkgdir/${dir%*}"
+ done
+}
+
+md5sums="26ba7fd532b8811e77a041ce8bacf79f 121685-BSM%20Simple%2013.tar.gz
+397bb9e05136048d64f5c4e629434245 bsm-simple-panel.patch"