summaryrefslogtreecommitdiffstats
path: root/testing/inotify-tools
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-01-05 13:47:49 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-01-05 13:50:24 +0000
commit1e43dab33007dd7d31c32b63450edd194a23ba45 (patch)
tree3bde71cbb7b4d6fb80edbfead1b32b4fd7e03116 /testing/inotify-tools
parent9bf71cfe5752e1bf683164d1420cba9cfa51cd90 (diff)
downloadaports-1e43dab33007dd7d31c32b63450edd194a23ba45.tar.bz2
aports-1e43dab33007dd7d31c32b63450edd194a23ba45.tar.xz
testing/inotify-tools: new aport
C library and CLI tools for interfacing to kernel inotify()
Diffstat (limited to 'testing/inotify-tools')
-rw-r--r--testing/inotify-tools/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/inotify-tools/APKBUILD b/testing/inotify-tools/APKBUILD
new file mode 100644
index 000000000..1aeee5812
--- /dev/null
+++ b/testing/inotify-tools/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname="inotify-tools"
+pkgver=3.14
+pkgrel=0
+pkgdesc="C library and CLI tools providing a simple interface to inotify"
+url="http://github.com/rvoicilas/inotify-tools"
+arch="x86 x86_64"
+license="GPL"
+depends=
+makedepends="wget"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/downloads/rvoicilas/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b43d95a0fa8c45f8bab3aec9672cf30c inotify-tools-3.14.tar.gz"