summaryrefslogtreecommitdiffstats
path: root/testing/lua-llthreads
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:26:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:46:50 +0000
commit8f96791a241d35dfe509dbdf21490d57ed391886 (patch)
treedc717c6dd38aa9fdc89ae950f23828ab6d861ea8 /testing/lua-llthreads
parent0c2c1652b2e5d74ea61ffdf6eb91325ee9f2093e (diff)
downloadaports-8f96791a241d35dfe509dbdf21490d57ed391886.tar.bz2
aports-8f96791a241d35dfe509dbdf21490d57ed391886.tar.xz
testing/lua-llthreads: new aport
Low-Level native threads module for Lua https://github.com/Neopallium/lua-llthreads
Diffstat (limited to 'testing/lua-llthreads')
-rw-r--r--testing/lua-llthreads/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/lua-llthreads/APKBUILD b/testing/lua-llthreads/APKBUILD
new file mode 100644
index 000000000..b27581503
--- /dev/null
+++ b/testing/lua-llthreads/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-llthreads
+pkgver=1.1
+pkgrel=0
+pkgdesc="Low-Level native threads module for Lua"
+url="https://github.com/Neopallium/lua-llthreads"
+arch="all"
+license="MIT"
+depends=""
+makedepends="wget cmake"
+install=""
+subpackages=
+source="saveas-http://github.com/Neopallium/lua-llthreads/tarball/v1.1/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Neopallium-lua-llthreads-48c39a5
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="f5c80984e7d8849ad777b42c4594da8d lua-llthreads-1.1.tar.gz"